summaryrefslogtreecommitdiff
path: root/graphics/cqcam/files
diff options
context:
space:
mode:
authorAlexander Langer <alex@FreeBSD.org>2000-07-14 12:46:30 +0000
committerAlexander Langer <alex@FreeBSD.org>2000-07-14 12:46:30 +0000
commit69718a50108a517de5ec5d765bfb5d56e3568eb8 (patch)
tree0d0862b7715877c844fe2b8caca2d6976d3bbd2c /graphics/cqcam/files
parentUpdate port to 1.2 (diff)
Update to version 0.90p9.
With this version, it is no longer only a frame grabber, but a whole control program. Thus, adjust COMMENT/DESCR. As a bonus, it should fix bento build. PR: 19824 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp>
Diffstat (limited to 'graphics/cqcam/files')
-rw-r--r--graphics/cqcam/files/patch-ab50
-rw-r--r--graphics/cqcam/files/patch-ac22
-rw-r--r--graphics/cqcam/files/patch-ad10
-rw-r--r--graphics/cqcam/files/patch-ae10
4 files changed, 92 insertions, 0 deletions
diff --git a/graphics/cqcam/files/patch-ab b/graphics/cqcam/files/patch-ab
new file mode 100644
index 000000000000..5be7b04c5112
--- /dev/null
+++ b/graphics/cqcam/files/patch-ab
@@ -0,0 +1,50 @@
+--- configure.orig Mon Feb 1 16:01:12 1999
++++ configure Mon Mar 13 03:54:42 2000
+@@ -1108,8 +1108,8 @@
+ echo "configure:1109: checking if the compiler understands -pipe" >&5
+ OLDCC="$CC"
+ OLDCXX="$CXX"
+- CC="$CC -pipe"
+- CXX="$CXX -pipe"
++ CC="$CC"
++ CXX="$CXX"
+ cat > conftest.$ac_ext <<EOF
+ #line 1115 "configure"
+ #include "confdefs.h"
+@@ -1655,7 +1655,7 @@
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+-LIBS="-lgtk `$gtkbin""gtk-config --libs` $LIBS"
++LIBS="`$gtkbin""$GTK_CONFIG --libs` $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 1661 "configure"
+ #include "confdefs.h"
+@@ -1694,7 +1694,7 @@
+
+ echo $ac_n "checking GTK+ version""... $ac_c" 1>&6
+ echo "configure:1697: checking GTK+ version" >&5
+- GTKV=`$gtkbin""gtk-config --version`
++ GTKV=`$gtkbin""$GTK_CONFIG --version`
+ echo "$ac_t""$GTKV" 1>&6
+ case "$GTKV" in
+ 1.0.*)
+@@ -1890,8 +1890,8 @@
+ OS_LIBCQCAM_OBJS=''
+ ;;
+ freebsd*)
+- OS_CFLAGS='-O2 -I/usr/local/include -DFREEBSD'
+- OS_LDFLAGS='-L/usr/local/lib'
++ OS_CFLAGS="$CXXFLAGS $CPPFLAGS -DFREEBSD"
++ OS_LDFLAGS="$LDFLAGS"
+ OS_LIBCQCAM_OBJS=''
+ ;;
+ bsdi*)
+@@ -2124,6 +2124,7 @@
+ s%@x_includes@%$x_includes%g
+ s%@bingroup@%$bingroup%g
+ s%@gtkbin@%$gtkbin%g
++s%@GTK_CONFIG@%$GTK_CONFIG%g
+ s%@GTK_CFLAGS@%$GTK_CFLAGS%g
+ s%@xviewlib@%$xviewlib%g
+
diff --git a/graphics/cqcam/files/patch-ac b/graphics/cqcam/files/patch-ac
new file mode 100644
index 000000000000..a4b9b4323c22
--- /dev/null
+++ b/graphics/cqcam/files/patch-ac
@@ -0,0 +1,22 @@
+--- gtkfe/Makefile.in.orig Mon Feb 1 14:25:32 1999
++++ gtkfe/Makefile.in Mon Mar 13 03:39:35 2000
+@@ -3,8 +3,8 @@
+ bindir = @bindir@
+ CC = @CC@
+ CXX = @CXX@
+-CFLAGS = -Wall @DEBUGFLAGS@ @OS_CFLAGS@ @GTK_CFLAGS@ @JPEG_CFLAGS@ `@gtkbin@gtk-config --cflags`
+-CXXFLAGS = -Wall @DEBUGFLAGS@ @OS_CFLAGS@ @GTK_CFLAGS@ @JPEG_CFLAGS@ @LOCKING@ -I../libcqcam `@gtkbin@gtk-config --cflags`
++CFLAGS = -Wall @DEBUGFLAGS@ @OS_CFLAGS@ @GTK_CFLAGS@ @JPEG_CFLAGS@ `@gtkbin@@GTK_CONFIG@ --cflags`
++CXXFLAGS = -Wall @DEBUGFLAGS@ @OS_CFLAGS@ @GTK_CFLAGS@ @JPEG_CFLAGS@ @LOCKING@ -I../libcqcam `@gtkbin@@GTK_CONFIG@ --cflags`
+ LDFLAGS = @OS_LDFLAGS@ -L../libcqcam
+ LIBS = -lcqcam @JPEG_LIBS@ @OS_LIBS@
+ INSTALL = @INSTALL@
+@@ -19,7 +19,7 @@
+ rm -f *.o core $(PROGRAMS)
+
+ gtkcam: $(OBJS) $(LIBCQCAM)
+- $(CXX) -o $@ $(OBJS) `@gtkbin@gtk-config --libs` $(LDFLAGS) $(LIBS)
++ $(CXX) -o $@ $(OBJS) `@gtkbin@@GTK_CONFIG@ --libs` $(LDFLAGS) $(LIBS)
+
+ bininstall:
+ $(INSTALL) -o root -g @bingroup@ -m 4711 $(PROGRAMS) $(bindir)
diff --git a/graphics/cqcam/files/patch-ad b/graphics/cqcam/files/patch-ad
new file mode 100644
index 000000000000..067456db16e6
--- /dev/null
+++ b/graphics/cqcam/files/patch-ad
@@ -0,0 +1,10 @@
+--- libcqcam/camera.C.orig Tue Apr 20 06:33:10 1999
++++ libcqcam/camera.C Sat Jul 8 11:51:06 2000
+@@ -18,7 +18,6 @@
+ */
+
+ #include <stdio.h>
+-#include <string.h>
+ #include <unistd.h>
+
+ #include "config.h"
diff --git a/graphics/cqcam/files/patch-ae b/graphics/cqcam/files/patch-ae
new file mode 100644
index 000000000000..2fe5f9a7f7c8
--- /dev/null
+++ b/graphics/cqcam/files/patch-ae
@@ -0,0 +1,10 @@
+--- xfe/xscan.C.orig Wed Apr 26 16:16:35 2000
++++ xfe/xscan.C Sat Jul 8 11:50:32 2000
+@@ -29,7 +29,6 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
+-#include <string.h>
+ #include <signal.h>
+ #include <sys/time.h>
+ #include <sys/stat.h>