summaryrefslogtreecommitdiff
path: root/graphics/cqcam/Makefile
diff options
context:
space:
mode:
authorAlexander Langer <alex@FreeBSD.org>2000-07-14 12:46:30 +0000
committerAlexander Langer <alex@FreeBSD.org>2000-07-14 12:46:30 +0000
commit69718a50108a517de5ec5d765bfb5d56e3568eb8 (patch)
tree0d0862b7715877c844fe2b8caca2d6976d3bbd2c /graphics/cqcam/Makefile
parentUpdate port to 1.2 (diff)
Update to version 0.90p9.
With this version, it is no longer only a frame grabber, but a whole control program. Thus, adjust COMMENT/DESCR. As a bonus, it should fix bento build. PR: 19824 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp>
Diffstat (limited to '')
-rw-r--r--graphics/cqcam/Makefile38
1 files changed, 34 insertions, 4 deletions
diff --git a/graphics/cqcam/Makefile b/graphics/cqcam/Makefile
index 3322db0beacf..a0d8322fdaac 100644
--- a/graphics/cqcam/Makefile
+++ b/graphics/cqcam/Makefile
@@ -6,20 +6,50 @@
#
PORTNAME= cqcam
-PORTVERSION= 0.45a
-CATEGORIES= graphics tk82
-MASTER_SITES= ftp://ftp.freesoftware.com/pub/unixfreeware/graphics/
+PORTVERSION= 0.90p9
+CATEGORIES= graphics
+MASTER_SITES= http://www.cs.duke.edu/~reynolds/cqcam/
+DISTNAME= ${PORTNAME}-0.90pre9
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= tk82.1:${PORTSDIR}/x11-toolkits/tk82 \
+LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
jpeg.9:${PORTSDIR}/graphics/jpeg
ONLY_FOR_ARCHS= i386
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+
+USE_XLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -pedantic" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --disable-asm
+INSTALL_TARGET= bininstall
+
MAN1= cqcam.1
MLINKS= cqcam.1 webcam.1 \
cqcam.1 xcqcam.1
+CQCAM_DOCS= README docs/APINOTES docs/CHANGES docs/README.webcam \
+ docs/refresh.html docs/webcam.html
+
+post-install:
+.for file in cqcam gtkcam webcam xcqcam
+ @strip ${PREFIX}/bin/${file}
+.endfor
+ ${INSTALL_MAN} ${WRKSRC}/docs/cqcam.1 ${PREFIX}/man/man1
+ @${MKDIR} ${PREFIX}/share/examples/cqcam
+ ${INSTALL_DATA} ${WRKSRC}/.cqcrc ${PREFIX}/share/examples/cqcam/sample.cqcrc
+ ${INSTALL_DATA} ${WRKSRC}/webcam/nph-webcam ${PREFIX}/share/examples/cqcam/sample.nph-webcam
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/cqcam
+.for file in ${CQCAM_DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/cqcam
+.endfor
+.endif
+ @${CAT} ${PKGMESSAGE}
+
.include <bsd.port.mk>