summaryrefslogtreecommitdiff
path: root/graphics/compupic/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-04-05 09:22:40 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-04-05 09:22:40 +0000
commit92908c7190d8cd337361a7b983e6c111f331245b (patch)
tree61caf527670acb0937e21c414b13943870fbfbcc /graphics/compupic/Makefile
parentallow build with more warnings enabled, NO_WERROR=yes (diff)
CompuPic 5.1.1016
CompuPic 5.1.1016 - Digital Content Manager PR: ports/35919 Submitted by: Abel Chow <abel@island.dhs.org>
Diffstat (limited to 'graphics/compupic/Makefile')
-rw-r--r--graphics/compupic/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/graphics/compupic/Makefile b/graphics/compupic/Makefile
new file mode 100644
index 000000000000..a19096ffd3c0
--- /dev/null
+++ b/graphics/compupic/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: compupic
+# Date created: Thu Mar 14 22:40:58 PST 2002
+# Whom: Abel Chow <ozsanh45vds001@sneakemail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= compupic
+PORTVERSION= 5.1.1063
+CATEGORIES= graphics
+MASTER_SITES= http://www.photodex.com/files.system/unix/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-i386-freebsd
+EXTRACT_ONLY= # extracted directly in install target
+
+MAINTAINER= abel@island.dhs.org
+COMMENT= Digital content manager
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+ONLY_FOR_ARCHS= i386
+
+MAN1= compupic.1
+
+do-install:
+ ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/${DISTNAME}.tar.gz \
+ ${EXTRACT_AFTER_ARGS} -C ${PREFIX}
+ ${RM} -f ${PREFIX}/bin/compupic
+ ${LN} -sf ${PREFIX}/compupic/compupic ${PREFIX}/bin/compupic
+ ${INSTALL_MAN} ${PREFIX}/compupic/compupic.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>