summaryrefslogtreecommitdiff
path: root/graphics/batik/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-12-09 10:29:50 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-12-09 10:29:50 +0000
commitf0c072ed9a7aa22e716d1af5b08c79700532619b (patch)
treec305f5a4426dec211b00a7881d3eb849efefed88 /graphics/batik/Makefile
parentHandle includes properly. (diff)
BROKEN: Does not compile on 4.x
Diffstat (limited to '')
-rw-r--r--graphics/batik/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/graphics/batik/Makefile b/graphics/batik/Makefile
index e855a1b30aa6..c6108c4cc4f6 100644
--- a/graphics/batik/Makefile
+++ b/graphics/batik/Makefile
@@ -30,6 +30,12 @@ BATIK_HOME= ${PREFIX}/batik
ANT_ALL_TARGET+= html
.endif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on 4.x"
+.endif
+
do-build:
@cd ${WRKSRC} && ${ANT} ${ANT_ALL_TARGET}
@@ -41,4 +47,4 @@ do-install:
@${FIND} ${BATIK_HOME} -type d | ${SORT} -r | \
${SED} -e "s,^${PREFIX}/,@dirrm ," >> ${TMPPLIST}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>