summaryrefslogtreecommitdiff
path: root/graphics/aqsis/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-13 07:50:12 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-13 07:50:12 +0000
commit63a379db28c83fdffe263edb39b3cf250445087c (patch)
treec56fbfa0fb2c5a05f57435ada50083271b5ca64d /graphics/aqsis/Makefile
parentUpdate to version 2.21 (diff)
add aqsis 0.6.6
A photorealistic rendering system
Diffstat (limited to 'graphics/aqsis/Makefile')
-rw-r--r--graphics/aqsis/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/graphics/aqsis/Makefile b/graphics/aqsis/Makefile
new file mode 100644
index 000000000000..bcf97068f7d1
--- /dev/null
+++ b/graphics/aqsis/Makefile
@@ -0,0 +1,32 @@
+# ex:ts=8
+# Ports collection Makefile for: aqsis
+# Date created: Sep 12, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= aqsis
+PORTVERSION= 0.6.6
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= tiff:${PORTSDIR}/graphics/tiff \
+ argparse:${PORTSDIR}/devel/libargparse
+
+USE_REINPLACE= yes
+USE_MESA= yes
+USE_LIBTOOL= yes
+CONFIGURE_ENV= \
+ CPPFLAGS="${CXXFLAGS} ${PTHREAD_CFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="${PTHREAD_LIBS} -L${LOCALBASE}/lib -L${X11BASE}/lib"
+INSTALLS_SHLIB= yes
+
+post-patch:
+ @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} \
+ -e "s|-ldl||g"
+
+.include <bsd.port.mk>