summaryrefslogtreecommitdiff
path: root/graphics/GraphicsMagick13
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2007-07-16 18:30:28 +0000
committerStanislav Sedov <stas@FreeBSD.org>2007-07-16 18:30:28 +0000
commitb5f66dee8ed357e3178c5d55fdbd1d1b75f38968 (patch)
tree78c41a394ba86bdd3f60b4a24bf05a68d1e5038c /graphics/GraphicsMagick13
parentSet default EMACS_PORT_NAME to emacs22. (diff)
- Do not redefine GraphicsMagick symbols, since it causes problems with
some ports, that expect standard Magick symbols to be present (that is revert revision 1.6). Redefine only the GetToken symbol instead just to get rid of ports/94905 - Use correct path for windows fonts [1] - Add a knob to depend on windows fonts conditionally. PR: ports/114036 [1] Submitted by: Roderick van Domburg <r.s.a.vandomburg@nedforce.nl>
Diffstat (limited to 'graphics/GraphicsMagick13')
-rw-r--r--graphics/GraphicsMagick13/Makefile13
-rw-r--r--graphics/GraphicsMagick13/files/patch-magick_symbols.h19
2 files changed, 27 insertions, 5 deletions
diff --git a/graphics/GraphicsMagick13/Makefile b/graphics/GraphicsMagick13/Makefile
index a68cce2bad11..d58e5c521e30 100644
--- a/graphics/GraphicsMagick13/Makefile
+++ b/graphics/GraphicsMagick13/Makefile
@@ -7,7 +7,7 @@
PORTNAME= GraphicsMagick
PORTVERSION= 1.1.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ftp.graphicsmagick.org/pub/GraphicsMagick/
@@ -42,15 +42,18 @@ MAN5= quantize.5
.ifndef WINDOWS_FONT_DIR
# Use fonts installed by x11-fonts/webfonts by default
-WINDOWS_FONT_DIR=${X11BASE}/lib/X11/webfonts
+WINDOWS_FONT_DIR=${X11BASE}/lib/X11/fonts/webfonts
.endif
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --without-perl --with-windows-font-dir=${WINDOWS_FONT_DIR} \
- --enable-shared --enable-static --without-threads \
- --enable-symbol-prefix
+CONFIGURE_ARGS= --without-perl --enable-shared --enable-static \
+ --without-threads
USE_LDCONFIG= yes
+.if defined(WITH_WINDOWS_FONT_DIR)
+CONFIGURE_ARGS+= --with-windows-font-dir="${WINDOWS_FONT_DIR}"
+.endif
+
.if !defined(NOPORTDOCS)
INSTALL_TARGET= install install-data-html
.endif
diff --git a/graphics/GraphicsMagick13/files/patch-magick_symbols.h b/graphics/GraphicsMagick13/files/patch-magick_symbols.h
new file mode 100644
index 000000000000..8edb9976ad45
--- /dev/null
+++ b/graphics/GraphicsMagick13/files/patch-magick_symbols.h
@@ -0,0 +1,19 @@
+--- magick/symbols.h.orig Mon Jul 16 21:55:06 2007
++++ magick/symbols.h Mon Jul 16 21:56:04 2007
+@@ -17,6 +17,8 @@
+ #if !defined(_MAGICK_SYMBOLS_H)
+ #define _MAGICK_SYMBOLS_H
+
++#define GetToken GmGetToken
++
+ #if defined(PREFIX_MAGICK_SYMBOLS)
+ #define AccessDefinition GmAccessDefinition
+ #define AcquireCacheNexus GmAcquireCacheNexus
+@@ -386,7 +388,6 @@
+ #define GetQuantizeInfo GmGetQuantizeInfo
+ #define GetSignatureInfo GmGetSignatureInfo
+ #define GetTimerInfo GmGetTimerInfo
+-#define GetToken GmGetToken
+ #define GetTypeInfo GmGetTypeInfo
+ #define GetTypeInfoByFamily GmGetTypeInfoByFamily
+ #define GetTypeList GmGetTypeList