summaryrefslogtreecommitdiff
path: root/graphics/Coin/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-03-31 09:28:08 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-03-31 09:28:08 +0000
commita1d8b80f8103fceee9c0ca53c5b348e696755055 (patch)
tree031ecffa6f3b0d9603d1a6f92a108272595fbcc7 /graphics/Coin/Makefile
parent* Update exim-4.12 -> exim-4.14: (diff)
Update port devel/Coin to the latest and greatest version 2.0.0.
PR: ports/49005 Submitted by: Roland Jesse <roland.jesse@gmx.net>
Diffstat (limited to 'graphics/Coin/Makefile')
-rw-r--r--graphics/Coin/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/graphics/Coin/Makefile b/graphics/Coin/Makefile
index cff8a67b0bde..ffb37be390f9 100644
--- a/graphics/Coin/Makefile
+++ b/graphics/Coin/Makefile
@@ -6,26 +6,30 @@
#
PORTNAME= Coin
-PORTVERSION= 1.0.3
+PORTVERSION= 2.0.0
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.coin3d.org/pub/coin/src/
MAINTAINER= roland.jesse@gmx.net
COMMENT= C++ 3D graphics library based on the Open Inventor 2.1 API
-LIB_DEPENDS= simage.22:${PORTSDIR}/graphics/simage
+LIB_DEPENDS= simage.22:${PORTSDIR}/graphics/simage \
+ openal.0:${PORTSDIR}/audio/openal
USE_REINPLACE= yes
USE_MESA= yes
USE_XLIB= yes
USE_LIBTOOL= yes
-CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" \
- LDFLAGS="${PTHREAD_LIBS}"
-CONFIGURE_ARGS= --program-transform-name="s/x/x/"
+CONFIGURE_ARGS= --program-transform-name="s/x/x/" --with-pthread=yes --enable-threadsafe --enable-3ds-import --enable-sound
INSTALLS_SHLIB= yes
MAN1= coin-config.1
+# Fixed in Coin's CVS but needed for the 2.0.0 release:
+pre-configure:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-ldl||g' ${WRKSRC}/configure
+
post-patch:
@${REINPLACE_CMD} -e 's|DATA install-data-local|DATA|g' ${WRKSRC}/Makefile.in