summaryrefslogtreecommitdiff
path: root/graphics/Cgraph/Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1998-12-24 07:10:15 +0000
committerSteve Price <steve@FreeBSD.org>1998-12-24 07:10:15 +0000
commite615b3dbed0e8a847a5d25b29db336dab9de4d4e (patch)
tree243a1baef8dc67a7671e65a451a2e5f7e70d3077 /graphics/Cgraph/Makefile
parentActivate the dcdflib port. (diff)
Initial import of Cgraph version 2.04.
A PostScript plotting library in C. PR: 8051 Submitted by: Anton Berezin <tobez@plab.ku.dk>
Diffstat (limited to 'graphics/Cgraph/Makefile')
-rw-r--r--graphics/Cgraph/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/graphics/Cgraph/Makefile b/graphics/Cgraph/Makefile
new file mode 100644
index 000000000000..1c44688a068f
--- /dev/null
+++ b/graphics/Cgraph/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: cgraph
+# Version required: 2.04
+# Date created: 25 September 1998
+# Whom: Anton Berezin <tobez@plab.ku.dk>
+#
+# $Id$
+#
+
+DISTNAME= Cgraph2.04
+PKGNAME= Cgraph-2.04
+CATEGORIES= graphics
+MASTER_SITES= ftp://pinoko.berkeley.edu/pub/software/
+
+MAINTAINER= tobez@plab.ku.dk
+
+WRKSRC= ${WRKDIR}/Cgraph/source
+
+.include <bsd.port.pre.mk>
+
+post-extract:
+ @${CP} ${FILESDIR}/Makefile.lib ${WRKSRC}/Makefile
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/cgraph
+ @${INSTALL_DATA} ${WRKSRC}/../docs/cgraph.ps ${PREFIX}/share/doc/cgraph
+.endif
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${PREFIX}/share/examples/cgraph
+ @${INSTALL_DATA} ${WRKSRC}/../examples/minimal/CGminimal.c ${PREFIX}/share/examples/cgraph
+ @${INSTALL_DATA} ${WRKSRC}/../examples/dash/dashlist.c ${PREFIX}/share/examples/cgraph
+ @${INSTALL_DATA} ${WRKSRC}/../examples/marker/markerlist.c ${PREFIX}/share/examples/cgraph
+ @${INSTALL_DATA} ${WRKSRC}/../examples/loglog/TFopt-lrLog.c ${PREFIX}/share/examples/cgraph
+ @${INSTALL_DATA} ${WRKSRC}/../examples/loglog/TFampspect.dat ${PREFIX}/share/examples/cgraph
+.endif
+.if ${PORTOBJFORMAT} == "aout"
+ @${LN} -sf libcgraph.so.2.4 ${PREFIX}/lib/libcgraph.so
+.endif
+ @${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
+
+.include <bsd.port.post.mk>