summaryrefslogtreecommitdiff
path: root/german/webalizer2/Makefile
diff options
context:
space:
mode:
authorAlexander Langer <alex@FreeBSD.org>2000-07-18 07:08:54 +0000
committerAlexander Langer <alex@FreeBSD.org>2000-07-18 07:08:54 +0000
commit05c510116bdebdcf864adc20d5fb33fe372a0ab8 (patch)
tree6ea4b43ffb5d3d8a50274a48d47ed35f3075eb07 /german/webalizer2/Makefile
parentMake erun depend on the new libepplet port rather than the epplets (diff)
Update to de-version 2.0.12 after repo-copy from german/webalizer by PW.
PR: 18891 Submitted by: Dirk Meyer <dirk.meyer@dinoex.sub.org>
Diffstat (limited to 'german/webalizer2/Makefile')
-rw-r--r--german/webalizer2/Makefile52
1 files changed, 31 insertions, 21 deletions
diff --git a/german/webalizer2/Makefile b/german/webalizer2/Makefile
index b9303d239ccd..772918ed9efb 100644
--- a/german/webalizer2/Makefile
+++ b/german/webalizer2/Makefile
@@ -1,58 +1,68 @@
-# New ports collection makefile for: webalizer
+# New ports collection makefile for: webalizer2
# Date created: 02.Jun 1998
# Whom: dirk.meyer@dinoex.sub.org
#
# $FreeBSD$
PORTNAME= webalizer
-PORTVERSION= 1.30.4
+PORTVERSION= 2.0.12
CATEGORIES= german www
-MASTER_SITES= ftp://ftp.mrunix.net/pub/webalizer/ \
- ftp://ftp.lan-ks.de/pub/approved/
-DISTNAME= webalizer-1.30-04-src
-EXTRACT_SUFX= .tgz
+MASTER_SITES= ftp://ftp.mrunix.net/pub/webalizer/pre-release/ \
+ ftp://ftp.lan-ks.de/pub/FreeBSD/distfiles/
+PKGNAMEPREFIX= de-
+DISTNAME= webalizer-2.00-12-src
MAINTAINER= dirk.meyer@dinoex.sub.org
-LIB_DEPENDS= gd.1:${PORTSDIR}/graphics/gd
+LIB_DEPENDS= gd.0:${PORTSDIR}/graphics/gd
+
+NO_LATEST_LINK= yes
WEBALIZER_LANG= german
+USE_BZIP2= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --with-gdlib=${PREFIX}/lib \
+CONFIGURE_ARGS+= --enable-dns \
+ --with-gdlib=${PREFIX}/lib \
--with-gd=${PREFIX}/include/gd \
--with-language=${WEBALIZER_LANG}
CONFIGURE_ENV+= LDFLAGS="-L${PREFIX}/lib"
-BIN1= de-webalizer
-MAN1= de-webalizer.1
+MAKE_ARGS+= CFLAGS="${CFLAGS}"
+MAN1= ${PKGNAMEPREFIX}webalizer.1
DOC1= CHANGES COPYING Copyright INSTALL \
- README country-codes.txt webalizer.LSM
+ README README.FIRST DNS.README country-codes.txt
WRKSRC= ${WRKDIR}/${DISTNAME:S/-src$//}
+PLIST_SUB+= PKGNAMEPREFIX=${PKGNAMEPREFIX}
pre-configure:
@${PERL5} -pi -e "s=/etc=${PREFIX}/etc=" ${WRKSRC}/webalizer.c
+ @${PERL5} -pi -e "s=webalizer.conf=${PKGNAMEPREFIX}webalizer.conf=" \
+ ${WRKSRC}/webalizer.c
do-install:
-.for i in ${BIN1}
- @${INSTALL_SCRIPT} ${WRKSRC}/webalizer ${PREFIX}/bin/${i}
-.endfor
+ @${INSTALL_PROGRAM} ${WRKSRC}/webalizer \
+ ${PREFIX}/bin/${PKGNAMEPREFIX}webalizer
+ ${LN} -sf ${PKGNAMEPREFIX}webalizer \
+ ${PREFIX}/bin/${PKGNAMEPREFIX}webazolver
post-install:
.for i in ${MAN1}
${INSTALL_MAN} ${WRKSRC}/webalizer.1 ${PREFIX}/man/man1/${i}
.endfor
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/de-webalizer
+ ${MKDIR} ${PREFIX}/share/doc/${PKGNAMEPREFIX}webalizer
.for i in ${DOC1}
- @${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/share/doc/de-webalizer/${i}
+ @${INSTALL_DATA} ${WRKSRC}/${i} \
+ ${PREFIX}/share/doc/${PKGNAMEPREFIX}webalizer/${i}
.endfor
.endif
- ${MKDIR} ${PREFIX}/share/examples/de-webalizer
-.for i in msfree.gif sample.conf webalizer.gif
- @${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/share/examples/de-webalizer/${i}
+ ${MKDIR} ${PREFIX}/share/examples/${PKGNAMEPREFIX}webalizer
+.for i in msfree.png sample.conf webalizer.png
+ @${INSTALL_DATA} ${WRKSRC}/${i} \
+ ${PREFIX}/share/examples/${PKGNAMEPREFIX}webalizer/${i}
.endfor
- @if [ ! -f ${PREFIX}/etc/de-webalizer.conf-dist ]; then \
+ @if [ ! -f ${PREFIX}/etc/${PKGNAMEPREFIX}webalizer.conf-dist ]; then \
${INSTALL_DATA} ${WRKSRC}/sample.conf \
- ${PREFIX}/etc/de-webalizer.conf-dist ; \
+ ${PREFIX}/etc/${PKGNAMEPREFIX}webalizer.conf-dist ; \
fi
.include <bsd.port.mk>