summaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-06-24 21:50:31 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-06-24 21:50:31 +0000
commit805a2895a25baa045f6796629b836182928c21d9 (patch)
treed3e8d42bfb6b6bd6e37ca0d56884cfbe03b5841f /games
parentForgot to 'cvs rm' this file to fix the apply patch. (diff)
Each player controls a team of several hedgehogs. During the course
of the game, players take turns with one of their hedgehogs. They then use whatever tools and weapons are available to attack and kill the opponents' hedgehogs, thereby winning the game. Hedgehogs may move around the terrain in a variety of ways, normally by walking and jumping but also by using particular tools such as the "Rope" or "Parachute", to move to otherwise inaccessible areas. Each turn is time-limited to ensure that players do not hold up the game with excessive thinking or moving. A large variety of tools and weapons are available for players during the game: Grenade, Cluster Bomb, Bazooka, UFO, Shotgun, Desert Eagle, Fire Punch, Baseball Bat, Dynamite, Mine, Rope, Pneumatic pick, Parachute. Most weapons, when used, cause explosions that deform the terrain, removing circular chunks. The landscape is an island floating on a body of water, or a restricted cave with water at the bottom. A hedgehog dies when it enters the water (either by falling off the island, or through a hole in the bottom of it), it is thrown off either side of the arena or when its health is reduced, typically from contact with explosions, to zero (the damage dealt to the attacked hedgehog or hedgehogs after a player's or CPU turn is shown only when all movement on the battlefield has ceased). WWW: http://www.hedgewars.org Approved by: miwi (mentor)
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/hedgewars/Makefile25
-rw-r--r--games/hedgewars/distinfo3
-rw-r--r--games/hedgewars/pkg-descr24
-rw-r--r--games/hedgewars/pkg-plist255
5 files changed, 308 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index fc6db1d76a61..d6b28c8929da 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -345,6 +345,7 @@
SUBDIR += gweled
SUBDIR += hangman
SUBDIR += hattrickorganizer
+ SUBDIR += hedgewars
SUBDIR += heretic
SUBDIR += heroes
SUBDIR += hex
diff --git a/games/hedgewars/Makefile b/games/hedgewars/Makefile
new file mode 100644
index 000000000000..3233395e5c1e
--- /dev/null
+++ b/games/hedgewars/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: hedgewars
+# Date created: 24 May 2008
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hedgewars
+PORTVERSION= 0.9.4
+CATEGORIES= games
+MASTER_SITES= http://hedgewars.org/download/ \
+ http://www.amdmi3.ru/distfiles/
+DISTNAME= ${PORTNAME}-src-${PORTVERSION}
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Free Worms-like turn based strategy game
+
+USE_BZIP2= yes
+USE_CMAKE= yes
+USE_SDL= sdl mixer image ttf net
+USE_FPC= opengl
+USE_QT_VER= 4
+QT_COMPONENTS= corelib gui moc_build network qmake_build rcc_build svg xml
+
+.include <bsd.port.mk>
diff --git a/games/hedgewars/distinfo b/games/hedgewars/distinfo
new file mode 100644
index 000000000000..0ac72252de41
--- /dev/null
+++ b/games/hedgewars/distinfo
@@ -0,0 +1,3 @@
+MD5 (hedgewars-src-0.9.4.tar.bz2) = d7dbba8f55352caa9527ac48bcbd45ee
+SHA256 (hedgewars-src-0.9.4.tar.bz2) = 3c157a98fac8c0a81b4f22310c350c166b91b8e87eaa05f68940e1f754020ccd
+SIZE (hedgewars-src-0.9.4.tar.bz2) = 6284884
diff --git a/games/hedgewars/pkg-descr b/games/hedgewars/pkg-descr
new file mode 100644
index 000000000000..19ad36bd241d
--- /dev/null
+++ b/games/hedgewars/pkg-descr
@@ -0,0 +1,24 @@
+Each player controls a team of several hedgehogs. During the course
+of the game, players take turns with one of their hedgehogs. They
+then use whatever tools and weapons are available to attack and
+kill the opponents' hedgehogs, thereby winning the game. Hedgehogs
+may move around the terrain in a variety of ways, normally by walking
+and jumping but also by using particular tools such as the "Rope"
+or "Parachute", to move to otherwise inaccessible areas. Each turn
+is time-limited to ensure that players do not hold up the game with
+excessive thinking or moving.
+
+A large variety of tools and weapons are available for players
+during the game: Grenade, Cluster Bomb, Bazooka, UFO, Shotgun,
+Desert Eagle, Fire Punch, Baseball Bat, Dynamite, Mine, Rope,
+Pneumatic pick, Parachute. Most weapons, when used, cause explosions
+that deform the terrain, removing circular chunks. The landscape
+is an island floating on a body of water, or a restricted cave with
+water at the bottom. A hedgehog dies when it enters the water (either
+by falling off the island, or through a hole in the bottom of it),
+it is thrown off either side of the arena or when its health is
+reduced, typically from contact with explosions, to zero (the damage
+dealt to the attacked hedgehog or hedgehogs after a player's or CPU
+turn is shown only when all movement on the battlefield has ceased).
+
+WWW: http://www.hedgewars.org
diff --git a/games/hedgewars/pkg-plist b/games/hedgewars/pkg-plist
new file mode 100644
index 000000000000..9a579b1f62d2
--- /dev/null
+++ b/games/hedgewars/pkg-plist
@@ -0,0 +1,255 @@
+bin/hedgewars
+bin/hwengine
+%%DATADIR%%/Data/Fonts/DejaVuSans.ttf
+%%DATADIR%%/Data/Forts/BarrelhouseL.png
+%%DATADIR%%/Data/Forts/BarrelhouseR.png
+%%DATADIR%%/Data/Forts/IslandL.png
+%%DATADIR%%/Data/Forts/IslandR.png
+%%DATADIR%%/Data/Graphics/AirBomb.png
+%%DATADIR%%/Data/Graphics/Airplane.png
+%%DATADIR%%/Data/Graphics/AmmoMenu/AmmoName.png
+%%DATADIR%%/Data/Graphics/AmmoMenu/Ammos.png
+%%DATADIR%%/Data/Graphics/AmmoMenu/BrdrLines.png
+%%DATADIR%%/Data/Graphics/AmmoMenu/Selection.png
+%%DATADIR%%/Data/Graphics/AmmoMenu/Slot.png
+%%DATADIR%%/Data/Graphics/AmmoMenu/SlotKeys.png
+%%DATADIR%%/Data/Graphics/AmmoMenu/TurnsLeft.png
+%%DATADIR%%/Data/Graphics/Arrow.png
+%%DATADIR%%/Data/Graphics/BigDigits.png
+%%DATADIR%%/Data/Graphics/BlueWater.png
+%%DATADIR%%/Data/Graphics/Bomb.png
+%%DATADIR%%/Data/Graphics/Case.png
+%%DATADIR%%/Data/Graphics/ClBomb.png
+%%DATADIR%%/Data/Graphics/ClParticle.png
+%%DATADIR%%/Data/Graphics/Clouds.png
+%%DATADIR%%/Data/Graphics/Crosshair.png
+%%DATADIR%%/Data/Graphics/Expl50.png
+%%DATADIR%%/Data/Graphics/Finger.png
+%%DATADIR%%/Data/Graphics/FirstAid.png
+%%DATADIR%%/Data/Graphics/Flame.png
+%%DATADIR%%/Data/Graphics/Frame.png
+%%DATADIR%%/Data/Graphics/Girder.png
+%%DATADIR%%/Data/Graphics/Graves/Bone.png
+%%DATADIR%%/Data/Graphics/Graves/Flower.png
+%%DATADIR%%/Data/Graphics/Graves/Grave.png
+%%DATADIR%%/Data/Graphics/Graves/Rip.png
+%%DATADIR%%/Data/Graphics/Graves/Simple.png
+%%DATADIR%%/Data/Graphics/Graves/Statue.png
+%%DATADIR%%/Data/Graphics/Graves/coffin.png
+%%DATADIR%%/Data/Graphics/Graves/eyecross.png
+%%DATADIR%%/Data/Graphics/Graves/pyramid.png
+%%DATADIR%%/Data/Graphics/Graves/star.png
+%%DATADIR%%/Data/Graphics/Grenade.png
+%%DATADIR%%/Data/Graphics/HHDeath.png
+%%DATADIR%%/Data/Graphics/Hammer.png
+%%DATADIR%%/Data/Graphics/Hats/Samurai.png
+%%DATADIR%%/Data/Graphics/Hedgehog.png
+%%DATADIR%%/Data/Graphics/Hedgehog/Idle.png
+%%DATADIR%%/Data/Graphics/Hedgehog/amAirAttack.png
+%%DATADIR%%/Data/Graphics/Hedgehog/amBTorch_i.png
+%%DATADIR%%/Data/Graphics/Hedgehog/amBTorch_w.png
+%%DATADIR%%/Data/Graphics/Hedgehog/amBaseball.png
+%%DATADIR%%/Data/Graphics/Hedgehog/amBazooka.png
+%%DATADIR%%/Data/Graphics/Hedgehog/amDEagle.png
+%%DATADIR%%/Data/Graphics/Hedgehog/amDEagle_w.png
+%%DATADIR%%/Data/Graphics/Hedgehog/amKamikaze.png
+%%DATADIR%%/Data/Graphics/Hedgehog/amRope.png
+%%DATADIR%%/Data/Graphics/Hedgehog/amShotgun.png
+%%DATADIR%%/Data/Graphics/Hedgehog/amShotgun_w.png
+%%DATADIR%%/Data/Graphics/Hedgehog/amWhip.png
+%%DATADIR%%/Data/Graphics/Lag.png
+%%DATADIR%%/Data/Graphics/MineOff.png
+%%DATADIR%%/Data/Graphics/MineOn.png
+%%DATADIR%%/Data/Graphics/Mortar.png
+%%DATADIR%%/Data/Graphics/Parachute.png
+%%DATADIR%%/Data/Graphics/Power.png
+%%DATADIR%%/Data/Graphics/PowerBar.png
+%%DATADIR%%/Data/Graphics/Progress.png
+%%DATADIR%%/Data/Graphics/RopeHook.png
+%%DATADIR%%/Data/Graphics/RopeNode.png
+%%DATADIR%%/Data/Graphics/SmokeTrace.png
+%%DATADIR%%/Data/Graphics/Switch.png
+%%DATADIR%%/Data/Graphics/Target.png
+%%DATADIR%%/Data/Graphics/Targetp.png
+%%DATADIR%%/Data/Graphics/Teleport.png
+%%DATADIR%%/Data/Graphics/UFO.png
+%%DATADIR%%/Data/Graphics/WindBar.png
+%%DATADIR%%/Data/Graphics/WindL.png
+%%DATADIR%%/Data/Graphics/WindR.png
+%%DATADIR%%/Data/Graphics/amAirplane.png
+%%DATADIR%%/Data/Graphics/amGirder.png
+%%DATADIR%%/Data/Graphics/dynamite.png
+%%DATADIR%%/Data/Graphics/hhMask.png
+%%DATADIR%%/Data/Graphics/thinking.png
+%%DATADIR%%/Data/Locale/en.txt
+%%DATADIR%%/Data/Locale/hedgewars_it.qm
+%%DATADIR%%/Data/Locale/hedgewars_pl.qm
+%%DATADIR%%/Data/Locale/hedgewars_ru.qm
+%%DATADIR%%/Data/Locale/it.txt
+%%DATADIR%%/Data/Locale/pl.txt
+%%DATADIR%%/Data/Locale/ru.txt
+%%DATADIR%%/Data/Maps/Hedgelove/map.cfg
+%%DATADIR%%/Data/Maps/Hedgelove/map.png
+%%DATADIR%%/Data/Maps/Hedgewars/map.cfg
+%%DATADIR%%/Data/Maps/Hedgewars/map.png
+%%DATADIR%%/Data/Maps/Plane/map.cfg
+%%DATADIR%%/Data/Maps/Plane/map.png
+%%DATADIR%%/Data/Maps/Volcano/map.cfg
+%%DATADIR%%/Data/Maps/Volcano/map.png
+%%DATADIR%%/Data/Maps/cheese/map.cfg
+%%DATADIR%%/Data/Maps/cheese/map.png
+%%DATADIR%%/Data/Maps/mushrooms/map.cfg
+%%DATADIR%%/Data/Maps/mushrooms/map.png
+%%DATADIR%%/Data/Sounds/explosion.ogg
+%%DATADIR%%/Data/Sounds/graveimpact.ogg
+%%DATADIR%%/Data/Sounds/grenadeimpact.ogg
+%%DATADIR%%/Data/Sounds/gun.ogg
+%%DATADIR%%/Data/Sounds/minetick.ogg
+%%DATADIR%%/Data/Sounds/pickhammer.ogg
+%%DATADIR%%/Data/Sounds/shotgunfire.ogg
+%%DATADIR%%/Data/Sounds/shotgunreload.ogg
+%%DATADIR%%/Data/Sounds/splash.ogg
+%%DATADIR%%/Data/Sounds/throwpowerup.ogg
+%%DATADIR%%/Data/Sounds/throwrelease.ogg
+%%DATADIR%%/Data/Sounds/ufo.ogg
+%%DATADIR%%/Data/Sounds/voices/Amazing.ogg
+%%DATADIR%%/Data/Sounds/voices/Boring.ogg
+%%DATADIR%%/Data/Sounds/voices/Brilliant.ogg
+%%DATADIR%%/Data/Sounds/voices/Bugger.ogg
+%%DATADIR%%/Data/Sounds/voices/Bungee.ogg
+%%DATADIR%%/Data/Sounds/voices/Byebye.ogg
+%%DATADIR%%/Data/Sounds/voices/Comeonthen.ogg
+%%DATADIR%%/Data/Sounds/voices/Coward.ogg
+%%DATADIR%%/Data/Sounds/voices/Cutitout.ogg
+%%DATADIR%%/Data/Sounds/voices/Drat.ogg
+%%DATADIR%%/Data/Sounds/voices/Enemydown.ogg
+%%DATADIR%%/Data/Sounds/voices/Excellent.ogg
+%%DATADIR%%/Data/Sounds/voices/Fire.ogg
+%%DATADIR%%/Data/Sounds/voices/Firstblood.ogg
+%%DATADIR%%/Data/Sounds/voices/Flawless.ogg
+%%DATADIR%%/Data/Sounds/voices/Gonnagetyou.ogg
+%%DATADIR%%/Data/Sounds/voices/Grenade.ogg
+%%DATADIR%%/Data/Sounds/voices/Hello.ogg
+%%DATADIR%%/Data/Sounds/voices/Hmm.ogg
+%%DATADIR%%/Data/Sounds/voices/Hurry.ogg
+%%DATADIR%%/Data/Sounds/voices/Illgetyou.ogg
+%%DATADIR%%/Data/Sounds/voices/Incoming.ogg
+%%DATADIR%%/Data/Sounds/voices/Jump1.ogg
+%%DATADIR%%/Data/Sounds/voices/Jump2.ogg
+%%DATADIR%%/Data/Sounds/voices/Jump3.ogg
+%%DATADIR%%/Data/Sounds/voices/Justyouwait.ogg
+%%DATADIR%%/Data/Sounds/voices/Kamikaze.ogg
+%%DATADIR%%/Data/Sounds/voices/Laugh.ogg
+%%DATADIR%%/Data/Sounds/voices/Leavemealone.ogg
+%%DATADIR%%/Data/Sounds/voices/Missed.ogg
+%%DATADIR%%/Data/Sounds/voices/Nooo.ogg
+%%DATADIR%%/Data/Sounds/voices/Nutter.ogg
+%%DATADIR%%/Data/Sounds/voices/Ohdear.ogg
+%%DATADIR%%/Data/Sounds/voices/Oops.ogg
+%%DATADIR%%/Data/Sounds/voices/Perfect.ogg
+%%DATADIR%%/Data/Sounds/voices/Reinforcements.ogg
+%%DATADIR%%/Data/Sounds/voices/Revenge.ogg
+%%DATADIR%%/Data/Sounds/voices/Runaway.ogg
+%%DATADIR%%/Data/Sounds/voices/Sameteam.ogg
+%%DATADIR%%/Data/Sounds/voices/Solong.ogg
+%%DATADIR%%/Data/Sounds/voices/Stupid.ogg
+%%DATADIR%%/Data/Sounds/voices/Takecover.ogg
+%%DATADIR%%/Data/Sounds/voices/Thisoneismine.ogg
+%%DATADIR%%/Data/Sounds/voices/Traitor.ogg
+%%DATADIR%%/Data/Sounds/voices/Uh-oh.ogg
+%%DATADIR%%/Data/Sounds/voices/Victory.ogg
+%%DATADIR%%/Data/Sounds/voices/Watchit.ogg
+%%DATADIR%%/Data/Sounds/voices/Watchthis.ogg
+%%DATADIR%%/Data/Sounds/voices/Whatthe.ogg
+%%DATADIR%%/Data/Sounds/voices/Whoopsee.ogg
+%%DATADIR%%/Data/Sounds/voices/Yessir.ogg
+%%DATADIR%%/Data/Sounds/voices/Youllregretthat.ogg
+%%DATADIR%%/Data/Themes/City/Border.png
+%%DATADIR%%/Data/Themes/City/Flake.png
+%%DATADIR%%/Data/Themes/City/LandTex.png
+%%DATADIR%%/Data/Themes/City/Sky.png
+%%DATADIR%%/Data/Themes/City/horizont.png
+%%DATADIR%%/Data/Themes/City/plant1.png
+%%DATADIR%%/Data/Themes/City/plant2.png
+%%DATADIR%%/Data/Themes/City/plant3.png
+%%DATADIR%%/Data/Themes/City/plant4.png
+%%DATADIR%%/Data/Themes/City/theme.cfg
+%%DATADIR%%/Data/Themes/Island/Border.png
+%%DATADIR%%/Data/Themes/Island/Flake.png
+%%DATADIR%%/Data/Themes/Island/LandTex.png
+%%DATADIR%%/Data/Themes/Island/Sky.png
+%%DATADIR%%/Data/Themes/Island/horizont.png
+%%DATADIR%%/Data/Themes/Island/plant1.png
+%%DATADIR%%/Data/Themes/Island/plant2.png
+%%DATADIR%%/Data/Themes/Island/plant3.png
+%%DATADIR%%/Data/Themes/Island/plant4.png
+%%DATADIR%%/Data/Themes/Island/theme.cfg
+%%DATADIR%%/Data/Themes/Planes/Flake.png
+%%DATADIR%%/Data/Themes/Planes/Sky.png
+%%DATADIR%%/Data/Themes/Planes/horizont.png
+%%DATADIR%%/Data/Themes/Planes/theme.cfg
+%%DATADIR%%/Data/Themes/Snow/Border.png
+%%DATADIR%%/Data/Themes/Snow/Flake.png
+%%DATADIR%%/Data/Themes/Snow/LandTex.png
+%%DATADIR%%/Data/Themes/Snow/Sky.png
+%%DATADIR%%/Data/Themes/Snow/horizont.png
+%%DATADIR%%/Data/Themes/Snow/plant1.png
+%%DATADIR%%/Data/Themes/Snow/plant2.png
+%%DATADIR%%/Data/Themes/Snow/plant3.png
+%%DATADIR%%/Data/Themes/Snow/plant4.png
+%%DATADIR%%/Data/Themes/Snow/theme.cfg
+%%DATADIR%%/Data/Themes/Volcano/Border.png
+%%DATADIR%%/Data/Themes/Volcano/Flake.png
+%%DATADIR%%/Data/Themes/Volcano/LandTex.png
+%%DATADIR%%/Data/Themes/Volcano/Sky.png
+%%DATADIR%%/Data/Themes/Volcano/gr1.png
+%%DATADIR%%/Data/Themes/Volcano/horizont.png
+%%DATADIR%%/Data/Themes/Volcano/leaf1.png
+%%DATADIR%%/Data/Themes/Volcano/leaf2.png
+%%DATADIR%%/Data/Themes/Volcano/theme.cfg
+%%DATADIR%%/Data/Themes/Volcano/tree.png
+%%DATADIR%%/Data/Themes/cheese/Flake.png
+%%DATADIR%%/Data/Themes/cheese/Sky.png
+%%DATADIR%%/Data/Themes/cheese/horizont.png
+%%DATADIR%%/Data/Themes/cheese/theme.cfg
+%%DATADIR%%/Data/Themes/nature/Border.png
+%%DATADIR%%/Data/Themes/nature/Flake.png
+%%DATADIR%%/Data/Themes/nature/LandTex.png
+%%DATADIR%%/Data/Themes/nature/Sky.png
+%%DATADIR%%/Data/Themes/nature/horizont.png
+%%DATADIR%%/Data/Themes/nature/plant1.png
+%%DATADIR%%/Data/Themes/nature/plant2.png
+%%DATADIR%%/Data/Themes/nature/plant3.png
+%%DATADIR%%/Data/Themes/nature/plant4.png
+%%DATADIR%%/Data/Themes/nature/theme.cfg
+%%DATADIR%%/Data/Themes/themes.cfg
+%%DATADIR%%/Data/Trainings/001_Shotgun.txt
+%%DATADIR%%/Data/Trainings/002_Bazooka.txt
+@dirrm %%DATADIR%%/Data/Trainings
+@dirrm %%DATADIR%%/Data/Themes/nature
+@dirrm %%DATADIR%%/Data/Themes/cheese
+@dirrm %%DATADIR%%/Data/Themes/Volcano
+@dirrm %%DATADIR%%/Data/Themes/Snow
+@dirrm %%DATADIR%%/Data/Themes/Planes
+@dirrm %%DATADIR%%/Data/Themes/Island
+@dirrm %%DATADIR%%/Data/Themes/City
+@dirrm %%DATADIR%%/Data/Themes
+@dirrm %%DATADIR%%/Data/Sounds/voices
+@dirrm %%DATADIR%%/Data/Sounds
+@dirrm %%DATADIR%%/Data/Maps/mushrooms
+@dirrm %%DATADIR%%/Data/Maps/cheese
+@dirrm %%DATADIR%%/Data/Maps/Volcano
+@dirrm %%DATADIR%%/Data/Maps/Plane
+@dirrm %%DATADIR%%/Data/Maps/Hedgewars
+@dirrm %%DATADIR%%/Data/Maps/Hedgelove
+@dirrm %%DATADIR%%/Data/Maps
+@dirrm %%DATADIR%%/Data/Locale
+@dirrm %%DATADIR%%/Data/Graphics/Hedgehog
+@dirrm %%DATADIR%%/Data/Graphics/Hats
+@dirrm %%DATADIR%%/Data/Graphics/Graves
+@dirrm %%DATADIR%%/Data/Graphics/AmmoMenu
+@dirrm %%DATADIR%%/Data/Graphics
+@dirrm %%DATADIR%%/Data/Forts
+@dirrm %%DATADIR%%/Data/Fonts
+@dirrm %%DATADIR%%/Data
+@dirrm %%DATADIR%%