summaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-09-23 11:54:19 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-09-23 11:54:19 +0000
commit5ef1cdeb43ef25f07f484834b3e67ef5a35b2eff (patch)
tree54156e9d1a7d343b19ccfa4aba40c184927711f7 /games
parentUpdate to 3.6 beta 19 (diff)
LPairs is a classical memory game. This means you have to find pairs
of identical cards which will then be removed. Your time and tries needed will be counted but there is no highscore chart or limit to this. WWW: http://lgames.sourceforge.net/index.php?project=LPairs
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/lpairs/Makefile35
-rw-r--r--games/lpairs/distinfo3
-rw-r--r--games/lpairs/pkg-descr6
-rw-r--r--games/lpairs/pkg-plist34
5 files changed, 79 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 0bc253d8a687..8a9ec74a23dd 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -470,6 +470,7 @@
SUBDIR += lmpc
SUBDIR += lordsawar
SUBDIR += love
+ SUBDIR += lpairs
SUBDIR += ltris
SUBDIR += lucidlife
SUBDIR += luola
diff --git a/games/lpairs/Makefile b/games/lpairs/Makefile
new file mode 100644
index 000000000000..f656d78439f2
--- /dev/null
+++ b/games/lpairs/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: lpairs
+# Date created: 12 Sep 2008
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lpairs
+PORTVERSION= 1.0.4
+CATEGORIES= games
+MASTER_SITES= SF/lgames
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Classical memory game
+
+GNU_CONFIGURE= yes
+USE_SDL= sdl
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" CPPFLAGS="-I${LOCALBASE}/include"
+
+.if !defined(WITHOUT_NLS)
+PLIST_SUB+= NLS=""
+USE_GETTEXT= yes
+CONFIGURE_ARGS= --with-libintl-prefix=${LOCALBASE}
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^LIBS =/ s|$$| $${INTLLIBS}|' \
+ ${WRKSRC}/lpairs/Makefile.in
+ @${REINPLACE_CMD} -e 's|^\(inst_dir=\).*|\1$$datarootdir/lpairs|' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/games/lpairs/distinfo b/games/lpairs/distinfo
new file mode 100644
index 000000000000..4fbb50544a7f
--- /dev/null
+++ b/games/lpairs/distinfo
@@ -0,0 +1,3 @@
+MD5 (lpairs-1.0.4.tar.gz) = 5eb00da9f7fc15dc5ce840c312e76cfa
+SHA256 (lpairs-1.0.4.tar.gz) = 350237a51a5de6b2a557af687b4f16678056a0e8d8d96d7e395f6629481462c5
+SIZE (lpairs-1.0.4.tar.gz) = 536625
diff --git a/games/lpairs/pkg-descr b/games/lpairs/pkg-descr
new file mode 100644
index 000000000000..c93b2e94e18b
--- /dev/null
+++ b/games/lpairs/pkg-descr
@@ -0,0 +1,6 @@
+LPairs is a classical memory game. This means you have to find pairs
+of identical cards which will then be removed. Your time and tries
+needed will be counted but there is no highscore chart or limit to
+this.
+
+WWW: http://lgames.sourceforge.net/index.php?project=LPairs
diff --git a/games/lpairs/pkg-plist b/games/lpairs/pkg-plist
new file mode 100644
index 000000000000..19ba3e6cd09b
--- /dev/null
+++ b/games/lpairs/pkg-plist
@@ -0,0 +1,34 @@
+bin/lpairs
+%%NLS%%share/locale/de/LC_MESSAGES/lpairs.mo
+%%DATADIR%%/gfx/0.bmp
+%%DATADIR%%/gfx/1.bmp
+%%DATADIR%%/gfx/10.bmp
+%%DATADIR%%/gfx/11.bmp
+%%DATADIR%%/gfx/12.bmp
+%%DATADIR%%/gfx/13.bmp
+%%DATADIR%%/gfx/14.bmp
+%%DATADIR%%/gfx/15.bmp
+%%DATADIR%%/gfx/16.bmp
+%%DATADIR%%/gfx/17.bmp
+%%DATADIR%%/gfx/18.bmp
+%%DATADIR%%/gfx/19.bmp
+%%DATADIR%%/gfx/2.bmp
+%%DATADIR%%/gfx/3.bmp
+%%DATADIR%%/gfx/4.bmp
+%%DATADIR%%/gfx/5.bmp
+%%DATADIR%%/gfx/6.bmp
+%%DATADIR%%/gfx/7.bmp
+%%DATADIR%%/gfx/8.bmp
+%%DATADIR%%/gfx/9.bmp
+%%DATADIR%%/gfx/back.bmp
+%%DATADIR%%/gfx/button.bmp
+%%DATADIR%%/gfx/f_white.bmp
+%%DATADIR%%/gfx/f_yellow.bmp
+%%DATADIR%%/gfx/stan_font.bmp
+%%DATADIR%%/gfx/title.bmp
+%%DATADIR%%/sound/click.wav
+%%DATADIR%%/sound/fail.wav
+%%DATADIR%%/sound/remove.wav
+@dirrm %%DATADIR%%/sound
+@dirrm %%DATADIR%%/gfx
+@dirrm %%DATADIR%%