summaryrefslogtreecommitdiff
path: root/games/pengpong/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-09-04 23:38:57 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-09-04 23:38:57 +0000
commit6a3e7d9599c4f646425c957319a8e72e9c72647e (patch)
treea31981f78fbd25e7eb80702527d2efe87c009e08 /games/pengpong/Makefile
parento Update to 0.6.0 (diff)
Update to 0.3
Submitted by: MAINTAINER
Diffstat (limited to 'games/pengpong/Makefile')
-rw-r--r--games/pengpong/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/games/pengpong/Makefile b/games/pengpong/Makefile
index d1db3c0dcd35..05b79705eff3 100644
--- a/games/pengpong/Makefile
+++ b/games/pengpong/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pengpong
-PORTVERSION= 0.2
+PORTVERSION= 0.3
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -20,11 +20,25 @@ SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
NO_WRKSUBDIR= yes
MAKE_ENV= SDL_CONFIG="${SDL_CONFIG}"
+DATAFILES= 24P_Copperplate_Blue.png ball.tga logo.jpg \
+ paddle.tga red.png
+
+pre-patch:
+ @${PERL} -pi.orig -e \
+ 's|/usr/local/share/games/pengpong|${DATADIR}|' \
+ ${WRKSRC}/files.h
+ @${PERL} -pi.orig -e 's|0.2|${PORTVERSION}|' \
+ ${WRKSRC}/pengpong.cpp
+
do-install:
.ifndef(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
@${INSTALL_PROGRAM} ${WRKSRC}/pengpong ${PREFIX}/bin
+.for files in ${DATAFILES}
+ @${MKDIR} ${DATADIR}
+ @${INSTALL_DATA} ${WRKSRC}/${files} ${DATADIR}
+.endfor
.include <bsd.port.mk>