summaryrefslogtreecommitdiff
path: root/games/heroes/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-09-28 14:06:24 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-09-28 14:06:24 +0000
commitfdd5b7657068717345af7d6c9b033f64ee0cb87c (patch)
treed931d841634d1199bd37e479245f96190d4e8c7d /games/heroes/Makefile
parentUpdate to 1.0.10. (diff)
Update to 0.6.
Diffstat (limited to 'games/heroes/Makefile')
-rw-r--r--games/heroes/Makefile39
1 files changed, 35 insertions, 4 deletions
diff --git a/games/heroes/Makefile b/games/heroes/Makefile
index 9e6be8507465..298c512b836b 100644
--- a/games/heroes/Makefile
+++ b/games/heroes/Makefile
@@ -6,28 +6,59 @@
#
PORTNAME= heroes
-PORTVERSION= 0.5
+PORTVERSION= 0.6
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
+ ${DATADISTNAME}${EXTRACT_SUFX} \
+ ${SOUNDISTNAME}${EXTRACT_SUFX} \
+ ${MUSICDISTNAME}${EXTRACT_SUFX}
MAINTAINER= sobomax@FreeBSD.org
-LIB_DEPENDS= SDL-1.1.2:${PORTSDIR}/devel/sdl-devel \
- mikmod.2:${PORTSDIR}/audio/libmikmod \
+LIB_DEPENDS= SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+DATAVERSION= 1.0
+SOUNDVERSION= 1.0
+MUSICVERSION= 1.0
+DATADISTNAME= ${PORTNAME}-data-${DATAVERSION}
+SOUNDISTNAME= ${PORTNAME}-sound-effects-${SOUNDVERSION}
+MUSICDISTNAME= ${PORTNAME}-sound-tracks-${MUSICVERSION}
+DATASRC= ${WRKDIR}/${DATADISTNAME}
+SOUNDSRC= ${WRKDIR}/${SOUNDISTNAME}
+MUSICSRC= ${WRKDIR}/${MUSICDISTNAME}
+INSTPREFIX= ${PREFIX}/share/heroes
+
SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
USE_X_PREFIX= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-sdl_mixer=${LOCALBASE}
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
- LIBS="-L${LOCALBASE}/lib -lgnugetopt"
+ LIBS="-L${LOCALBASE}/lib -lgnugetopt -pthread -lsmpeg -lgcc_r"
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN6= heroes.6
+pre-patch:
+ @for dir in ${DATASRC} ${SOUNDSRC} ${MUSICSRC}; do \
+ find $${dir} -name "Makefile*" | xargs ${RM}; \
+ done
+ @${RM} -f ${WRKSRC}/lib/getopt.h
+ @${LN} -sf ${LOCALBASE}/include/getopt.h ${WRKSRC}/lib/getopt.h
+
post-install:
+.for dir in levels pics tilesets
+ ${MKDIR} ${INSTPREFIX}/${dir}
+ ${INSTALL_DATA} ${DATASRC}/${dir}/* ${INSTPREFIX}/${dir}
+.endfor
+ ${MKDIR} ${INSTPREFIX}/sfx
+ ${INSTALL_DATA} ${SOUNDSRC}/*.wav ${SOUNDSRC}/sfx.conf ${INSTPREFIX}/sfx
+ ${MKDIR} ${INSTPREFIX}/mod
+ ${INSTALL_DATA} ${MUSICSRC}/*.xm ${MUSICSRC}/sound.conf ${INSTPREFIX}/mod
@install-info --section="X11 Games" \
--entry="* heroes: (heroes). Game of yore similar to the "Tron" and "Nibbles"" \
${PREFIX}/info/heroes.info ${PREFIX}/info/dir