summaryrefslogtreecommitdiff
path: root/games/formido/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-11-25 03:56:42 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-11-25 03:56:42 +0000
commit4988f2169df0de293b14313610de3c2edabba313 (patch)
tree026bdbf8a04adcb533c27daaccb4394bef339f31 /games/formido/Makefile
parentNew port: games/shootingstar (diff)
New port: games/formido 2D kill-em all with 3D rendered graphics
Formido is one of those games, where you are loaded with some guns and you go shooting different things. 'Things' in this case are big, ugly, - not green though - alien insects. The idea is to kill as many of those bastards as possible. Eventually they will overcome you, but struggle as long as you can. There are some power-ups to aid you in your honorable quest. Keep in mind, that those critters are rather tough and generally do nasty things when in close range of any player-characters. WWW: http://koti.mbnet.fi/lsoft/formido/formido.html PR: ports/89514 Submitted by: Dmitry Marakasov <amdmi3@mail.ru>
Diffstat (limited to 'games/formido/Makefile')
-rw-r--r--games/formido/Makefile62
1 files changed, 62 insertions, 0 deletions
diff --git a/games/formido/Makefile b/games/formido/Makefile
new file mode 100644
index 000000000000..ad875e5ba91f
--- /dev/null
+++ b/games/formido/Makefile
@@ -0,0 +1,62 @@
+# New ports collection makefile for: formido
+# Date created: 19 Nov 2005
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= formido
+PORTVERSION= 1.0
+CATEGORIES= games
+MASTER_SITES= http://koti.mbnet.fi/lsoft/formido/
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= 2D kill-em all with 3D rendered graphics
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_SDL= sdl mixer image
+
+HISCOREDIR= /var/games/formido
+
+MAKE_ENV= DATDIR="${DATADIR}" HISCOREDIR="${HISCOREDIR}" \
+ CC="${CXX}" LINKFLAGS="${CXXFLAGS}" DEFAULT_CONFIG_FILE="${DATADIR}/formido.cfg"
+
+OPTIONS= MUSIC "Install music (6MB)" on
+
+.include <bsd.port.pre.mk>
+
+.ifdef(WITH_MUSIC)
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${PORTNAME}-music${EXTRACT_SUFX}
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+PLIST_SUB+= MUSIC:=""
+.else
+PLIST_SUB+= MUSIC:="@comment "
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}|g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|formido.cfg|.formido.cfg|g' ${WRKSRC}/src/*.cpp
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/formido ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/data/* ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/formido.cfg ${DATADIR}
+.ifdef(WITH_MUSIC)
+ cd ${DATADIR} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/${PORTNAME}-music${EXTRACT_SUFX} ${EXTRACT_AFTER_ARGS}
+ ${CHOWN} root:wheel ${DATADIR}/*.ogg
+ ${CHMOD} 644 ${DATADIR}/*.ogg
+.endif
+ ${CHGRP} games ${PREFIX}/bin/formido
+ ${CHMOD} g+s ${PREFIX}/bin/formido
+
+post-install:
+.if !exists(${HISCOREDIR})
+ ${MKDIR} ${HISCOREDIR}
+ ${CHGRP} games ${HISCOREDIR}
+ ${CHMOD} g+w ${HISCOREDIR}
+.endif
+
+.include <bsd.port.post.mk>