summaryrefslogtreecommitdiff
path: root/games/fgsd
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2006-04-10 10:58:24 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2006-04-10 10:58:24 +0000
commit33d361ea8e9ff0d041958a37ccff5270334f1745 (patch)
tree755ef84327e8c93c5aca11337aac6769fb9cb96c /games/fgsd
parentRevert my last commit, lofi fixed 4.x support 32 minutes ago. My last commit (diff)
Add fgsd.
FGSD is an open source interactive program that allows the user to design custom sceneries for the FlightGear flight simulator project. It is developed under the terms of the GNU General Public License. WWW: http://fgsd.sourceforge.net/
Diffstat (limited to 'games/fgsd')
-rw-r--r--games/fgsd/Makefile57
-rw-r--r--games/fgsd/distinfo3
-rw-r--r--games/fgsd/files/patch-src_Fl__Cursor__Shape.cxx11
-rw-r--r--games/fgsd/pkg-descr8
4 files changed, 79 insertions, 0 deletions
diff --git a/games/fgsd/Makefile b/games/fgsd/Makefile
new file mode 100644
index 000000000000..cd8e7d4cd89d
--- /dev/null
+++ b/games/fgsd/Makefile
@@ -0,0 +1,57 @@
+# New ports collection makefile for: fgsd
+# Date created: 10 Apr 2006
+# Whom: Jean-Yves Lefort <jylefort@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fgsd
+DISTVERSION= 0.3.1a
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= jylefort@FreeBSD.org
+COMMENT= A scenery designer for the FlightGear flight simulator
+
+BUILD_DEPENDS= ${X11BASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib \
+ ${X11BASE}/lib/libsgmisc.a:${PORTSDIR}/devel/simgear
+RUN_DEPENDS= ${X11BASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib \
+ ${X11BASE}/lib/libsgmisc.a:${PORTSDIR}/devel/simgear
+LIB_DEPENDS= fltk:${PORTSDIR}/x11-toolkits/fltk \
+ flu:${PORTSDIR}/x11-toolkits/flu \
+ ungif:${PORTSDIR}/graphics/libungif \
+ curl:${PORTSDIR}/ftp/curl \
+ CGAL:${PORTSDIR}/math/cgal \
+ jpeg:${PORTSDIR}/graphics/jpeg \
+ png:${PORTSDIR}/graphics/png \
+ glut:${PORTSDIR}/graphics/libglut
+
+USE_X_PREFIX= yes
+USE_GL= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+
+PLIST_FILES= bin/fgsd share/pixmaps/fgsd.xpm
+DESKTOP_ENTRIES="FlightGear Scenery Designer" \
+ "Edit FlightGear scenery" \
+ "fgsd.xpm" \
+ "fgsd" \
+ "Application;Graphics;" \
+ false
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= does not build on FreeBSD 4.x
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lgif|-lungif|' ${WRKSRC}/configure
+
+post-install:
+ ${MKDIR} ${PREFIX}/share/pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/src/curves.xpm ${PREFIX}/share/pixmaps/fgsd.xpm
+
+.include <bsd.port.post.mk>
diff --git a/games/fgsd/distinfo b/games/fgsd/distinfo
new file mode 100644
index 000000000000..8ecbac8a47cf
--- /dev/null
+++ b/games/fgsd/distinfo
@@ -0,0 +1,3 @@
+MD5 (fgsd-0.3.1a.tar.gz) = 993518941208b46b81e319f4ed7d0c8f
+SHA256 (fgsd-0.3.1a.tar.gz) = 51887a3089bcac15d37f24fd3bef1581a254619219657e48378b69b751e040d8
+SIZE (fgsd-0.3.1a.tar.gz) = 311804
diff --git a/games/fgsd/files/patch-src_Fl__Cursor__Shape.cxx b/games/fgsd/files/patch-src_Fl__Cursor__Shape.cxx
new file mode 100644
index 000000000000..3d933bf9a7b3
--- /dev/null
+++ b/games/fgsd/files/patch-src_Fl__Cursor__Shape.cxx
@@ -0,0 +1,11 @@
+--- src/Fl_Cursor_Shape.cxx.orig Mon Apr 10 11:16:04 2006
++++ src/Fl_Cursor_Shape.cxx Mon Apr 10 11:16:18 2006
+@@ -53,7 +53,7 @@
+ # include <malloc.h>
+ #elif defined(__APPLE__)
+ #else
+-# include <malloc.h>
++# include <stdlib.h>
+ # include <string.h>
+ #endif
+
diff --git a/games/fgsd/pkg-descr b/games/fgsd/pkg-descr
new file mode 100644
index 000000000000..a2cce22c1215
--- /dev/null
+++ b/games/fgsd/pkg-descr
@@ -0,0 +1,8 @@
+FGSD is an open source interactive program that allows the user to design
+custom sceneries for the FlightGear flight simulator project. It is developed
+under the terms of the GNU General Public License.
+
+WWW: http://fgsd.sourceforge.net/
+
+- Jean-Yves Lefort
+jylefort@FreeBSD.org