summaryrefslogtreecommitdiff
path: root/games/easysok
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-05-21 22:23:08 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-05-21 22:23:08 +0000
commit258a678bdeccb425a20f68feb0aa7b03381497a3 (patch)
treeafce4682b9fbe23dad8220014989e00bec7fb1f7 /games/easysok
parent- Update to 1.4.4 (diff)
Remove inclusion of "${PORTSDIR}/x11/kde3/Makefile.kde", fix PTHREAD_LIBS
safeness, fix compilation where needed. Committers: Please do NOT include Makefile.kde or commit new ports which do so. It's for use with the core KDE ports maintained by kde@freebsd.org ONLY.
Diffstat (limited to 'games/easysok')
-rw-r--r--games/easysok/Makefile9
-rw-r--r--games/easysok/files/patch-src_Makefile.in11
2 files changed, 17 insertions, 3 deletions
diff --git a/games/easysok/Makefile b/games/easysok/Makefile
index 2f46d7e8c829..53a140cbd0d2 100644
--- a/games/easysok/Makefile
+++ b/games/easysok/Makefile
@@ -17,7 +17,10 @@ COMMENT= A sokoban game for KDE3
USE_KDELIBS_VER= 3
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||g' -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>
diff --git a/games/easysok/files/patch-src_Makefile.in b/games/easysok/files/patch-src_Makefile.in
new file mode 100644
index 000000000000..9d358467dec9
--- /dev/null
+++ b/games/easysok/files/patch-src_Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Fri May 21 22:37:02 2004
++++ src/Makefile.in Fri May 21 22:37:18 2004
+@@ -248,7 +248,7 @@
+
+ easysok_SOURCES = dummy.cpp
+ easysok_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+-easysok_LDADD = easysok.la $(LIB_KDEUI) $(LIB_KFILE) $(LIB_KIO) $(LIB_MNG) -lkdeprint
++easysok_LDADD = easysok.la $(LIB_KDEUI) $(LIB_KFILE) $(LIB_KIO) $(LIB_MNG) -lkdeprint $(LIBPTHREAD)
+
+ easysok_la_SOURCES = atomic_move.cpp move.cpp movements.cpp hash.cpp map.cpp \
+ compressed_map.cpp level.cpp collection.cpp collection_holder.cpp \