summaryrefslogtreecommitdiff
path: root/ftp/gollem
diff options
context:
space:
mode:
authorMarc G. Fournier <scrappy@FreeBSD.org>2006-04-15 16:29:27 +0000
committerMarc G. Fournier <scrappy@FreeBSD.org>2006-04-15 16:29:27 +0000
commit67394da2b69be2b9889ea66e8d0aa7019b24258a (patch)
tree025995aee4d5e691a1662305be383745bcef7453 /ftp/gollem
parentmake sure I update the PORTREVISION (diff)
After a recent discussion on freebsd-ports, I have modified the Horde
ports, so that they now do not overwrite existing configuration files. Rather than backing up the old ones and allowing the user to merge the files by hand, config files are left untouched. Submitted by: Shaun Amott <shaun@inerd.com>
Diffstat (limited to 'ftp/gollem')
-rw-r--r--ftp/gollem/files/pkg-deinstall.in9
-rw-r--r--ftp/gollem/files/pkg-install.in23
2 files changed, 26 insertions, 6 deletions
diff --git a/ftp/gollem/files/pkg-deinstall.in b/ftp/gollem/files/pkg-deinstall.in
index 5c399f4c3632..74ba43ea36c6 100644
--- a/ftp/gollem/files/pkg-deinstall.in
+++ b/ftp/gollem/files/pkg-deinstall.in
@@ -12,13 +12,10 @@ if [ -z "${PACKAGE_BUILDING}" ]; then
for cf in `ls %%GOLLEMDIR%%/config/*php`; do
diff -bBqw $cf $cf.dist >/dev/null 2>&1
case $? in
- 0) # original config file, will be deleted by pkg-plist
+ 0) # original config file, delete it
+ rm -f $cf
;;
- 1) # config file has been updated, must be backuped
- cp -p $cf $cf.previous
- echo "===> Backing-up..."
- echo "---> $cf has been saved ***"
- echo "---> as $cf.previous ***"
+ 1) # config file has been updated, leave it alone
;;
*) # not found?
;;
diff --git a/ftp/gollem/files/pkg-install.in b/ftp/gollem/files/pkg-install.in
new file mode 100644
index 000000000000..49c99fa99dee
--- /dev/null
+++ b/ftp/gollem/files/pkg-install.in
@@ -0,0 +1,23 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+PATH=/usr/sbin:/usr/bin:/bin ; export PATH
+
+case $2 in
+ PRE-INSTALL)
+ ;;
+
+ POST-INSTALL)
+ if [ -z "${PACKAGE_BUILDING}" ]; then
+ # Copy over sample config files unless they already exist
+
+ for cf in `ls %%GOLLEMDIR%%/config/*.dist | sed -e 's/\.dist//g'`; do
+ if [ ! -f $cf ]; then
+ cp -p $cf.dist $cf
+ fi
+ done
+ fi
+ ;;
+esac