summaryrefslogtreecommitdiff
path: root/finance/grisbi/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-08-29 11:41:11 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-08-29 11:41:11 +0000
commit1b7e94efb7e0a53058b96a2de175e6a3c431816b (patch)
tree81a9bd61202acaafa97ff5fb9036be3936928d9f /finance/grisbi/Makefile
parentUse the ftp location suggested by Joe (diff)
New port: finance/grisbi, a personal finance manager.
Grisbi is a personnal accounting application, written with Gnome and Gtk, and is released under the GPL licence. Its aim is to provide you with the most simple and intuitive software for basic use, although it can be very powerful if you spend a little time on the setup. Grisbi is an application written by french developpers, so it perfectly respects french accounting rules. Grisbi can manage multiple accounts, currencies and users. It manages third parties, expenditures and receipts categories, and also budgetary lines, financial years, and other information that make Grisbi adapted for associations (except those that require double entry accounting). WWW: http://www.grisbi.org/ PR: ports/54675 Submitted by: Thierry Thomas <thierry@pompo.net>
Diffstat (limited to 'finance/grisbi/Makefile')
-rw-r--r--finance/grisbi/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/finance/grisbi/Makefile b/finance/grisbi/Makefile
new file mode 100644
index 000000000000..00b87fe25321
--- /dev/null
+++ b/finance/grisbi/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: grisbi
+# Date created: 19 November 2002
+# Whom: Thierry Thomas <thierry@pompo.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= grisbi
+PORTVERSION= 0.4.1
+CATEGORIES= finance
+MASTER_SITES= http://grisbi.gegeweb.net/packages/src/
+
+MAINTAINER= thierry@pompo.net
+COMMENT= A personnal accounting application
+
+LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext \
+ iconv.3:${PORTSDIR}/converters/libiconv
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12 libcapplet libxml gnomepanel orbit gdkpixbuf gnomelibs gnomeprint
+USE_BISON= yes
+USE_BZIP2= yes
+USE_AUTOCONF= yes
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib" \
+ AUTOHEADER="${AUTOHEADER}" \
+ AUTOCONF="${AUTOCONF}"
+
+post-install:
+ @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE} | ${SED} -e "s:%%PREFIX%%:${PREFIX}:"
+ @${ECHO_MSG}
+
+.include <bsd.port.mk>