summaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2005-11-15 06:52:12 +0000
committerAde Lovett <ade@FreeBSD.org>2005-11-15 06:52:12 +0000
commit54a0b86543e9ffa811825f0afecea56e89aac2a5 (patch)
treef56fb969c6a70f5e63287a4f791d035ab1ef0ddc /emulators
parentRemove full path in patch (diff)
Mass-conversion to the USE_AUTOTOOLS New World Order. The code present
in bsd.autotools.mk essentially makes this a no-op given that all the old variables set a USE_AUTOTOOLS_COMPAT variable, which is parsed in exactly the same way as USE_AUTOTOOLS itself. Moreover, USE_AUTOTOOLS has already been extensively tested by the GNOME team -- all GNOME 2.12.x ports use it. Preliminary documentation can be found at: http://people.FreeBSD.org/~ade/autotools.txt which is in the process of being SGMLized before introduction into the Porters Handbook. Light blue touch-paper. Run.
Diffstat (limited to 'emulators')
-rw-r--r--emulators/gnuboy/Makefile2
-rw-r--r--emulators/lib765/Makefile2
-rw-r--r--emulators/libspectrum/Makefile2
-rw-r--r--emulators/libvm68k/Makefile2
-rw-r--r--emulators/mupen64-sdlinput/Makefile2
-rw-r--r--emulators/twin/Makefile2
-rw-r--r--emulators/uae/Makefile2
-rw-r--r--emulators/visualos/Makefile2
-rw-r--r--emulators/vx68k/Makefile2
-rw-r--r--emulators/xsystem35/Makefile3
10 files changed, 10 insertions, 11 deletions
diff --git a/emulators/gnuboy/Makefile b/emulators/gnuboy/Makefile
index 8eef9a5263c4..02bafaa53e27 100644
--- a/emulators/gnuboy/Makefile
+++ b/emulators/gnuboy/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= vga.1:${PORTSDIR}/graphics/svgalib
USE_SDL= sdl
USE_REINPLACE= yes
USE_XLIB= yes
-USE_AUTOCONF_VER= 259
+USE_AUTOTOOLS= autoconf:259
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
CONFIGURE_ARGS= --with-sdl
diff --git a/emulators/lib765/Makefile b/emulators/lib765/Makefile
index 28d808a44fb6..4c44c976dd25 100644
--- a/emulators/lib765/Makefile
+++ b/emulators/lib765/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= http://www.seasip.demon.co.uk/Unix/LibDsk/
MAINTAINER= kemm@in-line.ru
COMMENT= Emulation of uPD765a Floppy Disc Controller
-USE_INC_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13:inc
INSTALLS_SHLIB= yes
.if !defined(NOPORTDOCS)
diff --git a/emulators/libspectrum/Makefile b/emulators/libspectrum/Makefile
index 68a2289fcf2e..f130c8eb5912 100644
--- a/emulators/libspectrum/Makefile
+++ b/emulators/libspectrum/Makefile
@@ -17,7 +17,7 @@ COMMENT= Handling of ZX-Spectrum emulator files formats
USE_PERL5_BUILD= yes
WANT_GNOME= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= yes
MAN3= libspectrum.3
diff --git a/emulators/libvm68k/Makefile b/emulators/libvm68k/Makefile
index ffc38dec5887..0e6ee218c130 100644
--- a/emulators/libvm68k/Makefile
+++ b/emulators/libvm68k/Makefile
@@ -15,7 +15,7 @@ MASTER_SITES= ftp://ftp.hypercore.co.jp/vx68k/${PORTNAME}-${PORTVERSION:R}/
MAINTAINER= ports@FreeBSD.org
COMMENT= M68000 virtual machine library
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
diff --git a/emulators/mupen64-sdlinput/Makefile b/emulators/mupen64-sdlinput/Makefile
index a692d33ac904..221514ddb8be 100644
--- a/emulators/mupen64-sdlinput/Makefile
+++ b/emulators/mupen64-sdlinput/Makefile
@@ -21,7 +21,7 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_SDL= sdl
USE_GCC= 3.4
-USE_AUTOHEADER_VER= 259
+USE_AUTOTOOLS= autoheader:259
ONLY_FOR_ARCHS= i386
PLUGIN_NAME= blight_input
diff --git a/emulators/twin/Makefile b/emulators/twin/Makefile
index 0da7cd1b2c4c..2329b62bd1fa 100644
--- a/emulators/twin/Makefile
+++ b/emulators/twin/Makefile
@@ -23,7 +23,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USE_XLIB= yes
USE_REINPLACE= yes
-USE_AUTOCONF_VER= 213
+USE_AUTOTOOLS= autoconf:213
GNU_CONFIGURE= yes
.if ${MACHINE_ARCH} == "alpha"
CONFIGURE_ARGS+=--disable-intp
diff --git a/emulators/uae/Makefile b/emulators/uae/Makefile
index f85ab2eed596..5753eb9d0a4d 100644
--- a/emulators/uae/Makefile
+++ b/emulators/uae/Makefile
@@ -19,7 +19,7 @@ CONFLICTS= e-uae-*
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_AUTOCONF_VER= 259
+USE_AUTOTOOLS= autoconf:259
CONFIGURE_ARGS= --enable-sound --enable-vidmode --enable-dga
USE_XLIB= yes
USE_GNOME= gtk20
diff --git a/emulators/visualos/Makefile b/emulators/visualos/Makefile
index 120c81974970..d6f8d1d168a3 100644
--- a/emulators/visualos/Makefile
+++ b/emulators/visualos/Makefile
@@ -18,7 +18,7 @@ USE_X_PREFIX= yes
USE_GNOME= gnomehack gnomeprefix libglade
USE_REINPLACE= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/emulators/vx68k/Makefile b/emulators/vx68k/Makefile
index dd631552fe1a..99c41758cc9e 100644
--- a/emulators/vx68k/Makefile
+++ b/emulators/vx68k/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= vm68k.4:${PORTSDIR}/emulators/libvm68k
USE_GL= yes
USE_GNOME= gtk12
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_REINPLACE= yes
LIBTOOLFILES= configure vx68k-gtk/configure
#LIBTOOLFLAGS= --disable-ltlibs --release-ignore
diff --git a/emulators/xsystem35/Makefile b/emulators/xsystem35/Makefile
index 33689788317c..902945db7f19 100644
--- a/emulators/xsystem35/Makefile
+++ b/emulators/xsystem35/Makefile
@@ -16,8 +16,7 @@ COMMENT= AliceSoft System 3.5/3.6/3.8/3.9 on X Window System
LIB_DEPENDS= vorbis.3:${PORTSDIR}/audio/libvorbis \
jpeg.9:${PORTSDIR}/graphics/jpeg
-USE_AUTOCONF_VER= 259
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= autoconf:259 libtool:15
USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= gtk12