summaryrefslogtreecommitdiff
path: root/emulators/xmame/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-02-01 01:13:46 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-02-01 01:13:46 +0000
commit5c795d07084d1675f2eb4d56f13bddba8b6e76e3 (patch)
tree97549fe23af4a7d45f83f67b38c4471321b1b5ba /emulators/xmame/Makefile
parent- Fix build on AMD64 (diff)
- Update to 0.78.1
PR: ports/62137 Submitted by: Miguel Mendez <flynn@energyhq.es.eu.org> Approved by: maintainer (xmame part)
Diffstat (limited to 'emulators/xmame/Makefile')
-rw-r--r--emulators/xmame/Makefile21
1 files changed, 12 insertions, 9 deletions
diff --git a/emulators/xmame/Makefile b/emulators/xmame/Makefile
index 34b122c20830..4061cbcd25a4 100644
--- a/emulators/xmame/Makefile
+++ b/emulators/xmame/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME?= xmame
-PORTVERSION?= 0.77.1
+PORTVERSION?= 0.78.1
CATEGORIES= emulators
MASTER_SITES= http://x.mame.net/download/:xmame \
http://www.sys2064.com/files/util/:history \
@@ -24,7 +24,6 @@ USE_BZIP2= yes
USE_PERL5= yes
USE_GMAKE= yes
USE_REINPLACE= yes
-MAKEFILE= makefile.unix
MAN6= x${MAMEMESS}.6
@@ -79,18 +78,13 @@ GENERALDOCS= changes.unix \
xmame-gdoc.html \
xmame.css
XMAMEDOCS=
-XMESSDOCS= mess/cgafont.txt \
- mess/compilewin.html \
- mess/credits.htm \
- mess/credits.txt \
+XMESSDOCS= mess/credits.htm \
mess/faq.htm \
mess/imgtool.txt \
- mess/messhelp.txt \
mess/messnew.txt \
- mess/messold.txt \
mess/messroms.txt \
mess/sysinfo.dat \
- mess/windows.txt
+
PINMAMEDOCS= pinmame/simulation.txt \
pinmame/whatsnew.txt \
pinmame/pinmame.txt \
@@ -281,6 +275,15 @@ do-configure:
-e "s@^GLLIBS += .*@GLLIBS += ${PTHREAD_LIBS}@g" \
${WRKSRC}/makefile.unix
+# png.h conflicts with libpng.
+.for file in mess/artworkx.c mess/artworkx.h src/artwork.c \
+ src/common.c src/png.c src/unix/video-drivers/glexport.c
+
+ ${REINPLACE_CMD} -e "s@\"png.h\"@\"mame_png.h\"@g" ${WRKSRC}/${file}
+
+.endfor
+ ${LN} -s ${WRKSRC}/src/png.h ${WRKSRC}/src/mame_png.h
+
post-build:
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} SDL_VIDEODRIVER=aalib \
${GMAKE} doc/x${MAMEMESS}.6