summaryrefslogtreecommitdiff
path: root/emulators/wine-devel/Makefile
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2003-05-19 10:07:37 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2003-05-19 10:07:37 +0000
commit42eedefcd21552ea49d0045a2c1b8fa3810d7d21 (patch)
tree90b49d57e28fefc5aa9371908600cf4dd5557604 /emulators/wine-devel/Makefile
parentUpdate to exiscan-acl-4.20-06, which fixes a problem handling multiple (diff)
Install a script into etc/rc.d/ to run ldconfig after reboots so
Wine libraries could be found. Approved by: maintainer
Diffstat (limited to 'emulators/wine-devel/Makefile')
-rw-r--r--emulators/wine-devel/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index 0a46ca4c4813..fa41aedb7ab3 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -50,6 +50,10 @@ pre-extract:
@${ECHO} "that when running, only when it has to enter the debugger...)"
.endif
+post-extract:
+ @${SED} -e "s=%%PREFIX%%=${PREFIX}=g" ${FILESDIR}/wine.sh \
+ > ${WRKSRC}/wine.sh
+
post-configure:
cd ${WRKSRC} && make depend
@@ -89,4 +93,7 @@ do-install:
${ECHO}
@${SED} s+%%PREFIX%%+${PREFIX}+g <${PKGMESSAGE}
+post-install:
+ @$INSTALL_SCRIPT} ${WRKSRC}/wine.sh > ${PREFIX}/etc/rc.d/000.wine.sh
+
.include <bsd.port.post.mk>