summaryrefslogtreecommitdiff
path: root/emulators/vmware2/Makefile
diff options
context:
space:
mode:
authorMartin Blapp <mbr@FreeBSD.org>2003-04-13 09:55:44 +0000
committerMartin Blapp <mbr@FreeBSD.org>2003-04-13 09:55:44 +0000
commit03b57d00e7c0605fa2449c4435baebf2a4d3a224 (patch)
tree8cc8a98ed2f6f57c3eeae0a9ca7108e226a48dd3 /emulators/vmware2/Makefile
parentMake portlint a bit more happy. (diff)
Deal with minor number changes in CURRENT.
PR: 48608 Submitted by: Per Hedeland <per@hedeland.org>
Diffstat (limited to 'emulators/vmware2/Makefile')
-rw-r--r--emulators/vmware2/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/emulators/vmware2/Makefile b/emulators/vmware2/Makefile
index b029925fbb19..77a9c1e40484 100644
--- a/emulators/vmware2/Makefile
+++ b/emulators/vmware2/Makefile
@@ -67,11 +67,18 @@ BROKEN= "Kernel source files required"
.include "${WRKDIRPREFIX}${.CURDIR}/work/Makefile.inc.net"
.endif
+.if ${OSVERSION} < 500023
+VMNET1_MINOR= 0x00010001
+.else
+VMNET1_MINOR= 0x00800001
+.endif
+
SCRIPTS_ENV+= LINUXBASE="${LINUXBASE}" \
VMNET_HOST_IP="${VMNET_HOST_IP}" \
- VMNET_NETMASK="${VMNET_NETMASK}"
+ VMNET_NETMASK="${VMNET_NETMASK}" \
+ VMNET1_MINOR="${VMNET1_MINOR}"
MAKE_ARGS= KMODDIR="${VMDIR}/lib/modules"
-PLIST_SUB= LINUXBASE="${LINUXBASE}"
+PLIST_SUB= LINUXBASE="${LINUXBASE}" VMNET1_MINOR="${VMNET1_MINOR}"
post-extract:
.for m in ${MODULES}
@@ -125,6 +132,7 @@ post-patch:
${CAT} ${FILESDIR}/hostif_c.patch | (cd ${WRKSRC} && patch) > /dev/null 2>&1
${CAT} ${FILESDIR}/vm_types_h.patch | (cd ${WRKSRC} && patch) > /dev/null 2>&1
.endif
+ ${CAT} ${FILESDIR}/vmnet-only+Makefile.patch | (cd ${WRKSRC} && patch) > /dev/null 2>&1
setoptions:
${SED} -e 's;@@PREFIX@@;${PREFIX};' \
@@ -182,10 +190,6 @@ pre-install: setoptions
post-install:
${LN} -sf ${PREFIX}/etc/vmware /etc/
-.if ${OSVERSION} >= 500100
- ${RM} -f ${LINUXBASE}/dev/vmnet1
- ${LN} -sf /dev/vmnet1 ${LINUXBASE}/dev/vmnet1
-.endif
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>