summaryrefslogtreecommitdiff
path: root/emulators/vba/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-05-14 11:54:26 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-05-14 11:54:26 +0000
commitc5d69a5700401ac5a9592388ee56658bc10cf771 (patch)
tree9b7f463edb145d8e70deccf41fc80a3f3fe96770 /emulators/vba/Makefile
parentmaintainer update of emulators/vba (diff)
maintainer update of emulators/vba
Update of emulators/vba to 1.7.1_2 (this time for real!) PR: ports/64612 Submitted by: No Name <arundel@gmx.net>
Diffstat (limited to 'emulators/vba/Makefile')
-rw-r--r--emulators/vba/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/emulators/vba/Makefile b/emulators/vba/Makefile
index d59b48256635..4cfac6b35035 100644
--- a/emulators/vba/Makefile
+++ b/emulators/vba/Makefile
@@ -6,14 +6,14 @@
PORTNAME= vba
PORTVERSION= 1.7.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= VisualBoyAdvance-src-${PORTVERSION}
MAINTAINER= arundel@gmx.net
-COMMENT= Currently the best Gameboy Advance emulator!
+COMMENT= Open Source Gameboy Advance emulator
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
@@ -28,10 +28,12 @@ TARGET_DIR= ${PREFIX}/bin/
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500035
+.if (${OSVERSION} < 500035)
CFLAGS+= -O0
-.else
-CLAGS+=
+.endif
+
+.ifndef(PROFILING)
+CONFIGURE_ARGS= --without-profiling --disable-dev
.endif
DATA_FILES= ${WRKSRC}/src/VisualBoyAdvance.cfg
@@ -40,12 +42,10 @@ DOC_FILES= COPYING AUTHORS NEWS README ChangeLog INSTALL
pre-everything::
@${ECHO_MSG} ""
- @${ECHO_MSG} "GCC must be 3.x or greater in order to compile GBA.cpp with -O2. Earlier"
- @${ECHO_MSG} "versions have a problem during optimization that requires an absurd"
- @${ECHO_MSG} "ammount of memory and usually ends up crashing the compiler/computer"
+ @${ECHO_MSG} "You can enable profiling by defining PROFILING."
@${ECHO_MSG} ""
- @${ECHO_MSG} "Note by MAINTAINER: Currently everything < 500035 is being build with -O0"
- @${ECHO_MSG} "flag."
+ @${ECHO_MSG} "Due to a bug in gcc2 optimsations other than -O0 will be ignored on"
+ @${ECHO_MSG} "FreeBSD releases that didn't ship with gcc3 (prior 500035)."
@${ECHO_MSG} ""
do-install: