summaryrefslogtreecommitdiff
path: root/emulators/vba/Makefile
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2007-10-02 05:24:15 +0000
committerMark Linimon <linimon@FreeBSD.org>2007-10-02 05:24:15 +0000
commitc1dc7bd8aaf888192b6dd4ee7ed68249459ee555 (patch)
tree4d7da05958ac6ff1af03f545a74638f0254d74d9 /emulators/vba/Makefile
parentMark as broken with gcc4.2. (diff)
Mark as broken with gcc4.2. While here, remove antique compatibilty cruft.
Diffstat (limited to 'emulators/vba/Makefile')
-rw-r--r--emulators/vba/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/emulators/vba/Makefile b/emulators/vba/Makefile
index 60794fa334ae..bfb15969d5fd 100644
--- a/emulators/vba/Makefile
+++ b/emulators/vba/Makefile
@@ -35,11 +35,11 @@ DOC_FILES= COPYING AUTHORS NEWS README ChangeLog INSTALL
.include <bsd.port.pre.mk>
.if ${ARCH} == "ia64"
-BROKEN= "Runaway cc1plus process"
+BROKEN= Runaway cc1plus process
.endif
-.if ( ${OSVERSION} < 500035 )
-CFLAGS+= -O0
+.if ${OSVERSION} >= 700042
+BROKEN= Does not compile with GCC 4.2
.endif
.ifdef(WITH_GTK2)
@@ -67,9 +67,6 @@ pre-everything::
@${ECHO_MSG} "You can install the GTK2 based X version by defining WITH_GTK2."
.endif
@${ECHO_MSG} ""
- @${ECHO_MSG} "Due to a bug in gcc2 optimizations other than -O0 will be ignored on"
- @${ECHO_MSG} "FreeBSD releases that didn't ship with gcc3 (prior 500035)."
- @${ECHO_MSG} ""
do-install:
${INSTALL_PROGRAM} ${PROG_FILES} ${PREFIX}/bin