summaryrefslogtreecommitdiff
path: root/emulators/vba/Makefile
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2004-02-17 10:06:24 +0000
committerMark Linimon <linimon@FreeBSD.org>2004-02-17 10:06:24 +0000
commit5c3d5d1f4e42a4de8e72b2ce291a98694c46184f (patch)
tree11ea67566f76c2863c6f79a5adfcccfc61dcd166 /emulators/vba/Makefile
parentFORBIDDEN on 5.x: does not respect PTHREAD_{CFLAGS,LIBS} (diff)
Update to version 1.7.1: update battery file more often; many bugfixes.
See ChangeLog for complete details. PR: ports/62645 Submitted by: arundel@gmx.net (maintainer)
Diffstat (limited to 'emulators/vba/Makefile')
-rw-r--r--emulators/vba/Makefile26
1 files changed, 14 insertions, 12 deletions
diff --git a/emulators/vba/Makefile b/emulators/vba/Makefile
index af774969882b..cfdcd0dac764 100644
--- a/emulators/vba/Makefile
+++ b/emulators/vba/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= vba
-PORTVERSION= 1.7
-PORTREVISION= 1
+PORTVERSION= 1.7.1
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -21,7 +20,6 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
USE_X_PREFIX= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --without-profiling
USE_SDL= yes
WRKSRC= ${WRKDIR}/VisualBoyAdvance-${PORTVERSION}
@@ -36,8 +34,8 @@ CLAGS+=
.endif
DATA_FILES= ${WRKSRC}/src/VisualBoyAdvance.cfg
-PROG_FILES= ${WRKSRC}/src/VisualBoyAdvance
-DOC_FILES= ${WRKSRC}/COPYING ${WRKSRC}/AUTHORS ${WRKSRC}/NEWS ${WRKSRC}/README
+PROG_FILES= ${WRKSRC}/src/VisualBoyAdvance ${WRKSRC}/src/TestEmu
+DOC_FILES= COPYING AUTHORS NEWS README ChangeLog INSTALL
pre-everything::
@${ECHO_MSG} ""
@@ -49,18 +47,22 @@ pre-everything::
@${ECHO_MSG} "flag."
@${ECHO_MSG} ""
-post-extract:
- rm -rf `find ${WRKSRC} -name '.deps'`
-
do-install:
- ${INSTALL} -d ${TARGET_DIR} && \
- ${INSTALL_PROGRAM} ${PROG_FILES} ${TARGET_DIR} && \
- ${INSTALL_DATA} ${DATA_FILES} ${TARGET_DIR} && \
+ ${INSTALL} -d ${TARGET_DIR}
+ ${INSTALL_PROGRAM} ${PROG_FILES} ${TARGET_DIR}
+
+.if !exists (${PREFIX}/bin/VisualBoyAdvance.cfg)
+ ${INSTALL_DATA} ${DATA_FILES} ${TARGET_DIR}
+.endif
post-install:
.ifndef(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- ${INSTALL_MAN} ${DOC_FILES} ${DOCSDIR}
+
+.for filename in ${DOC_FILES}
+ ${INSTALL_MAN} ${WRKSRC}/${filename} ${DOCSDIR}
+.endfor
+
.endif
.include <bsd.port.post.mk>