summaryrefslogtreecommitdiff
path: root/emulators/vba/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-08-21 13:59:20 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-08-21 13:59:20 +0000
commit556a038edeabc9796ab254458ddebec4838eb855 (patch)
tree66bf87aa183189607246a7dd456edca2468cae2b /emulators/vba/Makefile
parentFix build error in the environment that using the OpenSSL from the ports (diff)
- Fix build on 4.x
- Don't install debugger unless asked - Assume maintainership PR: ports/70769 Submitted by: No Name <arundel@h3c.de>
Diffstat (limited to 'emulators/vba/Makefile')
-rw-r--r--emulators/vba/Makefile29
1 files changed, 21 insertions, 8 deletions
diff --git a/emulators/vba/Makefile b/emulators/vba/Makefile
index 889af7629eae..726b80a452eb 100644
--- a/emulators/vba/Makefile
+++ b/emulators/vba/Makefile
@@ -6,12 +6,13 @@
PORTNAME= vba
PORTVERSION= 1.7.2
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= VisualBoyAdvance-src-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= arundel@h3c.de
COMMENT= Open Source Gameboy Advance emulator
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
@@ -31,18 +32,22 @@ TARGET_DIR= ${PREFIX}/bin/
CFLAGS+= -O0
.endif
-.if ${OSVERSION} < 500000
-BROKEN= "Does not compile on 4.x"
-.endif
-
.ifndef(PROFILING)
CONFIGURE_ARGS+= --without-profiling
.endif
+PLIST_SUB= INSTALL_DEBUGGER=""
+
+.ifndef(WITH_DEBUGGER)
+CONFIGURE_ARGS+= --disable-dev
+PLIST_SUB= INSTALL_DEBUGGER="@comment "
+.endif
+
CONFIGURE_ARGS+= LIBS=-L${LOCALBASE}/lib
DATA_FILES= ${WRKSRC}/src/VisualBoyAdvance.cfg
-PROG_FILES= ${WRKSRC}/src/sdl/VisualBoyAdvance ${WRKSRC}/src/sdl/TestEmu
+PROG_FILES= ${WRKSRC}/src/sdl/VisualBoyAdvance
+DEBUG_FILES= ${WRKSRC}/src/sdl/TestEmu
DOC_FILES= COPYING AUTHORS NEWS README ChangeLog INSTALL
pre-everything::
@@ -50,15 +55,23 @@ pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} "You can enable profiling by defining PROFILING."
.endif
+.ifndef(WITH_DEBUGGER)
@${ECHO_MSG} ""
- @${ECHO_MSG} "Due to a bug in gcc2 optimsations other than -O0 will be ignored on"
+ @${ECHO_MSG} "You can install the ARM/THUMB debugger by defining WITH_DEBUGGER."
+.endif
+
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "Due to a bug in gcc2 optimizations other than -O0 will be ignored on"
@${ECHO_MSG} "FreeBSD releases that didn't ship with gcc3 (prior 500035)."
@${ECHO_MSG} ""
do-install:
${INSTALL} -d ${TARGET_DIR}
${INSTALL_PROGRAM} ${PROG_FILES} ${TARGET_DIR}
- ${CP} ${DATA_FILES} ${DATA_FILES}-default
+.ifdef(WITH_DEBUGGER)
+ ${INSTALL_PROGRAM} ${DEBUG_FILES} ${TARGET_DIR}
+.endif
+ ${SED} -e 's|filter=0|filter=1|' ${DATA_FILES} > ${DATA_FILES}-default
${INSTALL_DATA} ${DATA_FILES}-default ${TARGET_DIR}
post-install: