summaryrefslogtreecommitdiff
path: root/emulators/qemu/Makefile
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2009-03-08 17:09:43 +0000
committerJuergen Lock <nox@FreeBSD.org>2009-03-08 17:09:43 +0000
commite332617a7d04779931f8a5672946248611972643 (patch)
tree91300d0dc1bba025d68f3972602e7ebd337f8d6c /emulators/qemu/Makefile
parentUpdate to 0.7.22. (diff)
Update to 0.10.0 - from the official changelog:
- TCG support (No longer requires GCC 3.x) - Kernel Virtual Machine acceleration support [kernel bits not ported to FreeBSD yet] - BSD userspace emulation [untested on FreeBSD, probably doesn't work at least for i386 hosts] - Bluetooth emulation and host passthrough support [not ported to FreeBSD yet] - GDB XML register description support - Intel e1000 emulation - HPET emulation - VirtIO paravirtual device support - Marvell 88w8618 / MusicPal emulation - Nokia N-series tablet emulation / OMAP2 processor emulation - PCI hotplug support - Live migration and new save/restore formats - Curses display support - qemu-nbd utility to mount supported block formats [not ported to FreeBSD yet] - Altivec support in PPC emulation and new firmware (OpenBIOS) - Multiple VNC clients are now supported - TLS encryption is now supported in VNC - MIPS Magnum R4000 machine (Herve Poussineau) - Braille support (Samuel Thibault) - Freecom MusicPal system emulation (Jan Kiszka) - OMAP242x and Nokia N800, N810 machines (Andrzej Zaborowski) - EsounD audio driver (Frederick Reeve) - Gravis Ultrasound GF1 sound card (Tibor "TS" Schuetz) - Many, many, bug fixes and new features
Diffstat (limited to 'emulators/qemu/Makefile')
-rw-r--r--emulators/qemu/Makefile43
1 files changed, 28 insertions, 15 deletions
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index 8f8fd0c60447..2d594aa7fd71 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -6,15 +6,12 @@
#
PORTNAME= qemu
-PORTVERSION= 0.9.1
-PORTREVISION= 11
+PORTVERSION= 0.10.0
CATEGORIES= emulators
-MASTER_SITES= http://bellard.org/qemu/:release \
- http://qemu.org/:release \
- http://people.freebsd.org/~maho/qemu/:misc
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:release
+MASTER_SITES= ${MASTER_SITE_SAVANNAH} \
+ http://bellard.org/qemu/
+MASTER_SITE_SUBDIR= qemu
DIST_SUBDIR= qemu
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= nox@FreeBSD.org
COMMENT= QEMU CPU Emulator
@@ -22,9 +19,7 @@ COMMENT= QEMU CPU Emulator
HAS_CONFIGURE= yes
USE_GMAKE= yes
USE_PERL5= yes
-USE_GCC= 3.4
-PATCH_STRIP= -lp1
-CONFIGURE_ARGS+= --prefix=${PREFIX} --cc=${CC}
+PATCH_STRIP= -p1
MAKE_ENV+= BSD_MAKE="${MAKE}" LDFLAGS="${LDFLAGS}"
MAN1= qemu.1 qemu-img.1
ONLY_FOR_ARCHS= amd64 i386
@@ -35,12 +30,23 @@ OPTIONS= KQEMU "Build with (alpha!) accelerator module" Off \
SAMBA "samba dependency (for -smb)" Off \
SDL "SDL/X dependency (graphical output)" On \
GNUTLS "gnutls dependency (vnc encryption)" On \
- CDROM_DMA "IDE CDROM DMA" On
+ PCAP "pcap dependency (networking with bpf)" On \
+ CDROM_DMA "IDE CDROM DMA" On \
+ ADD_AUDIO "Emulate more audio hardware (experimental!)" Off \
+ ALL_TARGETS "Also build non-x86 targets" On
.include <bsd.port.pre.mk>
+.if defined(WITHOUT_ALL_TARGETS)
+CONFIGURE_ARGS+= --target-list=i386-softmmu,x86_64-softmmu
+PLIST_SUB+= ALLTARGETS="@comment "
+.else
+PLIST_SUB+= ALLTARGETS=""
+.endif
+
WITHOUT_CPU_CFLAGS=yes #to avoid problems with register allocation
CFLAGS:= ${CFLAGS:C/-fno-tree-vrp//}
+CONFIGURE_ARGS+= --prefix=${PREFIX} --cc=${CC}
.if defined(WITHOUT_SDL)
CONFIGURE_ARGS+= --disable-sdl --disable-gfx-check
@@ -49,13 +55,17 @@ USE_SDL= sdl
.endif
.if defined(WITHOUT_GNUTLS)
-CONFIGURE_ARGS+= --disable-vnc-tls
+CONFIGURE_ARGS+= --disable-vnc-tls
.else
LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
.endif
-.if defined (WITH_HACKS_CIRRUS) || defined (WITH_HACKS)
-DISTFILES+= patch3_cirrus:misc
+.if defined(WITH_PCAP)
+CONFIGURE_ARGS+= --enable-pcap
+.endif
+
+.if defined(WITH_ADD_AUDIO)
+CONFIGURE_ARGS+= --audio-card-list=ac97,es1370,sb16,cs4231a,adlib,gus
.endif
.if defined(WITH_SAMBA)
@@ -63,7 +73,7 @@ RUN_DEPENDS+= ${LOCALBASE}/sbin/smbd:${PORTSDIR}/net/samba3
.endif
.if defined(WITH_KQEMU)
-BUILD_DEPENDS+= kqemu-kmod>=1.3.0pre5:${PORTSDIR}/emulators/kqemu-kmod
+BUILD_DEPENDS+= kqemu-kmod-devel>=1.4.0pre1:${PORTSDIR}/emulators/kqemu-kmod-devel
.else
CONFIGURE_ARGS+= --disable-kqemu
.endif
@@ -92,6 +102,9 @@ post-patch:
.if defined(WITH_RTL8139_TIMER)
@cd ${WRKSRC} && ${PATCH} --quiet < ${FILESDIR}/rtl8139-re-patch
.endif
+.if defined(WITH_PCAP)
+ @cd ${WRKSRC} && ${PATCH} --quiet < ${FILESDIR}/pcap-patch
+.endif
.if defined(WITHOUT_CDROM_DMA)
@cd ${WRKSRC} && ${PATCH} --quiet < ${FILESDIR}/cdrom-dma-patch
.endif