summaryrefslogtreecommitdiff
path: root/emulators/qemu-devel/Makefile
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2013-07-18 17:54:56 +0000
committerJuergen Lock <nox@FreeBSD.org>2013-07-18 17:54:56 +0000
commitf4fca75acf11bb9d675f5b06fc6c609484ff75fe (patch)
tree22d161c39331db682fcd3eed6e5560a16c2d3534 /emulators/qemu-devel/Makefile
parentFix an arithmetic overflow in the RICE2 partitioner. (diff)
- Add missing USES=pkgconfig.
- Rename GTK knob to GTK2. Submitted by: olgeni (via private email)
Diffstat (limited to 'emulators/qemu-devel/Makefile')
-rw-r--r--emulators/qemu-devel/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index 05d6ed5204ef..72ef12558a79 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= pixman-1:${PORTSDIR}/x11/pixman
HAS_CONFIGURE= yes
USE_BZIP2= yes
-USES= gmake
+USES= gmake pkgconfig
USE_PERL5_BUILD= yes
USE_PYTHON_BUILD= yes
USE_GNOME+= glib20
@@ -30,7 +30,7 @@ ONLY_FOR_ARCHS= amd64 i386 powerpc # XXX someone wants to debug sparc64 hosts?
CONFLICTS_INSTALL= qemu-[0-9]*
MAKE_JOBS_SAFE= yes
-OPTIONS_DEFINE= SAMBA X11 GTK OPENGL GNUTLS SASL JPEG PNG CURL \
+OPTIONS_DEFINE= SAMBA X11 GTK2 OPENGL GNUTLS SASL JPEG PNG CURL \
CDROM_DMA PCAP USBREDIR GNS3 X86_TARGETS BSD_USER \
STATIC_LINK DOCS
SAMBA_DESC= samba dependency (for -smb)
@@ -46,7 +46,7 @@ GNS3_DESC= gns3 patches (promiscuous multicast)
X86_TARGETS_DESC= Don't build non-x86 system targets
BSD_USER_DESC= Also build bsd-user targets (for testing)
STATIC_LINK_DESC= Statically link the executables
-OPTIONS_DEFAULT=X11 GTK OPENGL GNUTLS SASL JPEG PNG CDROM_DMA CURL PCAP
+OPTIONS_DEFAULT=X11 GTK2 OPENGL GNUTLS SASL JPEG PNG CDROM_DMA CURL PCAP
.include <bsd.port.options.mk>
@@ -115,13 +115,13 @@ CONFIGURE_ARGS+= --enable-sdl
USE_SDL= sdl
.endif
-.if empty(PORT_OPTIONS:MGTK)
+.if empty(PORT_OPTIONS:MGTK2)
CONFIGURE_ARGS+= --disable-gtk
-PLIST_SUB+= GTK="@comment "
+PLIST_SUB+= GTK2="@comment "
.else
USE_GNOME+= gtk20 vte
USES+= gettext
-PLIST_SUB+= GTK=""
+PLIST_SUB+= GTK2=""
.endif
.if empty(PORT_OPTIONS:MGNUTLS)
@@ -172,7 +172,7 @@ CONFIGURE_ARGS+= --enable-pcap
.endif
.if ${PORT_OPTIONS:MSTATIC_LINK}
-.if ${PORT_OPTIONS:MGTK} || ${PORT_OPTIONS:MX11}
+.if ${PORT_OPTIONS:MGTK2} || ${PORT_OPTIONS:MX11}
IGNORE= X11 ui cannot be built static
.endif
CONFIGURE_ARGS+= --static