summaryrefslogtreecommitdiff
path: root/emulators/qemu-devel/Makefile
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2014-01-19 22:27:14 +0000
committerJuergen Lock <nox@FreeBSD.org>2014-01-19 22:27:14 +0000
commitd792df742746f81a6e14a799b90ad4711720a93c (patch)
treebbc7ae9c75621815b98f4a3e651c35a4c285552c /emulators/qemu-devel/Makefile
parent- Update to 2.2.1. (diff)
- Remove last mentions of SEABIOS_GIT. (which were nops already tho)
- Update LIB_DEPENDS. - Rewrite NOPORTDOCS. - Stagify. - Fix plist. (empty dirs) - Bump PORTREISION. Submitted by: rene (via private emai)
Diffstat (limited to 'emulators/qemu-devel/Makefile')
-rw-r--r--emulators/qemu-devel/Makefile37
1 files changed, 14 insertions, 23 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index 66b1208fab01..38306296dc55 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= qemu
PORTVERSION= 1.7.0
+PORTREISION= 1
CATEGORIES= emulators
MASTER_SITES= http://wiki.qemu.org/download/:release \
LOCAL/nox:snapshot
@@ -22,8 +23,6 @@ USE_XORG= pixman
USE_GNOME+= glib20
PATCH_STRIP= -p1
MAKE_ENV+= BSD_MAKE="${MAKE}"
-MAN1= qemu.1 qemu-img.1
-MAN8= qemu-nbd.8
ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64 # XXX someone wants to debug sparc64 hosts?
CONFLICTS_INSTALL= qemu-[0-9]*
@@ -37,7 +36,6 @@ JPEG_DESC= jpeg dependency (vnc lossy compression)
PNG_DESC= png dependency (vnc compression)
CDROM_DMA_DESC= IDE CDROM DMA
PCAP_DESC= pcap dependency (networking with bpf)
-SEABIOS_GIT_DESC= add seabios snapshot (-bios bios.bin-1.6.3.1)
USBREDIR_DESC= usb device network redirection (experimental!)
GNS3_DESC= gns3 patches (promiscuous multicast)
X86_TARGETS_DESC= Don't build non-x86 system targets
@@ -45,8 +43,6 @@ BSD_USER_DESC= Also build bsd-user targets (for testing)
STATIC_LINK_DESC= Statically link the executables
OPTIONS_DEFAULT=X11 GTK2 OPENGL GNUTLS SASL JPEG PNG CDROM_DMA CURL PCAP
-NO_STAGE= yes
-
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MBSD_USER}
@@ -150,31 +146,31 @@ PLIST_SUB+= GTK2=""
.if empty(PORT_OPTIONS:MGNUTLS)
CONFIGURE_ARGS+= --disable-vnc-tls
.else
-LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
+LIB_DEPENDS+= libgnutls.so:${PORTSDIR}/security/gnutls
.endif
.if empty(PORT_OPTIONS:MSASL)
CONFIGURE_ARGS+= --disable-vnc-sasl
.else
-LIB_DEPENDS+= sasl2:${PORTSDIR}/security/cyrus-sasl2
+LIB_DEPENDS+= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
.endif
.if empty(PORT_OPTIONS:MJPEG)
CONFIGURE_ARGS+= --disable-vnc-jpeg
.else
-LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS+= libjpeg.so:${PORTSDIR}/graphics/jpeg
.endif
.if empty(PORT_OPTIONS:MPNG)
CONFIGURE_ARGS+= --disable-vnc-png
.else
-LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS+= libpng15.so:${PORTSDIR}/graphics/png
.endif
.if empty(PORT_OPTIONS:MCURL)
CONFIGURE_ARGS+= --disable-curl
.else
-LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
.endif
.if empty(PORT_OPTIONS:MOPENGL)
@@ -205,14 +201,10 @@ CONFIGURE_ARGS+= --static
RUN_DEPENDS+= ${LOCALBASE}/sbin/smbd:${PORTSDIR}/net/samba36
.endif
-.if ${PORT_OPTIONS:MSEABIOS_GIT}
-RUN_DEPENDS+= seabios-devel>=1.6.3.1:${PORTSDIR}/emulators/seabios-devel
-.endif
-
-.if defined(NOPORTDOCS)
-MAKE_ARGS+= NOPORTDOCS=1
-.else
+.if ${PORT_OPTIONS:MDOCS}
BUILD_DEPENDS+= texi2html:${PORTSDIR}/textproc/texi2html
+.else
+MAKE_ARGS+= NOPORTDOCS=1
.endif
.if !defined(STRIP) || ${STRIP} == ""
@@ -287,16 +279,15 @@ post-configure:
post-install:
.if ${PORT_OPTIONS:MDOCS}
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} docs ${DOCSDIR}/)
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} docs ${STAGEDIR}${DOCSDIR}/)
.endif
- @${INSTALL_SCRIPT} ${FILESDIR}/qemu-ifup.sample ${PREFIX}/etc
- @${INSTALL_SCRIPT} ${FILESDIR}/qemu-ifdown.sample ${PREFIX}/etc
+ @${INSTALL_SCRIPT} ${FILESDIR}/qemu-ifup.sample ${STAGEDIR}${PREFIX}/etc
+ @${INSTALL_SCRIPT} ${FILESDIR}/qemu-ifdown.sample ${STAGEDIR}${PREFIX}/etc
@if [ ! -f ${PREFIX}/etc/qemu-ifup ]; then \
- ${CP} -p ${PREFIX}/etc/qemu-ifup.sample ${PREFIX}/etc/qemu-ifup ; \
+ ${CP} -p ${STAGEDIR}${PREFIX}/etc/qemu-ifup.sample ${STAGEDIR}${PREFIX}/etc/qemu-ifup ; \
fi
@if [ ! -f ${PREFIX}/etc/qemu-ifdown ]; then \
- ${CP} -p ${PREFIX}/etc/qemu-ifdown.sample ${PREFIX}/etc/qemu-ifdown ; \
+ ${CP} -p ${STAGEDIR}${PREFIX}/etc/qemu-ifdown.sample ${STAGEDIR}${PREFIX}/etc/qemu-ifdown ; \
fi
- @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>