summaryrefslogtreecommitdiff
path: root/emulators/qemu-devel/Makefile
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2010-01-17 16:20:56 +0000
committerJuergen Lock <nox@FreeBSD.org>2010-01-17 16:20:56 +0000
commitd4e517700042730d5420402bec25ccfa88fed6c8 (patch)
treefa8e73dd336e8f03ab2c5b0677215cf74cc8885a /emulators/qemu-devel/Makefile
parentAdd cl-trivial-features, which ensures consistent *FEATURES* across multiple (diff)
Finally bring qemu 0.12.1 into ports as the new emulators/qemu-devel,
release announcement is here: http://lists.gnu.org/archive/html/qemu-devel/2009-12/msg02151.html Quoting from pkg-message: - kqemu is no longer supported in qemu upstream after the 0.11 branch was created, which means also not in this version. (Linux has moved on to kvm now for qemu(-like) virtualization needs, so if you want qemu to go faster and don't want to switch to virtualbox or stick to the older emulators/qemu port which is at 0.11.1 atm and as such still supports kqemu you should help getting the FreeBSD kvm port updated and completed: http://wiki.freebsd.org/FabioChecconi/PortingLinuxKVMToFreeBSD )
Diffstat (limited to 'emulators/qemu-devel/Makefile')
-rw-r--r--emulators/qemu-devel/Makefile52
1 files changed, 19 insertions, 33 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index ee9aae3d0069..ab2a64487b40 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -6,53 +6,45 @@
#
PORTNAME= qemu
-PORTVERSION= 0.9.1s.20080620
-PORTREVISION= 5
+PORTVERSION= 0.12.1
CATEGORIES= emulators
-MASTER_SITES= http://bellard.org/qemu/:release \
- http://qemu-forum.ipi.fi/qemu-snapshots/:snapshot \
- ${MASTER_SITE_LOCAL}:snapshot
-MASTER_SITE_SUBDIR= nox/:snapshot
+MASTER_SITES= ${MASTER_SITE_SAVANNAH}:release \
+ ${MASTER_SITE_LOCAL}:snapshot \
+ http://people.freebsd.org/~nox/qemu/:snapshot
+MASTER_SITE_SUBDIR= qemu/:release nox/:snapshot
PKGNAMESUFFIX= -devel
-DISTNAME= ${PORTNAME}-snapshot-2008-06-20_19
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:snapshot
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:release
DIST_SUBDIR= qemu
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= nox@FreeBSD.org
COMMENT= QEMU CPU Emulator - development snapshot
HAS_CONFIGURE= yes
-USE_BZIP2= yes
USE_GMAKE= yes
USE_PERL5= yes
-PATCH_STRIP= -lp1
+PATCH_STRIP= -p1
MAKE_ENV+= BSD_MAKE="${MAKE}" LDFLAGS="${LDFLAGS}"
MAN1= qemu.1 qemu-img.1
ONLY_FOR_ARCHS= amd64 i386
CONFLICTS= qemu-[0-9]*
MAKE_JOBS_SAFE= yes
-# comment this if you really want to build this version:
-IGNORE= is currently an older snapshot than emulators/qemu
-
-OPTIONS= KQEMU "Build with (alpha!) accelerator module" Off \
- RTL8139_TIMER "allow use of re(4) nic with FreeBSD guests" Off \
+OPTIONS= RTL8139_TIMER "allow use of re(4) nic with FreeBSD guests" Off \
SAMBA "samba dependency (for -smb)" Off \
SDL "SDL/X dependency (graphical output)" On \
GNUTLS "gnutls dependency (vnc encryption)" On \
PCAP "pcap dependency (networking with bpf)" On \
CDROM_DMA "IDE CDROM DMA" On \
- ALL_TARGETS "Also build dyngen targets (requires gcc34)" On
+ ADD_AUDIO "Emulate more audio hardware (experimental!)" Off \
+ ALL_TARGETS "Also build non-x86 and user targets" On
.include <bsd.port.pre.mk>
.if defined(WITHOUT_ALL_TARGETS)
-CONFIGURE_ARGS+= --disable-gcc-check --target-list=i386-softmmu,sparc-softmmu,x86_64-softmmu,mips-softmmu,mipsel-softmmu,mips64-softmmu,mips64el-softmmu,arm-softmmu,m68k-softmmu,cris-softmmu
-PLIST_SUB+= DYNGEN="@comment "
+CONFIGURE_ARGS+= --target-list=i386-softmmu,x86_64-softmmu
+PLIST_SUB+= ALLTARGETS="@comment "
.else
-USE_GCC= 3.4
-PLIST_SUB+= DYNGEN=""
+PLIST_SUB+= ALLTARGETS=""
.endif
WITHOUT_CPU_CFLAGS=yes #to avoid problems with register allocation
@@ -60,7 +52,7 @@ CFLAGS:= ${CFLAGS:C/-fno-tree-vrp//}
CONFIGURE_ARGS+= --prefix=${PREFIX} --cc=${CC}
.if defined(WITHOUT_SDL)
-CONFIGURE_ARGS+= --disable-sdl --disable-gfx-check
+CONFIGURE_ARGS+= --disable-sdl
.else
USE_SDL= sdl
.endif
@@ -75,18 +67,17 @@ LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
CONFIGURE_ARGS+= --enable-pcap
.endif
-.if defined(WITH_SAMBA)
-RUN_DEPENDS+= ${LOCALBASE}/sbin/smbd:${PORTSDIR}/net/samba3
+.if defined(WITH_ADD_AUDIO)
+CONFIGURE_ARGS+= --audio-card-list=ac97,es1370,sb16,cs4231a,adlib,gus
.endif
-.if defined(WITH_KQEMU)
-BUILD_DEPENDS+= kqemu-kmod-devel>=1.4.0pre1:${PORTSDIR}/emulators/kqemu-kmod-devel
-.else
-CONFIGURE_ARGS+= --disable-kqemu
+.if defined(WITH_SAMBA)
+RUN_DEPENDS+= ${LOCALBASE}/sbin/smbd:${PORTSDIR}/net/samba3
.endif
.if defined(NOPORTDOCS)
MAKE_ARGS+= NOPORTDOCS=${NOPORTDOCS}
+CONFIGURE_ARGS+= --disable-docs
.else
BUILD_DEPENDS+= texi2html:${PORTSDIR}/textproc/texi2html
.endif
@@ -95,11 +86,6 @@ BUILD_DEPENDS+= texi2html:${PORTSDIR}/textproc/texi2html
MAKE_ARGS+= ARCH=x86_64
.endif
-post-extract:
- @${MKDIR} ${WRKSRC}/kqemu
- @${TOUCH} ${WRKSRC}/kqemu/Makefile
- @${ECHO} all: > ${WRKSRC}/kqemu/Makefile.freebsd
-
pre-patch:
@for A in ${ONLY_FOR_ARCHS}; do \
${MKDIR} ${WRKSRC}/bsd/$$A; \