summaryrefslogtreecommitdiff
path: root/emulators/qemu-devel/Makefile
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2005-12-31 00:12:20 +0000
committerMaho Nakata <maho@FreeBSD.org>2005-12-31 00:12:20 +0000
commit58ed0a6bf93ee4d0c21ee29f5026df11e203ade7 (patch)
treea3ec173d46415e364857f408becea5bba432971b /emulators/qemu-devel/Makefile
parentHandle a change in rc.subr. Nowadays, "faststart" is used instead of (diff)
Add a knob WITH_HACKS. we now have IDE Bus-master DMA Support.
(However, this will break existing Windows 2000 or XP installations). Approved by: maintainer
Diffstat (limited to 'emulators/qemu-devel/Makefile')
-rw-r--r--emulators/qemu-devel/Makefile18
1 files changed, 17 insertions, 1 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index 74bf2975086e..c4e701205973 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -12,8 +12,14 @@ CATEGORIES= emulators
MASTER_SITES= http://www.qemu.org/:release \
http://people.fruitsalad.org/nox/qemu/:snapshot \
http://www.volny.cz/xnavara/qemu/:snapshot \
- http://qemu.dad-answers.com/download/qemu/:snapshot
+ http://qemu.dad-answers.com/download/qemu/:snapshot \
+ http://people.brandeis.edu/~jcoiner/qemu_idedma/:idedma
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:release
+.if defined (WITH_HACKS)
+DISTFILES+= qemu_dma_patch.tar.gz:idedma
+.endif
+DIST_SUBDIR= qemu
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= nox@jelal.kn-bremen.de
COMMENT= QEMU CPU Emulator
@@ -54,6 +60,11 @@ pre-everything::
@${ECHO_MSG} "Notice: you can build qemu with the (alpha!) kqemu accelerator kernel module"
@${ECHO_MSG} "by defining WITH_KQEMU."
.endif
+.if !defined(WITH_HACKS)
+ @${ECHO_MSG} "You can build qemu with some hacks (esp. for speedup)"
+ @${ECHO_MSG} "by defining WITH_HACKS."
+ @${ECHO_MSG} "1. IDE Bus-master DMA Support by John Coiner"
+.endif
.if !defined(WITH_SAMBA) && !exists(${LOCALBASE}/sbin/smbd)
@${ECHO_MSG} "Notice: if you need qemu's -smb option (smb-export local dir to guest)"
@${ECHO_MSG} "then you also need samba, you can have this port install it by defining"
@@ -70,6 +81,11 @@ pre-patch:
${MKDIR} ${WRKSRC}/bsd/$$A; \
done
+post-patch:
+.if defined(WITH_HACKS)
+ @cd ${WRKDIR} ; ${TAR} xvfz ${DISTDIR}/${DIST_SUBDIR}/qemu_dma_patch.tar.gz ; ${CP} new_qemu_dma_patch/bios.bin ${WRKSRC}/pc-bios; cd ${WRKSRC}; ${PATCH} -p1 < ../new_qemu_dma_patch/qemu-piix4-udma.patch
+.endif
+
post-install:
@${CAT} ${PKGMESSAGE}