summaryrefslogtreecommitdiff
path: root/emulators/qemu-devel/Makefile
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2008-07-08 18:42:09 +0000
committerJuergen Lock <nox@FreeBSD.org>2008-07-08 18:42:09 +0000
commit54b840b37a44ced448a8ad0f47740ce08278f643 (patch)
treed4801d39b61ef12632cbef1176de598a3d1658c2 /emulators/qemu-devel/Makefile
parent- New port: plt-scheme (diff)
- Update to 20080620 svn snapshot, which uses the new kqemu-kmod-devel
port that now also works for the 32 bit "qemu" executable on amd64 (if you build with the KQEMU knob on, you have to deinstall the old kqemu-kmod first if it is installed) - Add an ALL_TARGETS knob that, if turned off, omits the remaining dyngen targets, eliminating the need for gcc 3.4 (everything but ppc and sh4 has been converted to tcg in this snapshot) - Add tcg fixes for amd64 guests on i386 hosts (two of three have been committed to qemu svn in the meantime) [1] - Update the pkg-message about kqemu on amd64, and add a note about using nfs with slirp, the latter [2] - Homepage now at http://bellard.org/qemu/ - update links Submitted by: nox [1] Submitted by: joerg [2]
Diffstat (limited to 'emulators/qemu-devel/Makefile')
-rw-r--r--emulators/qemu-devel/Makefile29
1 files changed, 15 insertions, 14 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index 25eff6cbd0a6..b884c690f544 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -6,17 +6,14 @@
#
PORTNAME= qemu
-PORTVERSION= 0.9.1s.20080302
-PORTREVISION= 9
+PORTVERSION= 0.9.1s.20080620
CATEGORIES= emulators
-MASTER_SITES= http://qemu.org/:release \
+MASTER_SITES= http://bellard.org/qemu/:release \
http://qemu-forum.ipi.fi/qemu-snapshots/:snapshot \
http://people.fruitsalad.org/nox/qemu/:snapshot \
- http://www.volny.cz/xnavara/qemu/:snapshot \
- http://people.brandeis.edu/~jcoiner/qemu_idedma/:idedma \
- http://people.freebsd.org/~maho/qemu/:misc
+ ${MASTER_SITE_LOCAL}:snapshot
PKGNAMESUFFIX= -devel
-DISTNAME= ${PORTNAME}-snapshot-2008-03-02_05
+DISTNAME= ${PORTNAME}-snapshot-2008-06-20_19
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:snapshot
DIST_SUBDIR= qemu
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
@@ -28,7 +25,6 @@ HAS_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_PERL5= yes
-USE_GCC= 3.4
PATCH_STRIP= -lp1
MAKE_ENV+= BSD_MAKE="${MAKE}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
MAN1= qemu.1 qemu-img.1
@@ -40,10 +36,19 @@ OPTIONS= KQEMU "Build with (alpha!) accelerator module" Off \
SAMBA "samba dependency (for -smb)" Off \
SDL "SDL/X dependency (graphical output)" On \
GNUTLS "gnutls dependency (vnc encryption)" On \
- CDROM_DMA "IDE CDROM DMA" On
+ CDROM_DMA "IDE CDROM DMA" On \
+ ALL_TARGETS "Also build dyngen targets (requires gcc34)" On
.include <bsd.port.pre.mk>
+.if defined(WITHOUT_ALL_TARGETS)
+CONFIGURE_ARGS+= --disable-gcc-check --target-list=i386-softmmu,sparc-softmmu,x86_64-softmmu,mips-softmmu,mipsel-softmmu,mips64-softmmu,mips64el-softmmu,arm-softmmu,m68k-softmmu,cris-softmmu
+PLIST_SUB+= DYNGEN="@comment "
+.else
+USE_GCC= 3.4
+PLIST_SUB+= DYNGEN=""
+.endif
+
.if ${OSVERSION} < 600000
# 5.x base gcc segfaults in target-mips/op_mem.c
BUILD_DEPENDS+= gcc34:${PORTSDIR}/lang/gcc34
@@ -66,16 +71,12 @@ CONFIGURE_ARGS+= --disable-vnc-tls
LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
.endif
-.if defined (WITH_HACKS_CIRRUS) || defined (WITH_HACKS)
-DISTFILES+= patch3_cirrus:misc
-.endif
-
.if defined(WITH_SAMBA)
RUN_DEPENDS+= ${LOCALBASE}/sbin/smbd:${PORTSDIR}/net/samba3
.endif
.if defined(WITH_KQEMU)
-BUILD_DEPENDS+= kqemu-kmod>=1.3.0pre5:${PORTSDIR}/emulators/kqemu-kmod
+BUILD_DEPENDS+= kqemu-kmod-devel>=1.4.0pre1:${PORTSDIR}/emulators/kqemu-kmod-devel
.else
CONFIGURE_ARGS+= --disable-kqemu
.endif