summaryrefslogtreecommitdiff
path: root/emulators/qemu-devel/Makefile
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2005-01-08 16:21:01 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2005-01-08 16:21:01 +0000
commit51597918190f2f3f8ed6c8cd65a0537b6a668e38 (patch)
tree184ebeb16df36026e310757ad250f8bad2d32123 /emulators/qemu-devel/Makefile
parentUpdate to version 0.32.2 (diff)
Update to 0.6.2 (2004/12/28 snapshot).
PR: ports/75644 Submitted by: Juergen Lock <nox@jelal.kn-bremen.de> (maintainer)
Diffstat (limited to 'emulators/qemu-devel/Makefile')
-rw-r--r--emulators/qemu-devel/Makefile22
1 files changed, 17 insertions, 5 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index e17b56b8ea26..a76550d179fb 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= qemu
-PORTVERSION= 0.6.1s.20041115
+PORTVERSION= 0.6.2s.20041228
PORTREVISION= 0
CATEGORIES= emulators
-MASTER_SITES= http://www.fruitsalad.org/qemu/ \
+MASTER_SITES= http://people.fruitsalad.org/nox/qemu/ \
http://dad-answers.com/qemu/
-DISTNAME= ${PORTNAME}-snapshot-2004-11-15_23
+DISTNAME= ${PORTNAME}-snapshot-2004-12-28_23
MAINTAINER= nox@jelal.kn-bremen.de
COMMENT= QEMU CPU Emulator
@@ -24,14 +24,26 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_GETOPT_LONG= yes
USE_SDL= sdl
-USE_GCC= 3.4
USE_PERL5= yes
PATCH_STRIP= -p1
CONFIGURE_ARGS+= --prefix=${PREFIX} --cc=${CC}\ -I${PREFIX}/include
MAN1= qemu.1 qemu-img.1
ONLY_FOR_ARCHS= i386 amd64 powerpc
+# gcc34 (system cc on 5.x now) has problems with qemu:
+# doesnt build target-i386/op.c on amd64, and builds a broken qemu-system-ppc
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+CC= gcc33
+CXX= g++33
+BUILD_DEPENDS+= gcc33:${PORTSDIR}/lang/gcc33
+GCCVERSION= 030301
+.else
+USE_GCC= 3.3
+.endif
+
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>