summaryrefslogtreecommitdiff
path: root/emulators/qemu-devel/Makefile
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2013-12-30 22:24:45 +0000
committerJuergen Lock <nox@FreeBSD.org>2013-12-30 22:24:45 +0000
commit150b789f3251eef3d123d2679de50c9ab79f626b (patch)
treedcb9c7cd78bb1383f5496f95183e43ba5de45b75 /emulators/qemu-devel/Makefile
parentUpdate to version 20131230. (diff)
- Update to 1.7.0, announce message is here:
http://lists.nongnu.org/archive/html/qemu-devel/2013-12/msg01770.html - Bring back BSD_USER knob thanx to sson's latest patches. [1] Submitted by: sson [1]
Diffstat (limited to 'emulators/qemu-devel/Makefile')
-rw-r--r--emulators/qemu-devel/Makefile43
1 files changed, 35 insertions, 8 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index ad7dad7c9e5c..583c1c499609 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= qemu
-PORTVERSION= 1.6.1
-PORTREVISION= 1
+PORTVERSION= 1.7.0
CATEGORIES= emulators
MASTER_SITES= http://wiki.qemu.org/download/:release \
LOCAL/nox:snapshot
@@ -29,7 +28,7 @@ ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64 # XXX someone wants to debug sparc6
CONFLICTS_INSTALL= qemu-[0-9]*
OPTIONS_DEFINE= SAMBA X11 GTK2 OPENGL GNUTLS SASL JPEG PNG CURL \
- CDROM_DMA PCAP USBREDIR GNS3 X86_TARGETS \
+ CDROM_DMA PCAP USBREDIR GNS3 X86_TARGETS BSD_USER \
STATIC_LINK DOCS
SAMBA_DESC= samba dependency (for -smb)
GNUTLS_DESC= gnutls dependency (vnc encryption)
@@ -50,16 +49,40 @@ NO_STAGE= yes
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MBSD_USER}
+PATCH_SITES= http://people.freebsd.org/~sson/qemu/qemu-bsd-user/
+PATCHFILES= \
+ 0001-bsd-user-refresh-freebsd-system-call-numbers.patch \
+ 0002-bsd-user-add-HOST_VARIANT_DIR-for-various-BSD-depend.patch \
+ 0003-bsd-user-move-strace-OS-arch-dependent-code-to-host-.patch \
+ 0004-bsd-user-move-arch-OS-dependent-code-out-of-main.c.patch \
+ 0005-bsd-user-move-arch-OS-dependent-code-out-of-syscall..patch \
+ 0006-bsd-user-add-support-for-freebsd-time-related-system.patch \
+ 0007-bsd-user-add-support-for-freebsd-signal-related-syst.patch \
+ 0008-bsd-user-move-arch-OS-dependent-code-out-of-elfload..patch \
+ 0009-bsd-user-add-support-for-freebsd-process-related-sys.patch \
+ 0010-bsd-user-add-support-for-file-system-related-system-.patch \
+ 0011-bsd-user-add-support-for-stat-dir-and-fcntl-related-.patch \
+ 0012-bsd-user-add-support-for-memory-management-related-s.patch \
+ 0013-bsd-user-add-support-for-socket-related-system-calls.patch \
+ 0014-bsd-user-add-support-for-thread-related-system-calls.patch \
+ 0015-bsd-user-add-support-for-the-ioctl-system-call.patch \
+ 0016-bsd-user-add-support-for-extattr-and-ACL-related-sys.patch \
+ 0017-bsd-user-add-support-for-miscellaneous-system-calls.patch \
+ 0018-bsd-user-add-arm-mips-and-mips64-options-to-configur.patch
+PATCH_DIST_STRIP= -p1
+.endif
+
CONFIGURE_ARGS+= --extra-ldflags=-L${LOCALBASE}/lib
-CONFIGURE_ARGS+= --disable-smartcard-nss
+CONFIGURE_ARGS+= --disable-smartcard-nss --disable-libssh2
PORTDOCS= docs qemu-doc.html qemu-tech.html qmp-commands.txt
.if ${PORT_OPTIONS:MX86_TARGETS}
.if ${PORT_OPTIONS:MBSD_USER}
.if ${ARCH} != "amd64"
-CONFIGURE_ARGS+= --enable-nptl --target-list=i386-softmmu,x86_64-softmmu,i386-bsd-user,sparc-bsd-user,arm-bsd-user,armeb-bsd-user,mips-bsd-user,mipsel-bsd-user
+CONFIGURE_ARGS+= --target-list=i386-softmmu,x86_64-softmmu,i386-bsd-user,sparc-bsd-user,arm-bsd-user,mips-bsd-user,mipsel-bsd-user
.else
-CONFIGURE_ARGS+= --enable-nptl --target-list=i386-softmmu,x86_64-softmmu,i386-bsd-user,x86_64-bsd-user,sparc-bsd-user,sparc64-bsd-user,arm-bsd-user,armeb-bsd-user,mips-bsd-user,mipsel-bsd-user,mips64-bsd-user
+CONFIGURE_ARGS+= --target-list=i386-softmmu,x86_64-softmmu,i386-bsd-user,x86_64-bsd-user,sparc-bsd-user,sparc64-bsd-user,arm-bsd-user,mips-bsd-user,mipsel-bsd-user,mips64-bsd-user,mips64el-bsd-user
.endif
.else
CONFIGURE_ARGS+= --target-list=i386-softmmu,x86_64-softmmu
@@ -68,9 +91,8 @@ CONFIGURE_ARGS+= --target-list=i386-softmmu,x86_64-softmmu
.if empty(PORT_OPTIONS:MBSD_USER)
CONFIGURE_ARGS+= --disable-bsd-user
.else
-CONFIGURE_ARGS+= --enable-nptl
.if ${ARCH} != "amd64"
-CONFIGURE_ARGS+= --target-list=i386-softmmu,x86_64-softmmu,alpha-softmmu,arm-softmmu,cris-softmmu,lm32-softmmu,m68k-softmmu,microblaze-softmmu,microblazeel-softmmu,mips-softmmu,mipsel-softmmu,mips64-softmmu,mips64el-softmmu,or32-softmmu,ppc-softmmu,ppcemb-softmmu,ppc64-softmmu,sh4-softmmu,sh4eb-softmmu,sparc-softmmu,sparc64-softmmu,s390x-softmmu,xtensa-softmmu,xtensaeb-softmmu,unicore32-softmmu,moxie-softmmu,i386-bsd-user,sparc-bsd-user,arm-bsd-user,armeb-bsd-user,mips-bsd-user,mipsel-bsd-user
+CONFIGURE_ARGS+= --target-list=i386-softmmu,x86_64-softmmu,alpha-softmmu,arm-softmmu,cris-softmmu,lm32-softmmu,m68k-softmmu,microblaze-softmmu,microblazeel-softmmu,mips-softmmu,mipsel-softmmu,mips64-softmmu,mips64el-softmmu,or32-softmmu,ppc-softmmu,ppcemb-softmmu,ppc64-softmmu,sh4-softmmu,sh4eb-softmmu,sparc-softmmu,sparc64-softmmu,s390x-softmmu,xtensa-softmmu,xtensaeb-softmmu,unicore32-softmmu,moxie-softmmu,i386-bsd-user,sparc-bsd-user,arm-bsd-user,mips-bsd-user,mipsel-bsd-user
.endif
.endif
.endif
@@ -218,6 +240,11 @@ MAKE_ENV+= COMPILER_PATH=${LOCALBASE}/bin
CONFIGURE_ARGS+= --python=${PYTHON_CMD}
+.if ${PORT_OPTIONS:MBSD_USER}
+pre-patch:
+ @cd ${WRKSRC} && ${PATCH} --quiet < ${FILESDIR}/prepatch-configure
+.endif
+
# -lprocstat actually only _needs_ -lelf after r249666 or r250870 (MFC)
# but it shouldn't matter much
post-patch: