summaryrefslogtreecommitdiff
path: root/emulators/mupen64-dummyaudio
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-10-12 04:57:04 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-10-12 04:57:04 +0000
commit66bef42e6b828d3fe36ce421f466fcc6ac224004 (patch)
tree38d6fe914faf0e32dff6ec4daeab828c16c0c59d /emulators/mupen64-dummyaudio
parentMupen64 base (diff)
Dummy sound plugin for Mupen64
- Mupen64 is a highly portable Nintendo 64 emulator. It has been developed on/for Linux originally but has already been ported successfully to other operating systems. The program can easily be ported to all operating systems supported by the SDL library. In its current state, the emulator is highly compatible and uses a plugin system. With the correct plugins ("correct" can be computer dependent), it can achieve nearly perfect graphics and sound in many games. WWW: http://mupen64.emulation64.com/ PR: 71895 Submitted by: Travis Poppe
Diffstat (limited to 'emulators/mupen64-dummyaudio')
-rw-r--r--emulators/mupen64-dummyaudio/Makefile46
-rw-r--r--emulators/mupen64-dummyaudio/distinfo2
-rw-r--r--emulators/mupen64-dummyaudio/files/patch-Makefile14
-rw-r--r--emulators/mupen64-dummyaudio/pkg-descr15
-rw-r--r--emulators/mupen64-dummyaudio/pkg-message9
5 files changed, 86 insertions, 0 deletions
diff --git a/emulators/mupen64-dummyaudio/Makefile b/emulators/mupen64-dummyaudio/Makefile
new file mode 100644
index 000000000000..642894e47154
--- /dev/null
+++ b/emulators/mupen64-dummyaudio/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: mupen64-dummyaudio
+# Date created: 12.Aug 2004
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= mupen64
+PORTVERSION= 0.4
+CATEGORIES+= emulators
+MASTER_SITES= http://mupen64.emulation64.com/files/${PORTVERSION}/
+PKGNAMESUFFIX= -dummyaudio
+DISTNAME= dummyaudio
+
+MAINTAINER?= tlp@LiquidX.org
+COMMENT= Dummy audio plugin for Mupen64
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GCC= 3.4
+ONLY_FOR_ARCHS= i386
+WRKSRC= ${WRKDIR}/dummy
+
+PLUGIN_NAME= dummyaudio
+PLIST_FILES= share/mupen64/plugins/${PLUGIN_NAME}.so
+PLIST_DIRS= share/mupen64/plugins
+PLIST_DIRS+= share/mupen64
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/mupen64/plugins
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PLUGIN_NAME}.so \
+ ${PREFIX}/share/mupen64/plugins/
+
+.include <bsd.port.pre.mk>
+
+CFLAGS+= -fPIC
+CFLAGS+= -O3 -fomit-frame-pointer -funroll-loops -ffast-math -Wall -pipe
+CFLAGS+= -DX86 -mcpu=athlon
+LDFLAGS+= -shared -Wl,-Bsymbolic -lc
+
+MAKE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" LD="${CC}"
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/emulators/mupen64-dummyaudio/distinfo b/emulators/mupen64-dummyaudio/distinfo
new file mode 100644
index 000000000000..359fd060653f
--- /dev/null
+++ b/emulators/mupen64-dummyaudio/distinfo
@@ -0,0 +1,2 @@
+MD5 (dummyaudio.tar.bz2) = b305bd25889d7a6eb195679dbc1ef55c
+SIZE (dummyaudio.tar.bz2) = 3417
diff --git a/emulators/mupen64-dummyaudio/files/patch-Makefile b/emulators/mupen64-dummyaudio/files/patch-Makefile
new file mode 100644
index 000000000000..fe54f2a294a3
--- /dev/null
+++ b/emulators/mupen64-dummyaudio/files/patch-Makefile
@@ -0,0 +1,14 @@
+--- Makefile.orig Sun Jul 4 11:44:08 2004
++++ Makefile Thu Aug 12 16:02:04 2004
+@@ -1,7 +1,7 @@
+-CC = gcc
+-CFLAGS = -O3 -fomit-frame-pointer -funroll-loops -ffast-math -mcpu=athlon -Wall
+-LD = gcc
+-LDFLAGS = -shared -Wl,-Bsymbolic
++#CC = gcc
++#CFLAGS = -O3 -fomit-frame-pointer -funroll-loops -ffast-math -mcpu=athlon -Wall
++#LD = gcc
++#LDFLAGS = -shared -Wl,-Bsymbolic
+
+ OBJECTS = audio.o
+
diff --git a/emulators/mupen64-dummyaudio/pkg-descr b/emulators/mupen64-dummyaudio/pkg-descr
new file mode 100644
index 000000000000..80ec3fec0cf4
--- /dev/null
+++ b/emulators/mupen64-dummyaudio/pkg-descr
@@ -0,0 +1,15 @@
+Dummy sound plugin for Mupen64
+-
+Mupen64 is a highly portable Nintendo 64 emulator. It has been developed
+on/for Linux originally but has already been ported successfully to other
+operating systems. The program can easily be ported to all operating systems
+supported by the SDL library.
+
+In its current state, the emulator is highly compatible and uses a plugin
+system. With the correct plugins ("correct" can be computer dependent), it
+can achieve nearly perfect graphics and sound in many games.
+
+WWW: http://mupen64.emulation64.com/
+
+- Travis Poppe
+tlp@liquidx.org
diff --git a/emulators/mupen64-dummyaudio/pkg-message b/emulators/mupen64-dummyaudio/pkg-message
new file mode 100644
index 000000000000..d53470396a22
--- /dev/null
+++ b/emulators/mupen64-dummyaudio/pkg-message
@@ -0,0 +1,9 @@
+-------------------------------------------------------------------------------
+If you have installed/upgraded any new plugins or are upgrading from a previous
+version of Mupen64, please note that in order for these changes to take effect,
+you -must- backup and then remove ~/.mupen64 first. After you have removed the
+directory, run 'mupen64' to re-create it. Then, manually copy back your save
+files/other data you need from the backup if necessary.
+
+Enjoy!
+-------------------------------------------------------------------------------