summaryrefslogtreecommitdiff
path: root/emulators/linux_base-debian
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2005-01-13 02:10:56 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2005-01-13 02:10:56 +0000
commitf8ad6f08b3dd717149351e7f20e911af53825dde (patch)
tree17af017c4ab26dc091e0518027c3b210f9117e2c /emulators/linux_base-debian
parent- Update to 3.2.6 (diff)
For some reason our rebuilt libc6 .deb package containing an ldconfig marked by
brandelf was invalid ("files list file for package `libc6' contains an empty filename"), causing an installation error. Avoid the error by instead unpacking libc6 into the installation directory, then running brandelf, then configuring libc6. Note restriction due to GNU GPL. Take maintainership.
Diffstat (limited to 'emulators/linux_base-debian')
-rw-r--r--emulators/linux_base-debian/Makefile19
1 files changed, 6 insertions, 13 deletions
diff --git a/emulators/linux_base-debian/Makefile b/emulators/linux_base-debian/Makefile
index 38537262726f..4b958e6d39d2 100644
--- a/emulators/linux_base-debian/Makefile
+++ b/emulators/linux_base-debian/Makefile
@@ -15,18 +15,16 @@ PKGNAMESUFFIX= -debian
DISTFILES= basedebs.tar util-linux-locales_2.11n-7_all.deb
EXTRACT_ONLY= basedebs.tar
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= trevor@FreeBSD.org
COMMENT= Debian base set for the Linux mode
CONFLICTS= linux_base-6* linux_base-7* linux_base-8* linux_base-gentoo* \
linux_base-rh* linux_base-suse*
ONLY_FOR_ARCHS= i386 amd64
-BUILD_DEPENDS= ${DPKG_CMD}:${PORTSDIR}/archivers/dpkg
+RESTRICTED= "binaries under GNU GPL: http://www.gnu.org/licenses/gpl.txt"
-BROKEN= "Does not build"
-EXPIRATION_DATE=2005-02-18
-DEPRECATED= ${BROKEN}
+BUILD_DEPENDS= ${DPKG_CMD}:${PORTSDIR}/archivers/dpkg
PREFIX?= ${LINUXBASE}
@@ -73,13 +71,6 @@ post-extract:
${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/util-linux-locales_2.11n-7_all.deb \
${WRKSRC}
-do-patch: build-depends
- cd ${WRKSRC} && \
- ${DPKG_CMD} -x ${LIBC6NAME}.deb ${LIBC6NAME} && \
- ${DPKG_CMD} -e ${LIBC6NAME}.deb ${LIBC6NAME}/DEBIAN && \
- ${BRANDELF} -t Linux ${WRKSRC}/${LIBC6NAME}/sbin/ldconfig && \
- ${DPKG_CMD} -b ${LIBC6NAME}
-
do-install:
# Create /dev/null for the chrooted environment
${MKDIR} ${PREFIX}/dev
@@ -107,7 +98,9 @@ do-install:
# Install the `special' base packages that must be installed before all
${DPKG} -i ${WRKSRC}/dpkg_*.deb
- ${DPKG} --force-all -i ${WRKSRC}/libc6_*.deb
+ ${DPKG} --unpack ${WRKSRC}/libc6_*.deb
+ ${BRANDELF} -t Linux ${PREFIX}/sbin/ldconfig
+ ${DPKG} --configure libc6
# Install the base packages
${MKDIR} ${WRKSRC}/instpkgs