summaryrefslogtreecommitdiff
path: root/emulators/dosbox
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2004-12-17 14:44:51 +0000
committerVolker Stolz <vs@FreeBSD.org>2004-12-17 14:44:51 +0000
commit832dcb8cf4c7690e14b6dcf1e69723dde6c447a2 (patch)
treef1012ac985b00957e95380d06b0ca10b9780e4aa /emulators/dosbox
parentAn open source clone of the Microprose game "Transport Tycoon Deluxe". (diff)
Update to 0.63
PR: ports/74303 Submitted by: Miguel Mendez Approved by: maintainer timeout
Diffstat (limited to 'emulators/dosbox')
-rw-r--r--emulators/dosbox/Makefile3
-rw-r--r--emulators/dosbox/distinfo4
-rw-r--r--emulators/dosbox/files/patch-src::dos::cdrom.h13
-rw-r--r--emulators/dosbox/files/patch-src::dos::cdrom_image.cpp17
4 files changed, 7 insertions, 30 deletions
diff --git a/emulators/dosbox/Makefile b/emulators/dosbox/Makefile
index 345e2cf6a68b..a5dd4446cabf 100644
--- a/emulators/dosbox/Makefile
+++ b/emulators/dosbox/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= dosbox
-PORTVERSION= 0.62
-PORTREVISION= 1
+PORTVERSION= 0.63
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/emulators/dosbox/distinfo b/emulators/dosbox/distinfo
index 21394ab78838..a25da6ed7081 100644
--- a/emulators/dosbox/distinfo
+++ b/emulators/dosbox/distinfo
@@ -1,2 +1,2 @@
-MD5 (dosbox-0.62.tar.gz) = 80b10f438119f9d83b44dcf175493dcb
-SIZE (dosbox-0.62.tar.gz) = 633259
+MD5 (dosbox-0.63.tar.gz) = 629413e41224ae9cdd115fdafd55cbdc
+SIZE (dosbox-0.63.tar.gz) = 648762
diff --git a/emulators/dosbox/files/patch-src::dos::cdrom.h b/emulators/dosbox/files/patch-src::dos::cdrom.h
deleted file mode 100644
index a7c8b70b771d..000000000000
--- a/emulators/dosbox/files/patch-src::dos::cdrom.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/dos/cdrom.h.orig Mon Oct 25 21:57:27 2004
-+++ src/dos/cdrom.h Mon Oct 25 21:59:27 2004
-@@ -4,8 +4,9 @@
-
- #define MAX_ASPI_CDROM 5
-
--#include <string.h>
-+#include <string>
- #include <iostream>
-+#include <fstream>
- #include <vector>
- #include "dosbox.h"
- #include "mem.h"
diff --git a/emulators/dosbox/files/patch-src::dos::cdrom_image.cpp b/emulators/dosbox/files/patch-src::dos::cdrom_image.cpp
index d6f13eca4e62..2a45cbfe8cb8 100644
--- a/emulators/dosbox/files/patch-src::dos::cdrom_image.cpp
+++ b/emulators/dosbox/files/patch-src::dos::cdrom_image.cpp
@@ -1,20 +1,11 @@
---- src/dos/cdrom_image.cpp.orig Mon Oct 25 22:00:14 2004
-+++ src/dos/cdrom_image.cpp Mon Oct 25 22:00:52 2004
+--- src/dos/cdrom_image.cpp.orig Tue Oct 5 21:55:03 2004
++++ src/dos/cdrom_image.cpp Tue Nov 23 21:11:08 2004
@@ -23,7 +23,7 @@
#include <cstdio>
#include <fstream>
#include <iostream>
--#include <limits>
-+/* #include <limits> */
+-#include <limits.h>
++/* #include <limits.h> */
#include <sstream>
#include <vector>
#include <sys/stat.h>
-@@ -572,7 +572,7 @@
- if (stat(filename.c_str(), &test) == 0) return true;
-
- // check if file with path relative to cue file exists
--#if not defined(WIN32)
-+#if !defined(WIN32)
- string tmpstr(pathname + "/" + filename);
- if (stat(tmpstr.c_str(), &test) == 0) {
- filename = tmpstr;