summaryrefslogtreecommitdiff
path: root/emulators/bochs/files
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2003-01-10 23:59:22 +0000
committerEric Anholt <anholt@FreeBSD.org>2003-01-10 23:59:22 +0000
commite5a833e15c32a3536efe81376c73dda595644fb6 (patch)
tree629b512b0280bb80db45315511f1283bb20c4ce3 /emulators/bochs/files
parentDo not try to S/${_CPUCFLAGS}//g when _CPUCFLAGS is not defined or empty (diff)
Update bochs port to 2.0.1, take maintainership.
PR: 46937 Submitted by: Ports Fury (PR), Keith Jones (patch-cdrom.cc)
Diffstat (limited to 'emulators/bochs/files')
-rw-r--r--emulators/bochs/files/patch-cdrom.cc41
-rw-r--r--emulators/bochs/files/patch-configure.in21
-rw-r--r--emulators/bochs/files/patch-iodev::soundlnx.cc14
-rw-r--r--emulators/bochs/files/patch-iodev::soundlnx.h14
4 files changed, 41 insertions, 49 deletions
diff --git a/emulators/bochs/files/patch-cdrom.cc b/emulators/bochs/files/patch-cdrom.cc
new file mode 100644
index 000000000000..808753a0db78
--- /dev/null
+++ b/emulators/bochs/files/patch-cdrom.cc
@@ -0,0 +1,41 @@
+--- iodev/cdrom.cc Sat Dec 14 21:29:42 2002
++++ iodev/cdrom.cc Fri Jan 3 13:21:31 2003
+@@ -101,6 +101,8 @@
+ #include <sys/cdio.h>
+ #include <sys/ioctl.h>
+ #include <sys/disklabel.h>
++// ntohl(x) et al have been moved out of sys/param.h in FreeBSD 5
++#include <netinet/in.h>
+
+ // XXX
+ #define BX_CD_FRAMESIZE 2048
+@@ -881,7 +883,7 @@
+ t.data_len = sizeof(tocentry);
+ t.data = &tocentry;
+
+- if (ioctl (fd, CDIOREADTOCENTRYS, &tocentry) < 0)
++ if (ioctl (fd, CDIOREADTOCENTRYS, &t) < 0)
+ BX_PANIC(("cdrom: read_toc: READTOCENTRY failed."));
+
+ buf[len++] = 0; // Reserved
+@@ -910,7 +912,7 @@
+ t.data_len = sizeof(tocentry);
+ t.data = &tocentry;
+
+- if (ioctl (fd, CDIOREADTOCENTRYS, &tocentry) < 0)
++ if (ioctl (fd, CDIOREADTOCENTRYS, &t) < 0)
+ BX_PANIC(("cdrom: read_toc: READTOCENTRY lead-out failed."));
+
+ buf[len++] = 0; // Reserved
+@@ -1123,9 +1125,8 @@
+ }
+ #elif defined(__FreeBSD__)
+ {
+- // Read the TOC to get the data size, since disklabel doesn't appear
+- // to work, sadly.
+- // Keith Jones, 16 January 2000
++ // Read the TOC to get the size of the data track.
++ // Keith Jones <freebsd.dev@blueyonder.co.uk>, 16 January 2000
+
+ #define MAX_TRACKS 100
+
diff --git a/emulators/bochs/files/patch-configure.in b/emulators/bochs/files/patch-configure.in
deleted file mode 100644
index a5a5aad8dfbc..000000000000
--- a/emulators/bochs/files/patch-configure.in
+++ /dev/null
@@ -1,21 +0,0 @@
---- configure.in.orig Wed Mar 27 17:20:32 2002
-+++ configure.in Thu May 30 21:32:01 2002
-@@ -101,8 +101,16 @@
- AC_CHECK_FUNCS(usleep, AC_DEFINE(BX_HAVE_USLEEP))
- AC_CHECK_FUNCS(nanosleep, AC_DEFINE(BX_HAVE_NANOSLEEP))
- AC_CHECK_FUNCS(abort, AC_DEFINE(BX_HAVE_ABORT))
--AC_CHECK_TYPE(socklen_t, AC_DEFINE(BX_HAVE_SOCKLEN_T), , [#include <sys/socket.h>])
--
-+AC_MSG_CHECKING(for socklen_t)
-+AC_TRY_COMPILE([#include <sys/types.h>
-+ #include <sys/socket.h>],
-+ [socklen_t x],
-+ [
-+ AC_DEFINE(BX_HAVE_SOCKLEN_T)
-+ AC_MSG_RESULT(yes)
-+ ],
-+ AC_MSG_RESULT(no)
-+ )
- AC_MSG_CHECKING(for struct timeval)
- AC_TRY_COMPILE([#include <sys/time.h>],
- [struct timeval x;],
diff --git a/emulators/bochs/files/patch-iodev::soundlnx.cc b/emulators/bochs/files/patch-iodev::soundlnx.cc
deleted file mode 100644
index 9b665724deb4..000000000000
--- a/emulators/bochs/files/patch-iodev::soundlnx.cc
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- iodev/soundlnx.cc 2001/05/30 22:19:00 1.1
-+++ iodev/soundlnx.cc 2001/05/30 22:19:34
-@@ -22,7 +22,7 @@
-
- // This file (SOUNDLNX.CC) written and donated by Josef Drexler
-
--#if defined(linux)
-+#if (defined(linux) || defined(__FreeBSD__))
-
- #include "bochs.h"
-
diff --git a/emulators/bochs/files/patch-iodev::soundlnx.h b/emulators/bochs/files/patch-iodev::soundlnx.h
deleted file mode 100644
index 148e5f6e0d53..000000000000
--- a/emulators/bochs/files/patch-iodev::soundlnx.h
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- iodev/soundlnx.h.orig Tue Apr 10 05:20:00 2001
-+++ iodev/soundlnx.h Thu May 31 01:07:43 2001
-@@ -23,7 +23,7 @@
- // This file (SOUNDLNX.H) written and donated by Josef Drexler
-
-
--#if defined(linux)
-+#if (defined(linux) || defined(__FreeBSD__))
-
- #include "bochs.h"
-