summaryrefslogtreecommitdiff
path: root/emulators/atari800/files
diff options
context:
space:
mode:
authorDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2001-06-12 01:33:38 +0000
committerDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2001-06-12 01:33:38 +0000
commit3a4c84a11179221f8e66d3519d359cd81985b780 (patch)
treead5948f1af0f7cc35e76666da30c2fc866b03a95 /emulators/atari800/files
parentNew maintainer, Pete Fritchman <petef@databits.net> (diff)
Removed unneeded files/patches
Updated to latest version - 1.07 Moved EXTRACT_ONLY down one Add url to website Add correct paths and make it follow PORTDOCS to pkg-plist PR: 28043 Submitted by: KATO Tsuguru <tkato@prontomail.com> Reviewed by: keichii
Diffstat (limited to 'emulators/atari800/files')
-rw-r--r--emulators/atari800/files/atari800.cfg4
-rw-r--r--emulators/atari800/files/patch-aa86
-rw-r--r--emulators/atari800/files/patch-ab29
-rw-r--r--emulators/atari800/files/patch-ac26
-rw-r--r--emulators/atari800/files/patch-ad19
-rw-r--r--emulators/atari800/files/patch-ae19
6 files changed, 37 insertions, 146 deletions
diff --git a/emulators/atari800/files/atari800.cfg b/emulators/atari800/files/atari800.cfg
index fb85692e7271..446241cc465a 100644
--- a/emulators/atari800/files/atari800.cfg
+++ b/emulators/atari800/files/atari800.cfg
@@ -1,4 +1,4 @@
-Atari 800 Emulator, Version 0.8.0
+Atari 800 Emulator
OS/A_ROM=
OS/B_ROM=GUMBY/atariosb.rom
XL/XE_ROM=GUMBY/atarixl.rom
@@ -16,5 +16,5 @@ DEFAULT_SYSTEM=Atari XL
DEFAULT_TV_MODE=PAL
HOLD_OPTION=0
ENABLE_C000_RAM=0
+ENABLE_ROM_PATCH=1
ENABLE_SIO_PATCH=1
-ENABLE_XCOLPF1=0
diff --git a/emulators/atari800/files/patch-aa b/emulators/atari800/files/patch-aa
index d10b78b80558..afce41daf337 100644
--- a/emulators/atari800/files/patch-aa
+++ b/emulators/atari800/files/patch-aa
@@ -1,60 +1,44 @@
---- Makefile.unix Sat Feb 21 10:39:13 1998
-+++ Makefile Wed Nov 8 01:54:54 2000
-@@ -4,14 +4,14 @@
- # if they cause a problem on your system.
- #
-
--CC = gcc
-+CC ?= gcc
- CPPFLAGS = $(OTHER)
--CFLAGS = -c -O6 -DGNU_C
--LD = gcc
-+CFLAGS += -c -DGNU_C
-+LD = $(CC)
- LDFLAGS =
- LDLIBS = -lm
+--- Makefile.unix.orig Wed Apr 4 07:35:36 2001
++++ Makefile.unix Wed May 23 23:29:50 2001
+@@ -1,11 +1,11 @@
+ # $Id: Makefile.unix,v 1.5 2001/04/04 05:35:36 knik Exp $
+
+-CC = gcc
++CC ?= gcc
+ EXE=
+-CFLAGS = -O2 -Wall
+-DEFS =
++CFLAGS ?= -O2 -Wall
++DEFS = -DDEFAULT_CFG_PATH=\\"\"${PREFIX}/share/atari800/atari800.cfg\\"\"
-PREFIX = /usr/local
-+PREFIX?= /usr/local
++PREFIX ?= /usr/local
BIN_PATH = ${PREFIX}/bin
LIB_PATH = ${PREFIX}/lib
MAN_PATH = ${PREFIX}/man
-@@ -195,16 +195,16 @@
- OBJ="atari_curses.o"
-
- freebsd-x11 :
-- make atari800 \
-- CPPFLAGS="-I/usr/X11R6/include" \
-- LDFLAGS="-L/usr/X11R6/lib" \
-+ $(MAKE) atari800 \
-+ CPPFLAGS="-I${X11BASE}/include" \
-+ LDFLAGS="-L${X11BASE}/lib" \
- LDLIBS="-lX11 -lm" \
- OBJ="atari_x11.o"
-
- freebsd-x11-shm :
-- make atari800 \
-- CPPFLAGS="-I/usr/X11R6/include -DSHM" \
-- LDFLAGS="-L/usr/X11R6/lib" \
-+ $(MAKE) atari800 \
-+ CPPFLAGS="-I${X11BASE}/include -DSHM" \
-+ LDFLAGS="-L${X11BASE}/lib" \
- LDLIBS="-lX11 -lXext -lm" \
- OBJ="atari_x11.o"
-
-@@ -246,7 +246,6 @@
- platform.h
-
- config config.h : configure
-- ./configure
-
- configure : configure.o prompts.o
- $(LD) $(LDFLAGS) configure.o prompts.o $(LDLIBS) -o configure
-@@ -348,5 +347,5 @@
- chmod 4755 ${BIN_PATH}/atari800
+@@ -72,13 +72,13 @@
+
+ x11:
+ $(MAKE) $(TARGET) DEFS="$(DEFS) -DX11" OBJ="$(OBJ) $(XOBJ)" \
+- INCLUDE="$(INCLUDE) -I/usr/X11R6/include" \
+- LIBS="-L/usr/X11/lib -L/usr/X11R6/lib $(LIBS) -lX11"
++ INCLUDE="$(INCLUDE) -I${X11BASE}/include" \
++ LIBS="-L${X11BASE}/lib $(LIBS) -lX11"
+
+ x11-shm:
+ $(MAKE) $(TARGET) DEFS="$(DEFS) -DX11 -DSHM" OBJ="$(OBJ) $(XOBJ)" \
+- INCLUDE="$(INCLUDE) -I/usr/X11R6/include" \
+- LIBS="-L/usr/X11/lib -L/usr/X11R6/lib $(LIBS) -lX11 -lXext"
++ INCLUDE="$(INCLUDE) -I${X11BASE}/include" \
++ LIBS="-L${X11BASE}/lib $(LIBS) -lX11 -lXext"
+
+ hp9000-ansic-x11:
+ $(MAKE) $(TARGET) \
+@@ -113,5 +113,5 @@
+ chmod 4755 ${BIN_PATH}/$(TARGET)
install :
-- cp atari800 ${BIN_PATH}/atari800
+- cp atari800 ${BIN_PATH}/$(TARGET)
- cp atari800.man ${MAN_PATH}/man1/atari800.1
-+ ${BSD_INSTALL_PROGRAM} atari800 ${BIN_PATH}/atari800
++ ${BSD_INSTALL_PROGRAM} atari800 ${BIN_PATH}/$(TARGET)
+ ${BSD_INSTALL_MAN} atari800.man ${MAN_PATH}/man1/atari800.1
diff --git a/emulators/atari800/files/patch-ab b/emulators/atari800/files/patch-ab
deleted file mode 100644
index 12b39bf31bdf..000000000000
--- a/emulators/atari800/files/patch-ab
+++ /dev/null
@@ -1,29 +0,0 @@
---- prompts.c.orig Thu Jun 18 20:20:15 1998
-+++ prompts.c Thu Jun 18 20:22:22 1998
-@@ -10,7 +10,7 @@
- char gash[128];
-
- printf(message, string);
-- gets(gash);
-+ fgets(gash,128,stdin);
- if (strlen(gash) > 0)
- strcpy(string, gash);
- }
-@@ -20,7 +20,7 @@
- char gash[128];
-
- printf(message, *num);
-- gets(gash);
-+ fgets(gash,128,stdin);
- if (strlen(gash) > 0)
- sscanf(gash, "\n%d", num);
- }
-@@ -32,7 +32,7 @@
-
- do {
- printf(message, *yn);
-- gets(gash);
-+ fgets(gash,128,stdin);
-
- if (strlen(gash) > 0)
- t_yn = gash[0];
diff --git a/emulators/atari800/files/patch-ac b/emulators/atari800/files/patch-ac
deleted file mode 100644
index e82785f41efc..000000000000
--- a/emulators/atari800/files/patch-ac
+++ /dev/null
@@ -1,26 +0,0 @@
---- monitor.c.orig Sun Feb 22 02:19:59 1998
-+++ monitor.c Thu Jun 18 21:05:50 1998
-@@ -94,10 +94,13 @@
-
- printf("> ");
- fflush(stdout);
-- if (gets(s) == NULL) {
-+ if (fgets(s,256,stdin) == NULL) {
- printf("\n> CONT\n");
- strcpy(s, "CONT");
- }
-+
-+ s[strlen(s)-1]='\0'; /* fgets provision */
-+
- t = get_token(s);
- if (t == NULL) {
- continue;
-@@ -179,7 +182,7 @@
- char gash[4];
-
- printf("Press return to continue: ");
-- gets(gash);
-+ fgets(gash,4,stdin);
- nlines = 0;
- }
- }
diff --git a/emulators/atari800/files/patch-ad b/emulators/atari800/files/patch-ad
deleted file mode 100644
index cc8d4527a87f..000000000000
--- a/emulators/atari800/files/patch-ad
+++ /dev/null
@@ -1,19 +0,0 @@
-*** sound.c.orig Thu Jun 18 21:57:09 1998
---- sound.c Thu Jun 18 21:57:30 1998
-***************
-*** 5,11 ****
- #ifdef VOXWARE
- #include <fcntl.h>
- #include <sys/ioctl.h>
-! #include <sys/soundcard.h>
-
- #include "pokey11.h"
-
---- 5,11 ----
- #ifdef VOXWARE
- #include <fcntl.h>
- #include <sys/ioctl.h>
-! #include <machine/soundcard.h>
-
- #include "pokey11.h"
-
diff --git a/emulators/atari800/files/patch-ae b/emulators/atari800/files/patch-ae
deleted file mode 100644
index 4b8301709ead..000000000000
--- a/emulators/atari800/files/patch-ae
+++ /dev/null
@@ -1,19 +0,0 @@
-*** rt-config.c.orig Wed Jul 1 19:55:57 1998
---- rt-config.c Wed Jul 1 19:56:17 1998
-***************
-*** 32,38 ****
- int enable_xcolpf1;
-
- static char *rtconfig_filename1 = "atari800.cfg";
-! static char *rtconfig_filename2 = "/etc/atari800.cfg";
-
- int RtConfigLoad(char *rtconfig_filename)
- {
---- 32,38 ----
- int enable_xcolpf1;
-
- static char *rtconfig_filename1 = "atari800.cfg";
-! static char *rtconfig_filename2 = "GUMBY/atari800.cfg";
-
- int RtConfigLoad(char *rtconfig_filename)
- {