summaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorGary Jennejohn <gj@FreeBSD.org>2000-09-23 19:27:31 +0000
committerGary Jennejohn <gj@FreeBSD.org>2000-09-23 19:27:31 +0000
commit3c87ed7cf6fbf4aeb9157e28c00663bde3fccd21 (patch)
tree1ba6a31ca90baae076280a276fb87eadea1feb92 /editors
parentSet INSTALLS_SHLIB (instead of calling ldconfig). (diff)
Specify --with-database=berkdb in the CONFIGURE_ARGS to avoid
confusion when databases/gdbm is installed. This change assures that the Berkeley db in libc is used. Since this is such a trivial change I also just went ahead and did it for xemacs21-mule also. PR: 21172 Submitted by: OGAWA Takaya
Diffstat (limited to 'editors')
-rw-r--r--editors/xemacs-devel/Makefile1
-rw-r--r--editors/xemacs/Makefile1
-rw-r--r--editors/xemacs21-mule/Makefile1
-rw-r--r--editors/xemacs21/Makefile1
4 files changed, 4 insertions, 0 deletions
diff --git a/editors/xemacs-devel/Makefile b/editors/xemacs-devel/Makefile
index 8751f283d086..c0d7b6c9199a 100644
--- a/editors/xemacs-devel/Makefile
+++ b/editors/xemacs-devel/Makefile
@@ -44,6 +44,7 @@ CONFIGURE_ARGS?=${XEMACS_ARCH} --prefix=${PREFIX} \
--with-png=yes \
--with-tiff=yes \
--with-site-lisp \
+ --with-database=berkdb \
${WITH_XFACE} ${WITH_DIALOGS} ${WITH_OFFIX}
MAKE_ARGS= prefix=${PREFIX}
.if !defined(MULE_SLAVE)
diff --git a/editors/xemacs/Makefile b/editors/xemacs/Makefile
index 8751f283d086..c0d7b6c9199a 100644
--- a/editors/xemacs/Makefile
+++ b/editors/xemacs/Makefile
@@ -44,6 +44,7 @@ CONFIGURE_ARGS?=${XEMACS_ARCH} --prefix=${PREFIX} \
--with-png=yes \
--with-tiff=yes \
--with-site-lisp \
+ --with-database=berkdb \
${WITH_XFACE} ${WITH_DIALOGS} ${WITH_OFFIX}
MAKE_ARGS= prefix=${PREFIX}
.if !defined(MULE_SLAVE)
diff --git a/editors/xemacs21-mule/Makefile b/editors/xemacs21-mule/Makefile
index bb8189d5445a..899658537995 100644
--- a/editors/xemacs21-mule/Makefile
+++ b/editors/xemacs21-mule/Makefile
@@ -60,6 +60,7 @@ CONFIGURE_ARGS?=${XEMACS_ARCH} \
--infopath=${PREFIX}/lib/xemacs/info:${PREFIX}/info:${X11BASE}/info:/usr/info:${PREFIX}/lib/texmf/doc/info:/usr/lib/texmf/doc:/usr/share/info \
--with-clash-detection \
--lockdir=/var/run/emacs/lock \
+ --with-database=berkdb \
${WITH_INPUT_METHOD}
MAKE_ENV= LANG=C
INSTALL_COOKIE= ${WRKDIR}/.install_done-${PKGNAME}
diff --git a/editors/xemacs21/Makefile b/editors/xemacs21/Makefile
index 8751f283d086..c0d7b6c9199a 100644
--- a/editors/xemacs21/Makefile
+++ b/editors/xemacs21/Makefile
@@ -44,6 +44,7 @@ CONFIGURE_ARGS?=${XEMACS_ARCH} --prefix=${PREFIX} \
--with-png=yes \
--with-tiff=yes \
--with-site-lisp \
+ --with-database=berkdb \
${WITH_XFACE} ${WITH_DIALOGS} ${WITH_OFFIX}
MAKE_ARGS= prefix=${PREFIX}
.if !defined(MULE_SLAVE)