summaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2002-01-08 01:24:11 +0000
committerWill Andrews <will@FreeBSD.org>2002-01-08 01:24:11 +0000
commitfccbfb4a6f4925aabb8269cc1567fb89ffbb5548 (patch)
treeca2c40b42219f6159e190f1d54a98c21f1cf914f /editors
parentUpdate to 0.2.2 (diff)
If !WANT_KDE_NDEBUG and !PARALLEL_PACKAGE_BUILDING, also add
--enable-debug and turn off stripping of binaries so we actually get all the debugging we're supposed to get. :) Submitted by: Alan Eldridge <alane@geeksrus.net>
Diffstat (limited to 'editors')
-rw-r--r--editors/calligra/Makefile3
-rw-r--r--editors/koffice-kde3/Makefile3
-rw-r--r--editors/koffice-kde4/Makefile3
-rw-r--r--editors/koffice/Makefile3
4 files changed, 12 insertions, 0 deletions
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index 3b6aeb773ff6..69f321887c99 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -30,6 +30,9 @@ CONFIGURE_ARGS+=--enable-final
.endif
.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
CONFIGURE_ARGS+=--disable-debug
+.else
+CONFIGURE_ARGS+=--enable-debug
+STRIP=''
.endif
USE_GMAKE= yes
diff --git a/editors/koffice-kde3/Makefile b/editors/koffice-kde3/Makefile
index 3b6aeb773ff6..69f321887c99 100644
--- a/editors/koffice-kde3/Makefile
+++ b/editors/koffice-kde3/Makefile
@@ -30,6 +30,9 @@ CONFIGURE_ARGS+=--enable-final
.endif
.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
CONFIGURE_ARGS+=--disable-debug
+.else
+CONFIGURE_ARGS+=--enable-debug
+STRIP=''
.endif
USE_GMAKE= yes
diff --git a/editors/koffice-kde4/Makefile b/editors/koffice-kde4/Makefile
index 3b6aeb773ff6..69f321887c99 100644
--- a/editors/koffice-kde4/Makefile
+++ b/editors/koffice-kde4/Makefile
@@ -30,6 +30,9 @@ CONFIGURE_ARGS+=--enable-final
.endif
.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
CONFIGURE_ARGS+=--disable-debug
+.else
+CONFIGURE_ARGS+=--enable-debug
+STRIP=''
.endif
USE_GMAKE= yes
diff --git a/editors/koffice/Makefile b/editors/koffice/Makefile
index 3b6aeb773ff6..69f321887c99 100644
--- a/editors/koffice/Makefile
+++ b/editors/koffice/Makefile
@@ -30,6 +30,9 @@ CONFIGURE_ARGS+=--enable-final
.endif
.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
CONFIGURE_ARGS+=--disable-debug
+.else
+CONFIGURE_ARGS+=--enable-debug
+STRIP=''
.endif
USE_GMAKE= yes