summaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorMartin Blapp <mbr@FreeBSD.org>2002-09-01 22:05:52 +0000
committerMartin Blapp <mbr@FreeBSD.org>2002-09-01 22:05:52 +0000
commit1a8d0bb1d5cb87f57e290e4b36cf8cbb914e740a (patch)
tree80d51017f4b8691f7bad78d486d534408566c015 /editors
parentUpdate to version 2002.09.01. (diff)
Works again with system compiler.
Diffstat (limited to 'editors')
-rw-r--r--editors/openoffice-1.0/Makefile14
-rw-r--r--editors/openoffice.org-1.0/Makefile14
-rw-r--r--editors/openoffice/Makefile14
3 files changed, 12 insertions, 30 deletions
diff --git a/editors/openoffice-1.0/Makefile b/editors/openoffice-1.0/Makefile
index 6f6fff2834a2..d892c463fef7 100644
--- a/editors/openoffice-1.0/Makefile
+++ b/editors/openoffice-1.0/Makefile
@@ -73,16 +73,10 @@ USE_GCC=3.1
#
# OO is still broken with the system gcc on CURRENT.
#
-.if !defined(USE_GCC)
-USE_GCC=3.1
-.endif
-.if defined(USE_GCC) && ${USE_GCC} == 3.1
-#
-# We depend on the port. System g++ is broken at the moment.
-#
-BUILD_DEPENDS+= gcc31:${PORTSDIR}/lang/gcc31
-CC= gcc31
-CXX= g++31
+.if defined(USE_GCC) && ${USE_GCC} == 3.2
+BUILD_DEPENDS+= gcc32:${PORTSDIR}/lang/gcc32
+CC= gcc32
+CXX= g++32
.endif
.endif
diff --git a/editors/openoffice.org-1.0/Makefile b/editors/openoffice.org-1.0/Makefile
index 6f6fff2834a2..d892c463fef7 100644
--- a/editors/openoffice.org-1.0/Makefile
+++ b/editors/openoffice.org-1.0/Makefile
@@ -73,16 +73,10 @@ USE_GCC=3.1
#
# OO is still broken with the system gcc on CURRENT.
#
-.if !defined(USE_GCC)
-USE_GCC=3.1
-.endif
-.if defined(USE_GCC) && ${USE_GCC} == 3.1
-#
-# We depend on the port. System g++ is broken at the moment.
-#
-BUILD_DEPENDS+= gcc31:${PORTSDIR}/lang/gcc31
-CC= gcc31
-CXX= g++31
+.if defined(USE_GCC) && ${USE_GCC} == 3.2
+BUILD_DEPENDS+= gcc32:${PORTSDIR}/lang/gcc32
+CC= gcc32
+CXX= g++32
.endif
.endif
diff --git a/editors/openoffice/Makefile b/editors/openoffice/Makefile
index 6f6fff2834a2..d892c463fef7 100644
--- a/editors/openoffice/Makefile
+++ b/editors/openoffice/Makefile
@@ -73,16 +73,10 @@ USE_GCC=3.1
#
# OO is still broken with the system gcc on CURRENT.
#
-.if !defined(USE_GCC)
-USE_GCC=3.1
-.endif
-.if defined(USE_GCC) && ${USE_GCC} == 3.1
-#
-# We depend on the port. System g++ is broken at the moment.
-#
-BUILD_DEPENDS+= gcc31:${PORTSDIR}/lang/gcc31
-CC= gcc31
-CXX= g++31
+.if defined(USE_GCC) && ${USE_GCC} == 3.2
+BUILD_DEPENDS+= gcc32:${PORTSDIR}/lang/gcc32
+CC= gcc32
+CXX= g++32
.endif
.endif