summaryrefslogtreecommitdiff
path: root/editors/openoffice-3-devel
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2012-09-27 02:48:53 +0000
committerMaho Nakata <maho@FreeBSD.org>2012-09-27 02:48:53 +0000
commit6c4fc737e4793dd6a79470a42760dc558fd0e4e5 (patch)
tree6a766757abcaf52fe0b7f479a7bcc5f5df1bbdc2 /editors/openoffice-3-devel
parent- Apply new Makefile format (diff)
Allowing openjdk7 build.
Diffstat (limited to 'editors/openoffice-3-devel')
-rw-r--r--editors/openoffice-3-devel/Makefile3
-rw-r--r--editors/openoffice-3-devel/files/patch-configure.in12
-rw-r--r--editors/openoffice-3-devel/files/patch-i12109813
-rw-r--r--editors/openoffice-3-devel/files/patch-jdk7-hsqldb-debian270
-rw-r--r--editors/openoffice-3-devel/files/patch-jdk7-hsqldb-debian-x12
-rw-r--r--editors/openoffice-3-devel/files/patch-sed16
6 files changed, 325 insertions, 1 deletions
diff --git a/editors/openoffice-3-devel/Makefile b/editors/openoffice-3-devel/Makefile
index 1762b6fb0232..93ab8c17d201 100644
--- a/editors/openoffice-3-devel/Makefile
+++ b/editors/openoffice-3-devel/Makefile
@@ -45,7 +45,7 @@ GNOMEVFS_DESC= Enable GNOME Virtual File System
USE_JAVA= yes
JAVA_BUILD= jdk
JAVA_VENDOR= freebsd bsdjava openjdk
-JAVA_VERSION= 1.5 1.6
+JAVA_VERSION= 1.5 1.6 1.7
.if !defined(WITHOUT_GCONF)
USE_GNOME+= gconf2
@@ -194,6 +194,7 @@ CONFIGURE_ARGS+= --enable-verbose \
--with-system-apr \
--with-system-apr-util \
--with-system-coinmp \
+ --with-system-apache-commons=yes \
--with-commons-codec-jar=${JAVALIBDIR}/commons-codec.jar \
--with-commons-lang-jar=${JAVALIBDIR}/commons-lang.jar \
--with-commons-httpclient-jar=${JAVALIBDIR}/commons-httpclient.jar \
diff --git a/editors/openoffice-3-devel/files/patch-configure.in b/editors/openoffice-3-devel/files/patch-configure.in
new file mode 100644
index 000000000000..8594ed9b1174
--- /dev/null
+++ b/editors/openoffice-3-devel/files/patch-configure.in
@@ -0,0 +1,12 @@
+--- configure.in~ 2012-09-21 20:42:22.000000000 +0900
++++ configure.in 2012-09-26 13:32:06.000000000 +0900
+@@ -52,6 +52,9 @@
+ AC_ARG_WITH(system-graphite,
+ [ --with-system-graphite use graphite library already installed on system
+ ],,)
++AC_ARG_WITH(system-apache-commons,
++[ --with-system-apache-commons use apache-commons jar files already installed on system
++],,)
+ AC_ARG_ENABLE(online-update,
+ [ --disable-online-update Disables the Online Update feature.
+ ],,enable_online_update=yes)
diff --git a/editors/openoffice-3-devel/files/patch-i121098 b/editors/openoffice-3-devel/files/patch-i121098
new file mode 100644
index 000000000000..0d2549229f82
--- /dev/null
+++ b/editors/openoffice-3-devel/files/patch-i121098
@@ -0,0 +1,13 @@
+Index: codemaker/source/javamaker/classfile.cxx
+===================================================================
+--- codemaker/source/javamaker/classfile.cxx (revision 1389908)
++++ codemaker/source/javamaker/classfile.cxx (working copy)
+@@ -695,7 +695,7 @@
+ void ClassFile::write(FileStream & file) const {
+ writeU4(file, 0xCAFEBABE);
+ writeU2(file, 0);
+- writeU2(file, 46);
++ writeU2(file, 49);
+ writeU2(file, m_constantPoolCount);
+ writeStream(file, m_constantPool);
+ writeU2(file, static_cast< sal_uInt16 >(m_accessFlags));
diff --git a/editors/openoffice-3-devel/files/patch-jdk7-hsqldb-debian b/editors/openoffice-3-devel/files/patch-jdk7-hsqldb-debian
new file mode 100644
index 000000000000..0f169774a37d
--- /dev/null
+++ b/editors/openoffice-3-devel/files/patch-jdk7-hsqldb-debian
@@ -0,0 +1,270 @@
+--- hsqldb/patches/jdbc-4.1.patch
++++ hsqldb/patches/jdbc-4.1.patch
+@@ -0,0 +1,267 @@
++--- misc/hsqldb/build/build.xml 2012-02-08 15:14:42.827123541 +0000
+++++ misc/build/hsqldb/build/build.xml 2012-02-08 15:21:43.827722388 +0000
++@@ -98,7 +98,11 @@
++ <echo message="ant.java.hasjsse=${ant.java.hasjsse}" />
++ </target>
++
++- <target name="javaversion6">
+++ <target name="javaversion7">
+++ <available classname="java.util.Objects" property="ant.java.iscjava17"/>
+++ </target>
+++
+++ <target name="javaversion6" depends="javaversion7" unless="ant.java.iscjava17">
++ <available classname="java.net.IDN" property="ant.java.iscjava16"/>
++ </target>
++
++@@ -210,6 +214,7 @@
++ <arg value="+JAVA2FULL"/>
++ <arg value="-JAVA4"/>
++ <arg value="-JAVA6"/>
+++ <arg value="-JAVA7"/>
++ </java>
++ </target>
++
++@@ -244,6 +249,7 @@
++ <arg value="+JAVA2FULL"/>
++ <arg value="+JAVA4"/>
++ <arg value="-JAVA6"/>
+++ <arg value="-JAVA7"/>
++ </java>
++ </target>
++
++@@ -279,10 +285,47 @@
++ <arg value="+JAVA2FULL"/>
++ <arg value="+JAVA4"/>
++ <arg value="+JAVA6"/>
+++ <arg value="+JAVA7"/>
+++ </java>
+++ </target>
+++
+++ <target name="switchtojdk17" depends="switchtojdk16"
+++ description="self explanatory" if="ant.java.iscjava17">
+++ <java classname="org.hsqldb.util.CodeSwitcher" classpath="classes" >
+++ <arg file="${src}/org/hsqldb/lib/java/JavaSystem.java"/>
+++ <arg file="${src}/org/hsqldb/lib/HsqlTimer.java"/>
+++ <arg file="${src}/org/hsqldb/jdbcDriver.java"/>
+++ <arg file="${src}/org/hsqldb/jdbc/jdbcBlob.java"/>
+++ <arg file="${src}/org/hsqldb/jdbc/jdbcDatabaseMetaData.java"/>
+++ <arg file="${src}/org/hsqldb/jdbc/jdbcDataSource.java"/>
+++ <arg file="${src}/org/hsqldb/jdbc/jdbcCallableStatement.java"/>
+++ <arg file="${src}/org/hsqldb/jdbc/jdbcClob.java"/>
+++ <arg file="${src}/org/hsqldb/jdbc/jdbcConnection.java"/>
+++ <arg file="${src}/org/hsqldb/jdbc/jdbcParameterMetaData.java"/>
+++ <arg file="${src}/org/hsqldb/jdbc/jdbcPreparedStatement.java"/>
+++ <arg file="${src}/org/hsqldb/jdbc/jdbcResultSet.java"/>
+++ <arg file="${src}/org/hsqldb/jdbc/jdbcResultSetMetaData.java"/>
+++ <arg file="${src}/org/hsqldb/jdbc/jdbcStatement.java"/>
+++ <arg file="${src}/org/hsqldb/persist/LockFile.java"/>
+++ <arg file="${src}/org/hsqldb/persist/Logger.java"/>
+++ <arg file="${src}/org/hsqldb/persist/ScaledRAFile.java"/>
+++ <arg file="${src}/org/hsqldb/rowio/RowInputTextLog.java"/>
+++ <arg file="${src}/org/hsqldb/util/DatabaseManager.java"/>
+++ <arg file="${src}/org/hsqldb/util/ConnectionDialogCommon.java"/>
+++ <arg file="${src}/org/hsqldb/lib/SimpleLog.java"/>
+++ <arg file="${src}/org/hsqldb/rowio/RowInputTextLog.java"/>
+++ <arg file="${src}/org/hsqldb/lib/SimpleLog.java"/>
+++ <arg file="${src}/org/hsqldb/rowio/RowInputTextLog.java"/>
+++ <arg file="${src}/org/hsqldb/HsqlDateTime.java"/>
+++ <arg value="+JAVA2"/>
+++ <arg value="+JAVA2FULL"/>
+++ <arg value="+JAVA4"/>
+++ <arg value="+JAVA6"/>
+++ <arg value="+JAVA7"/>
++ </java>
++ </target>
++
++- <target name="store" depends="switchtojdk16"
+++ <target name="store" depends="switchtojdk17"
++ description="compiles the /store folder">
++ <javac srcdir="${src}"
++ destdir="classes"
++--- misc/hsqldb/src/org/hsqldb/jdbc/jdbcCallableStatement.java 2012-02-08 15:14:42.802123563 +0000
+++++ misc/build/hsqldb/src/org/hsqldb/jdbc/jdbcCallableStatement.java 2012-02-08 15:47:35.842635642 +0000
++@@ -3375,4 +3375,18 @@
++ }
++
++ //#endif JAVA6
+++
+++//#ifdef JAVA7
+++ public <T> T getObject(String columnLabel, Class<T> type) throws SQLException
+++ {
+++ throw new UnsupportedOperationException("Not supported yet.");
+++ }
+++
+++ public <T> T getObject(int ColumnIndex, Class<T> type) throws SQLException
+++ {
+++ throw new UnsupportedOperationException("Not supported yet.");
+++ }
+++
+++
+++//#endif JAVA7
++ }
++--- misc/hsqldb/src/org/hsqldb/jdbc/jdbcConnection.java 2012-02-08 15:14:42.802123563 +0000
+++++ misc/build/hsqldb/src/org/hsqldb/jdbc/jdbcConnection.java 2012-02-08 15:47:35.851635628 +0000
++@@ -48,6 +48,12 @@
++ import java.sql.SQLXML;
++
++ //#endif JAVA6
+++
+++//#ifdef JAVA7
+++import java.util.concurrent.Executor;
+++
+++//#endif JAVA7
+++
++ import java.sql.PreparedStatement;
++ import java.sql.SQLException;
++ import java.sql.SQLWarning;
++@@ -2793,4 +2799,31 @@
++ }
++
++ //#endif JAVA6
+++
+++//#ifdef JAVA7
+++ public int getNetworkTimeout() throws SQLException
+++ {
+++ throw new UnsupportedOperationException("Not supported yet.");
+++ }
+++
+++ public void setNetworkTimeout(Executor executor, int millis) throws SQLException
+++ {
+++ throw new UnsupportedOperationException("Not supported yet.");
+++ }
+++
+++ public void abort(Executor executor) throws SQLException
+++ {
+++ throw new UnsupportedOperationException("Not supported yet.");
+++ }
+++
+++ public String getSchema() throws SQLException
+++ {
+++ throw new UnsupportedOperationException("Not supported yet.");
+++ }
+++
+++ public void setSchema(String schema) throws SQLException
+++ {
+++ throw new UnsupportedOperationException("Not supported yet.");
+++ }
+++//#endif JAVA7
++ }
++--- misc/hsqldb/src/org/hsqldb/jdbc/jdbcDatabaseMetaData.java 2012-02-08 15:14:42.802123563 +0000
+++++ misc/build/hsqldb/src/org/hsqldb/jdbc/jdbcDatabaseMetaData.java 2012-02-08 15:47:35.835635654 +0000
++@@ -5693,4 +5693,21 @@
++ }
++
++ //#endif JAVA6
+++
+++
+++//#ifdef JAVA7
+++ public boolean generatedKeyAlwaysReturned() throws SQLException
+++ {
+++ throw new UnsupportedOperationException("Not supported yet.");
+++ }
+++
+++ public ResultSet getPseudoColumns(String catalog, String schemaPattern,
+++ String tableNamePattern, String columnNamePattern) throws SQLException
+++ {
+++ throw new UnsupportedOperationException("Not supported yet.");
+++ }
+++
+++
+++//#endif JAVA7
+++
++ }
++--- misc/hsqldb/src/org/hsqldb/jdbc/jdbcDataSource.java 2012-02-08 15:14:42.802123563 +0000
+++++ misc/build/hsqldb/src/org/hsqldb/jdbc/jdbcDataSource.java 2012-02-08 15:47:35.836635653 +0000
++@@ -47,6 +47,11 @@
++ //#endif JAVA4
++ import org.hsqldb.jdbcDriver;
++
+++//#ifdef JAVA7
+++import java.sql.SQLFeatureNotSupportedException;
+++import java.util.logging.Logger;
+++//#endif JAVA7
+++
++ // boucherb@users 20040411 - doc 1.7.2 - javadoc updates toward 1.7.2 final
++
++ /**
++@@ -323,4 +328,12 @@
++ }
++
++ //#endif JAVA6
+++
+++//#ifdef JAVA7
+++ public Logger getParentLogger() throws SQLFeatureNotSupportedException
+++ {
+++ throw new SQLFeatureNotSupportedException("Not supported yet.");
+++ }
+++
+++//#endif JAVA7
++ }
++--- misc/hsqldb/src/org/hsqldb/jdbc/jdbcResultSet.java 2012-02-08 15:14:42.802123563 +0000
+++++ misc/build/hsqldb/src/org/hsqldb/jdbc/jdbcResultSet.java 2012-02-08 15:47:35.866635606 +0000
++@@ -5324,4 +5324,19 @@
++ }
++
++ //#endif JAVA6
+++
+++//#ifdef JAVA7
+++
+++ public <T> T getObject(String columnLabel, Class<T> type) throws SQLException
+++ {
+++ throw new UnsupportedOperationException("Not supported yet.");
+++ }
+++
+++ public <T> T getObject(int columnNum, Class<T> type) throws SQLException
+++ {
+++ throw new UnsupportedOperationException("Not supported yet.");
+++ }
+++
+++//#endif JAVA7
+++
++ }
++--- misc/hsqldb/src/org/hsqldb/jdbc/jdbcStatement.java 2012-02-08 15:14:42.802123563 +0000
+++++ misc/build/hsqldb/src/org/hsqldb/jdbc/jdbcStatement.java 2012-02-08 15:47:35.872635595 +0000
++@@ -1608,4 +1608,16 @@
++ throw new UnsupportedOperationException("Not supported yet.");
++ }
++ //#endif JAVA6
+++
+++//#ifdef JAVA7
+++ public boolean isCloseOnCompletion() throws SQLException
+++ {
+++ throw new UnsupportedOperationException("Not supported yet.");
+++ }
+++
+++ public void closeOnCompletion() throws SQLException
+++ {
+++ throw new UnsupportedOperationException("Not supported yet.");
+++ }
+++//#endif JAVA7
++ }
++--- misc/hsqldb/src/org/hsqldb/jdbcDriver.java 2012-02-08 15:14:42.800123566 +0000
+++++ misc/build/hsqldb/src/org/hsqldb/jdbcDriver.java 2012-02-08 15:47:35.826635667 +0000
++@@ -42,6 +42,11 @@
++ import org.hsqldb.persist.HsqlDatabaseProperties;
++ import org.hsqldb.persist.HsqlProperties;
++
+++//#ifdef JAVA7
+++import java.sql.SQLFeatureNotSupportedException;
+++import java.util.logging.Logger;
+++//#endif JAVA7
+++
++ // fredt@users 20011220 - patch 1.7.0 by fredt
++ // new version numbering scheme
++ // fredt@users 20020320 - patch 1.7.0 - JDBC 2 support and error trapping
++@@ -321,4 +326,12 @@
++ DriverManager.registerDriver(new jdbcDriver());
++ } catch (Exception e) {}
++ }
+++
+++//#ifdef JAVA7
+++ public Logger getParentLogger() throws SQLFeatureNotSupportedException
+++ {
+++ throw new SQLFeatureNotSupportedException("Not supported yet.");
+++ }
+++
+++//#endif JAVA7
++ }
diff --git a/editors/openoffice-3-devel/files/patch-jdk7-hsqldb-debian-x b/editors/openoffice-3-devel/files/patch-jdk7-hsqldb-debian-x
new file mode 100644
index 000000000000..0b3ead629058
--- /dev/null
+++ b/editors/openoffice-3-devel/files/patch-jdk7-hsqldb-debian-x
@@ -0,0 +1,12 @@
+--- hsqldb/makefile.mk.orig 2012-02-17 08:46:16.000000000 +0000
++++ hsqldb/makefile.mk 2012-09-15 18:00:27.000000000 +0000
+@@ -52,7 +52,8 @@
+ PATCH_FILES=patches$/i96823.patch \
+ patches$/i97032.patch \
+ patches$/i103528.patch \
+- patches$/i104901.patch
++ patches$/i104901.patch \
++ patches$/jdbc-4.1.patch
+
+ .IF "$(JAVACISGCJ)"=="yes"
+ JAVA_HOME=
diff --git a/editors/openoffice-3-devel/files/patch-sed b/editors/openoffice-3-devel/files/patch-sed
new file mode 100644
index 000000000000..0907725277fe
--- /dev/null
+++ b/editors/openoffice-3-devel/files/patch-sed
@@ -0,0 +1,16 @@
+--- swext/mediawiki/makefile.mk 2012-09-21 20:36:58.000000000 +0900
++++ swext/mediawiki/makefile.mk 2012-09-26 16:36:38.000000000 +0900
+@@ -50,10 +50,10 @@
+
+ fix_system_commons:
+ @echo "Fix Java Class-Path entry for Apache Commons libraries from system."
+- @$(SED) -r -e "s#(name=\"Class-Path\" value=\").*\"#\1file://$(COMMONS_CODEC_JAR) file://$(COMMONS_LANG_JAR) \
+-file://$(COMMONS_HTTPCLIENT_JAR) file://$(COMMONS_LOGGING_JAR)\"#" -i build.xml
++ @$(SED) -i.bak -r -e "s#(name=\"Class-Path\" value=\").*\"#\1file://$(COMMONS_CODEC_JAR) file://$(COMMONS_LANG_JAR) \
++file://$(COMMONS_HTTPCLIENT_JAR) file://$(COMMONS_LOGGING_JAR)\"#" build.xml
+ @echo "Unbundle Apache Commons libraries from Mediawiki Presentation extension."
+- @$(SED) '/file="..commons/d' -i build.xml
++ @$(SED) -i.bak '/file="..commons/d' build.xml
+
+ .ELSE
+ @all: