summaryrefslogtreecommitdiff
path: root/editors/fpc-ide/Makefile
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-07-24 11:21:27 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-07-24 11:21:27 +0000
commit995ae8b1bdfe5e9d356eae060097bee70cbccbc8 (patch)
tree716cad45f74530d35aed61fcde093f63ed88f722 /editors/fpc-ide/Makefile
parentNew port: lang/fpc-utils (diff)
- The big change on ports of freepascal, now all ports are compiled
- Adding entry for lang/fpc-utils Approved by: garga (mentor)
Diffstat (limited to 'editors/fpc-ide/Makefile')
-rw-r--r--editors/fpc-ide/Makefile23
1 files changed, 21 insertions, 2 deletions
diff --git a/editors/fpc-ide/Makefile b/editors/fpc-ide/Makefile
index ec6fafe50b52..b0aa86767269 100644
--- a/editors/fpc-ide/Makefile
+++ b/editors/fpc-ide/Makefile
@@ -8,13 +8,32 @@
CATEGORIES= editors lang
PKGNAMESUFFIX= -ide
-MAINTAINER= acardenas@bsd.org.pe
+MAINTAINER= acm@FreeBSD.org
COMMENT= Free Pascal integrated IDE/compiler
-RUN_DEPENDS= ${UNITSDIR}/fv/Package.fpc:${PORTSDIR}/devel/fpc-fv
+BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc \
+ fpcmake:${PORTSDIR}/lang/fpc-utils \
+ ${UNITSDIR}/gdbint/Package.fpc:${PORTSDIR}/devel/fpc-gdbint \
+ ${UNITSDIR}/ibase/Package.fpc:${PORTSDIR}/databases/fpc-ibase \
+ ${UNITSDIR}/libasync/Package.fpc:${PORTSDIR}/net/fpc-libasync \
+ ${UNITSDIR}/md5/Package.fpc:${PORTSDIR}/security/fpc-md5 \
+ ${UNITSDIR}/mysql/Package.fpc:${PORTSDIR}/databases/fpc-mysql \
+ ${UNITSDIR}/netdb/Package.fpc:${PORTSDIR}/net/fpc-netdb \
+ ${UNITSDIR}/odbc/Package.fpc:${PORTSDIR}/databases/fpc-odbc \
+ ${UNITSDIR}/oracle/Package.fpc:${PORTSDIR}/databases/fpc-oracle \
+ ${UNITSDIR}/pasjpeg/Package.fpc:${PORTSDIR}/graphics/fpc-pasjpeg \
+ ${UNITSDIR}/paszlib/Package.fpc:${PORTSDIR}/archivers/fpc-paszlib \
+ ${UNITSDIR}/pthreads/Package.fpc:${PORTSDIR}/devel/fpc-pthreads \
+ ${UNITSDIR}/postgres/Package.fpc:${PORTSDIR}/databases/fpc-postgres \
+ ${UNITSDIR}/regexpr/Package.fpc:${PORTSDIR}/devel/fpc-regexpr \
+ ${UNITSDIR}/sqlite/Package.fpc:${PORTSDIR}/databases/fpc-sqlite \
+ ${UNITSDIR}/fcl/Package.fpc:${PORTSDIR}/devel/fpc-fcl \
+ ${UNITSDIR}/fv/Package.fpc:${PORTSDIR}/devel/fpc-fv
UNITSDIR= ${LOCALBASE}/lib/fpc/${PORTVERSION}/units/${BUILDNAME}
UNITPREFIX= # none
MASTERDIR= ${.CURDIR}/../../lang/fpc
+WRKUNITDIR= ${PORTNAME}/${PKGNAMESUFFIX:S/-//}
+EXTRACTUNITDIR+= ${WRKUNITDIR} ${PORTNAME}/compiler ${PORTNAME}/rtl ${PORTNAME}/fv
.include "${MASTERDIR}/Makefile"