summaryrefslogtreecommitdiff
path: root/editors/emacs21/files
diff options
context:
space:
mode:
authorShigeyuki Fukushima <shige@FreeBSD.org>2001-10-23 16:36:02 +0000
committerShigeyuki Fukushima <shige@FreeBSD.org>2001-10-23 16:36:02 +0000
commitb1acfd0dd89af033176adbc21ad37e257fa3824f (patch)
treedccd9a9f421a1791738064402aa9088a5b25a3b5 /editors/emacs21/files
parentAdd ruby-graph, graph-related Ruby classes. (diff)
New port for emacs-21.1.
Diffstat (limited to 'editors/emacs21/files')
-rw-r--r--editors/emacs21/files/patch-configure.in34
-rw-r--r--editors/emacs21/files/patch-lib-src:Makefile.in27
-rw-r--r--editors/emacs21/files/patch-man:Makefile.in11
3 files changed, 72 insertions, 0 deletions
diff --git a/editors/emacs21/files/patch-configure.in b/editors/emacs21/files/patch-configure.in
new file mode 100644
index 000000000000..3362fe0736b6
--- /dev/null
+++ b/editors/emacs21/files/patch-configure.in
@@ -0,0 +1,34 @@
+--- configure.in.orig Fri Oct 19 23:09:18 2001
++++ configure.in Mon Oct 22 21:19:32 2001
+@@ -179,6 +179,15 @@
+ machine='' opsys='' unported=no
+ case "${canonical}" in
+
++ ## FreeBSD ports
++ *-*-freebsd* )
++ opsys=freebsd
++ case "${canonical}" in
++ alpha*-*-freebsd*) machine=alpha ;;
++ i[3456]86-*-freebsd*) machine=intel386 ;;
++ esac
++ ;;
++
+ ## NetBSD ports
+ *-*-netbsd* )
+ opsys=netbsd
+@@ -1017,7 +1026,6 @@
+ ;;
+ *-sysv4.2uw* ) opsys=unixware; NON_GNU_CPP=/lib/cpp ;;
+ *-386bsd* ) opsys=386bsd ;;
+- *-freebsd* ) opsys=freebsd ;;
+ *-nextstep* ) opsys=nextstep ;;
+ ## Otherwise, we'll fall through to the generic opsys code at the bottom.
+ esac
+@@ -2007,6 +2015,7 @@
+ # Solaris requires -lintl if you want strerror (which calls dgettext)
+ # to return localized messages.
+ AC_CHECK_LIB(intl, dgettext)
++AC_CHECK_LIB(xpg4, _xpg4_setrunelocale)
+
+ AC_MSG_CHECKING(whether localtime caches TZ)
+ AC_CACHE_VAL(emacs_cv_localtime_cache,
diff --git a/editors/emacs21/files/patch-lib-src:Makefile.in b/editors/emacs21/files/patch-lib-src:Makefile.in
new file mode 100644
index 000000000000..4226f59f9f96
--- /dev/null
+++ b/editors/emacs21/files/patch-lib-src:Makefile.in
@@ -0,0 +1,27 @@
+--- lib-src/Makefile.in.orig Wed Aug 30 02:12:42 2000
++++ lib-src/Makefile.in Thu Oct 11 01:54:10 2001
+@@ -85,6 +85,7 @@
+ INSTALL = @INSTALL@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+ INSTALL_DATA = @INSTALL_DATA@
++INSTALL_SCRIPT = @INSTALL_SCRIPT@
+ # By default, we uphold the dignity of our programs.
+ INSTALL_STRIP =
+
+@@ -278,7 +279,7 @@
+ if [ `(cd ${archlibdir} && /bin/pwd)` \
+ != `(cd ${srcdir} && /bin/pwd)` ]; then \
+ for file in ${SCRIPTS}; do \
+- $(INSTALL_PROGRAM) ${srcdir}/$$file ${archlibdir}/$$file; \
++ $(INSTALL_SCRIPT) ${srcdir}/$$file ${archlibdir}/$$file; \
+ done ; \
+ fi
+
+@@ -290,7 +291,7 @@
+ chmod a+rx ${bindir}/$${file}; \
+ done
+ for file in ${INSTALLABLE_SCRIPTS} ; do \
+- $(INSTALL_PROGRAM) ${srcdir}/$${file} ${bindir}/$${file} ; \
++ $(INSTALL_SCRIPT) ${srcdir}/$${file} ${bindir}/$${file} ; \
+ chmod a+rx ${bindir}/$${file}; \
+ done
diff --git a/editors/emacs21/files/patch-man:Makefile.in b/editors/emacs21/files/patch-man:Makefile.in
new file mode 100644
index 000000000000..23e59c2673f6
--- /dev/null
+++ b/editors/emacs21/files/patch-man:Makefile.in
@@ -0,0 +1,11 @@
+--- man/Makefile.in.orig Thu Apr 26 02:17:33 2001
++++ man/Makefile.in Mon Oct 22 20:43:45 2001
+@@ -31,7 +31,7 @@
+
+
+ # The makeinfo program is part of the Texinfo distribution.
+-MAKEINFO = makeinfo
++MAKEINFO = makeinfo --no-split
+ INFO_TARGETS = ../info/emacs ../info/ccmode ../info/cl \
+ ../info/dired-x ../info/ediff ../info/forms ../info/gnus \
+ ../info/info ../info/message ../info/mh-e ../info/reftex \