summaryrefslogtreecommitdiff
path: root/editors/bitmap-emacs20/Makefile
diff options
context:
space:
mode:
authorShigeyuki Fukushima <shige@FreeBSD.org>2001-12-11 13:42:09 +0000
committerShigeyuki Fukushima <shige@FreeBSD.org>2001-12-11 13:42:09 +0000
commitffb8c4d93977f46873865934d3c1c42a3b97feac (patch)
tree77fdeb01220f43099bb7933891928dbfba282278 /editors/bitmap-emacs20/Makefile
parentBump PORTREVISION for this recent change: (diff)
Update to 8.4.p200109201221.
Apply new master/slave scheme. Update master port (editors/bitmap) for emacs21. Update slave ports (editors/bitmap-mule and editors/bitmap-emacs20) to stub ports. Install el/elc files to version specific site-lisp directory. Change some style.
Diffstat (limited to 'editors/bitmap-emacs20/Makefile')
-rw-r--r--editors/bitmap-emacs20/Makefile55
1 files changed, 5 insertions, 50 deletions
diff --git a/editors/bitmap-emacs20/Makefile b/editors/bitmap-emacs20/Makefile
index e2234ddc6754..01b1ed13b876 100644
--- a/editors/bitmap-emacs20/Makefile
+++ b/editors/bitmap-emacs20/Makefile
@@ -5,59 +5,14 @@
# $FreeBSD$
#
-PORTNAME= bitmap
-PORTVERSION= ${BITMAP_VER}
-CATEGORIES= editors elisp
-MASTER_SITES= ftp://ftp.jpl.org/pub/elisp/bitmap/ \
- ftp://ftp.jpl.org/pub/elisp/bitmap/snapshots/
-DISTNAME= bitmap-mule-${BITMAP_DISTVER}
-PKGNAMESUFFIX= -${EMACS_PORT_NAME}
-
MAINTAINER= shige@FreeBSD.org
-# ports version
-BITMAP_VER= ${BITMAP_MVER}${BITMAP_SNAP_PREFIX}${BITMAP_SNAP}
-# distfile version
-BITMAP_MVER= 8.4
-BITMAP_DISTVER= ${BITMAP_MVER}
-# variables for snapshots version
-BITMAP_SNAP_PREFIX= .p
-BITMAP_SNAP= 200102280240
-BITMAP_DISTVER= ${BITMAP_SNAP}
+# This is a slave port.
+PORTCLASS= slave
-BITMAPDOCDIR= share/doc/bitmap
-BITMAP_FONT= ${X11BASE}/lib/X11/fonts/local/bitmap16.pcf.gz
+MASTERDIR= ${.CURDIR}/../../editors/bitmap
-# emacs20
+# Setup EMACS_PORT_NAME variable.
EMACS_PORT_NAME= emacs20
-# target name for make build
-ALL_TARGET= elc
-
-BUILD_DEPENDS= uncompface:${PORTSDIR}/mail/faces
-RUN_DEPENDS= ${BITMAP_FONT}:${PORTSDIR}/x11-fonts/bitmap-fonts
-PLIST_SUB= BITMAPDOCDIR=${BITMAPDOCDIR}
-
-.include <bsd.port.pre.mk>
-
-.if defined(EMACS_PORT_NAME)
-# depends on apel
-BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_LIBDIR}/${EMACS_VER}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
-RUN_DEPENDS+= ${LOCALBASE}/${EMACS_LIBDIR}/${EMACS_VER}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
-.else
-.BEGIN:
- @${ECHO} "Error: Bad port."
- @${ECHO} "You must define EMACS_PORT_NAME."
- @${FALSE}
-.endif
-
-post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${LOCALBASE}/${BITMAPDOCDIR}
- @(cd ${WRKSRC} ; \
- for i in ChangeLog NEWS README.* ; do \
- ${INSTALL_DATA} ${WRKSRC}/$${i} ${LOCALBASE}/${BITMAPDOCDIR}/ ; \
- done)
-.endif
-
-.include <bsd.port.post.mk>
+.include <${MASTERDIR}/Makefile>