summaryrefslogtreecommitdiff
path: root/dns/posadis/Makefile
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2003-10-14 14:39:55 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2003-10-14 14:39:55 +0000
commit942c5b1b4c7e0b88a06d90f31004aef45c53aca6 (patch)
tree5b6e33e4f1b5406fc5dafc32db9f597cd6d17230 /dns/posadis/Makefile
parentAdd p5-Net-Nslookup 1.14 (diff)
- Add dependency on devel/libltdl forgotten by ade
- Do not explicitly add --disable-ltdl-install to CONFIGURE_ARGS as configure DTRT now - Add optional dependency on devel/fam - Sort pkg-plist - Bump PORTREVISION Submitted by: Sergei Kolobov <sergei@kolobov.com> (maintainer) PR: 58005
Diffstat (limited to 'dns/posadis/Makefile')
-rw-r--r--dns/posadis/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/dns/posadis/Makefile b/dns/posadis/Makefile
index be59e34ea694..252069223771 100644
--- a/dns/posadis/Makefile
+++ b/dns/posadis/Makefile
@@ -7,7 +7,7 @@
PORTNAME= posadis
PORTVERSION= 0.60.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= dns
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,15 +15,25 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= sergei@kolobov.com
COMMENT= "Domain Name Server (DNS) implementation"
-LIB_DEPENDS= poslib.0:${PORTSDIR}/devel/poslib
+LIB_DEPENDS= poslib.0:${PORTSDIR}/devel/poslib \
+ ltdl.4:${PORTSDIR}/devel/libltdl
+
+.if defined(WITH_FAM) || exists(${LOCALBASE}/lib/libfam.so)
+CONFIGURE_ARGS= --enable-fam
+BUILD_DEPENDS= ${LOCALBASE}/include/fam.h:${PORTSDIR}/devel/fam
+RUN_DEPENDS= ${LOCALBASE}/bin/fam:${PORTSDIR}/devel/fam
+PLIST_SUB= FAM=""
+.else
+CONFIGURE_ARGS= --disable-fam
+PLIST_SUB= FAM="@comment "
+.endif
USE_LIBTOOL= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --disable-ltdl-install
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
INSTALLS_SHLIB= yes
-PLIST_SUB= VERSION="${PORTVERSION}"
+PLIST_SUB+= VERSION="${PORTVERSION}"
MAN1= getzone.1 posadis.1 posadis-getroots.1 posask.1 poshost.1
MAN5= posadisrc.5