summaryrefslogtreecommitdiff
path: root/dns/posadis/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-10-09 12:29:20 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-10-09 12:29:20 +0000
commit005437f6beb0155e09d012c8973526a81236f26b (patch)
treeb14a006856658d4157ca37051c2611096213d362 /dns/posadis/Makefile
parent Fix building of suexec with Russian and SLL patches. (diff)
- Update to 0.60.1
- Add missing dependency on poslib PR: 57719 Submitted by: maintainer
Diffstat (limited to 'dns/posadis/Makefile')
-rw-r--r--dns/posadis/Makefile21
1 files changed, 11 insertions, 10 deletions
diff --git a/dns/posadis/Makefile b/dns/posadis/Makefile
index 9e74c3c89e21..7da3da2244db 100644
--- a/dns/posadis/Makefile
+++ b/dns/posadis/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= posadis
-PORTVERSION= 0.50.9
+PORTVERSION= 0.60.1
CATEGORIES= dns
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,22 +14,23 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= sergei@kolobov.com
COMMENT= "Domain Name Server (DNS) implementation"
+LIB_DEPENDS= poslib.0:${PORTSDIR}/devel/poslib
+
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-cxxflags="${CXXFLAGS}" --disable-gtk
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
-MAN1= posadis.1 posctl.1 posask.1
-MAN5= posadis.conf.5 posadis-domains.conf.5
-DOCS= AUTHORS ChangeLog NEWS README TODO
+PLIST_SUB= VERSION="${PORTVERSION}"
-post-patch:
- ${RM} -f ${WRKSRC}/doc/posadis.info*
+MAN1= getzone.1 posadis.1 posadis-getroots.1 posask.1 poshost.1
+MAN5= posadisrc.5
+DOCS= AUTHORS ChangeLog README TODO
.if !defined(NOPORTDOCS)
post-install:
@${MKDIR} ${DOCSDIR}
-.for file in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
-.endfor
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
.include <bsd.port.mk>