summaryrefslogtreecommitdiff
path: root/dns/bind9-dlz/files
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2002-11-17 21:43:13 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2002-11-17 21:43:13 +0000
commit46ff8a6c07b15cef4a6da15f10604d6ff779c96c (patch)
tree0b04eb2354b47d979ffdde012412ed901a6ae02f /dns/bind9-dlz/files
parentadd leo because addport barfed on itself (diff)
- Update to 0.3.0
- MySQL and filesystem driver added - interactive driver select ability - use MASTER_SITE_ISC - more reorganize to make portlint happy not added: - SED -> REINPLACE_CMD does break on 4.6 stable, bad version in bsd.port.mk - change version number to satisfy portlint stay consistent with mod_php and a other combined versions - remove file files/dlz_postgres_driver.c.diff still needed, to make gcc happy. Extensions my Maintainter: - Support for openSSL for all Versions - Allow BINDDLZ_OPTIONS in /etc/make.conf - MySQL not default, conflicts with threads. - moved configure.bind9-dlz to files, avoiding extra directory. PR: 45332 Submitted by: sem@ciam.ru
Diffstat (limited to 'dns/bind9-dlz/files')
-rw-r--r--dns/bind9-dlz/files/configure.bind9-dlz74
1 files changed, 74 insertions, 0 deletions
diff --git a/dns/bind9-dlz/files/configure.bind9-dlz b/dns/bind9-dlz/files/configure.bind9-dlz
new file mode 100644
index 000000000000..cf6e0b06b488
--- /dev/null
+++ b/dns/bind9-dlz/files/configure.bind9-dlz
@@ -0,0 +1,74 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
+ exit
+fi
+
+if [ "${BATCH}" -o "${BINDDLZ_OPTIONS}" ]; then
+ if [ "${BINDDLZ_OPTIONS}" ]; then
+ set ${BINDDLZ_OPTIONS}
+ else
+ set \"OpenSSL\" \"PostgreSQL\" \"FileSystem\"
+ fi
+else
+ dialog --title "configuration options" --clear \
+ --checklist "\n\
+Please select desired options:" -1 -1 5 \
+OpenSSL "OpenSSL support" ON \
+PostgreSQL "PostgreSQL driver" ON \
+MySQL "MySQL driver" OFF \
+FileSystem "Filesystem driver" OFF \
+Stub "Stub driver" OFF \
+2> /tmp/checklist.tmp.$$
+
+ retval=$?
+ if [ -s /tmp/checklist.tmp.$$ ]; then
+ set `cat /tmp/checklist.tmp.$$`
+ fi
+ rm -f /tmp/checklist.tmp.$$
+
+ case $retval in
+ 0) if [ -z "$*" ]; then
+ echo "Nothing selected"
+ fi
+ ;;
+ 1) echo "Cancel pressed."
+ exit 1
+ ;;
+ esac
+fi
+
+${MKDIR} ${WRKDIRPREFIX}${CURDIR}
+exec > ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
+
+while [ "$1" ]; do
+ case $1 in
+ \"OpenSSL\")
+ echo WITH_OPENSSL=YES
+ ;;
+ \"PostgreSQL\")
+ echo WITH_POSTGRESQL_DRIVER=YES
+ WITH_POSTGRESQL_DRIVER=1
+ ;;
+ \"MySQL\")
+ echo WITH_MYSQL_DRIVER=YES
+ ;;
+ \"FileSystem\")
+ echo WITH_FILESYSTEM_DRIVER=YES
+ ;;
+ \"Stub\")
+ echo WITH_STUB_DRIVER=YES
+ ;;
+ \"nothing\"|true)
+ ;;
+ *)
+ echo "Invalid option(s): $*" > /dev/stderr
+ rm -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
+ exit 1
+ ;;
+ esac
+ shift
+done
+exec > /dev/stderr