summaryrefslogtreecommitdiff
path: root/dns/Makefile
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2004-11-19 14:11:10 +0000
committerHerve Quiroz <hq@FreeBSD.org>2004-11-19 14:11:10 +0000
commit578714486767646ae5fbc76cac14d3d8e4a080a5 (patch)
treecaf78bbe721e8460105a68eb76a2f0374f7ddd04 /dns/Makefile
parentAdd devel/p5-Commands-Guarded 0.01, deterministic guarded commands fro (diff)
dnsjava is an implementation of DNS in Java. It supports all defined record
types (including the DNSSEC types), and unknown types. It can be used for queries, zone transfers, and dynamic updates. It includes a cache which can be used by clients, and a minimal implementation of a server. It supports TSIG authenticated messages, partial DNSSEC verification, and EDNS0. dnsjava provides functionality above and beyond that of the InetAddress class. Since it is written in pure Java, dnsjava is fully threadable, and in many cases is faster than using InetAddress. dnsjava provides both high and low level access to DNS. The high level functions perform queries for records of a given name, type, and class, and return an array of records. There is also a clone of InetAddress, which is even simpler. A cache is used to reduce the number of DNS queries sent. The low level functions allow direct manipulation of DNS messages and records, as well as allowing additional resolver properties to be set. WWW: http://www.xbill.org/dnsjava/
Diffstat (limited to 'dns/Makefile')
-rw-r--r--dns/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 14ae543e0046..b7ffea659022 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -22,6 +22,7 @@
SUBDIR += dnsdoctor
SUBDIR += dnsflood
SUBDIR += dnshijacker
+ SUBDIR += dnsjava
SUBDIR += dnsmasq
SUBDIR += dnsproxy
SUBDIR += dnssecwalker